Home » Applications » Oracle Fusion Apps & E-Business Suite » Forms behaves strange (Oracle11i,windows)
Forms behaves strange [message #522805] Wed, 14 September 2011 01:10 Go to next message
fayas
Messages: 23
Registered: August 2011
Location: bangalore
Junior Member
Hi all,
I have developed a new for form in 6i and deployed in front end 11i.It is Query find window.the functionality of the form is that we search for an order number in the first screen and press button(search button).Then in the next screen it pulls headers information(deal number,currecy code, org_id etc) for the order number and also line level adjustments.In the second screen line level adjustments comes from diffirent table and header info order from other table..
Now, the problem when search for the order number..It pulls information for some orders number and for some other order number its not pulling data it shows blank screen,even though the orders has data in the back end..
I have attached the screen of the form for better understanding.
Please refer to the attachment for better understanding
Please help me to solve this issue..
please reply ASAP

Thanks in advance,
fayaz

  • Attachment: Forms.pdf
    (Size: 173.42KB, Downloaded 233 times)
Re: Forms behaves strange [message #522806 is a reply to message #522805] Wed, 14 September 2011 01:14 Go to previous messageGo to next message
Littlefoot
Messages: 19882
Registered: June 2005
Location: Croatia, Europe
Senior Member
Account Moderator
What does the "search" button do? How exactly do you retrieve data?
Re: Forms behaves strange [message #522808 is a reply to message #522806] Wed, 14 September 2011 01:19 Go to previous messageGo to next message
fayas
Messages: 23
Registered: August 2011
Location: bangalore
Junior Member
i have used a when button pressed trigger

IF :SO_QF.ORDER_NUMBER IS NULL
THEN
MESSAGE('No results rendered when invalid SO Number searched ');
MESSAGE('No results rendered when invalid SO Number searched ');
RAISE FORM_TRIGGER_FAILURE;
else
:parameter.G_query_find := 'TRUE';
app_find.find('EMCINT_ORD_HEADERS_ALL');
:parameter.G_query_find := 'FALSE';

END if;
Re: Forms behaves strange [message #522810 is a reply to message #522808] Wed, 14 September 2011 01:20 Go to previous messageGo to next message
fayas
Messages: 23
Registered: August 2011
Location: bangalore
Junior Member
i use a query find trigger..which copys the order number entered in the first screen.
then it uses the query find trigger to pull data
Re: Forms behaves strange [message #522811 is a reply to message #522810] Wed, 14 September 2011 01:22 Go to previous message
fayas
Messages: 23
Registered: August 2011
Location: bangalore
Junior Member
Specfically i have not used any query to pull data for seacrh button ..
Previous Topic: How to calculate YTD credit amount and YTD Debit amount
Next Topic: Open Material Transaction Interface
Goto Forum:
  


Current Time: Thu Dec 18 03:13:00 CST 2014

Total time taken to generate the page: 0.13388 seconds