Home » Developer & Programmer » Reports & Discoverer » Location of .bmp of image in report (Oracle Reports Developer 10.1.2.0.2, Unix, 10 G database)
Location of .bmp of image in report [message #516024] Thu, 14 July 2011 11:37 Go to next message
TX_developer
Messages: 46
Registered: July 2011
Member
Hi,

I just started working for a company and am modifying existing reports. This report has a logo in the layout in the form of an image. Is there a way to find out where this image is located? It cannot find the image when I open the layout or run the report so I assume I am not mapped to the drive/directory where the images are located? Is this information noted anywhere in the actual report?

Thanks,
~k
Re: Location of .bmp of image in report [message #516100 is a reply to message #516024] Fri, 15 July 2011 01:58 Go to previous messageGo to next message
Littlefoot
Messages: 18822
Registered: June 2005
Location: Croatia, Europe
Senior Member
Account Moderator
What does "I cannot find the image" mean? You can't find it in Reports Builder (Paper Layout Editor), or logo location on a disk, or ...?

If it is the Editor: maybe the logo is located in report's margin (see the attached image):

./fa/9198/0/

In this example, "Source Filename" property is simply its name: "LOGO.GIF". There's no path to it, so - how does the report know where to take it from (i.e. its location on a disk)? It is set in a setting (whose name I don't know) somewhere on the Application Server (Reports Services handle that, I presume), but - if you ask a person who is responsible for the iAS configuration, I guess he/she might know the answer.

On the other hand, Reports Builder needs to have access to logo file (my "LOGO.GIF") - otherwise, you wouldn't be able to run the report from the Builder. On a developer's PC (running under MS Windows), this location is set in Windows registry, in REPORTS_PATH. As you use Unix (and I don't), I wouldn't know where to look for it. I *suppose* there is REPORTS_PATH there as well, but ... no idea where to find it, sorry. If you manage to locate it, take a look at list of directories mentioned in REPORTS_PATH. Logo should be in one of them.

Finally, *maybe* REPORTS_PATH does the same job on iAS; I wouldn't know as I never configured it.
  • Attachment: logo.png
    (Size: 44.46KB, Downloaded 736 times)
Re: Location of .bmp of image in report [message #516778 is a reply to message #516100] Wed, 20 July 2011 16:13 Go to previous messageGo to next message
TX_developer
Messages: 46
Registered: July 2011
Member
The issue is that I log on to the reports developer through Citrix. The actual RDFs are located on "my" user drive on a different server. So if I don't map a drive, I cannot run/compile the reports. In order to keep moving forward, I placed the logo in the same directory as the RDFs, then hardcoded the path in the Source filename in the property palette of the object. now that I am done with the report, it will not let me take the path back out. If I remove the path and just try to set it back to the logo file name, I get an REP-0119 and once I click out of the Source Filename field it changes it back to the hardcoded path.

I contacted our help desk but so far have not gotten an answer. Anybody know how to fix this? I checked the registry and do not have a REPORTS_PATH variable. I also do not have an ORACLE_HOME directory on my client under the Oracle directory.

Thanks!
Re: Location of .bmp of image in report [message #516807 is a reply to message #516778] Thu, 21 July 2011 00:43 Go to previous messageGo to next message
Littlefoot
Messages: 18822
Registered: June 2005
Location: Croatia, Europe
Senior Member
Account Moderator
If logo image is not accessible by Reports Builder, it won't let you remove the path. So - do what I described previously. If there's no REPORTS_PATH in registry (which is kind of strange), add it. By the way, did you look at the right place? Did you search the registry? I think (but might be wrong) that different Developer Suite versions use different registry key names (such as REPORTS_PATH, REPORTS60_PATH and similar).

"Oracle home" is not a directory name, it is common name for a directory into which you installed certain Oracle product. For example, if you installed Developer Suite 10g into "C:\oracle\devsuit10g", then "C:\oracle\devsuit10g" is Developer Suite's "Oracle home".
Re: Location of .bmp of image in report [message #516912 is a reply to message #516807] Thu, 21 July 2011 07:22 Go to previous messageGo to next message
TX_developer
Messages: 46
Registered: July 2011
Member
I believe the issue is that the Developer Suite was not installed on my client. I access the Developer Suite through Citrix. What was installed on my computer is the Oracle Client.

Yes I searched the registry. I would assume the reports_path is under HKEY_LOCAL_MACHINE - SOFTWARE - ORACLE, however, I did a search on REPORTS_PATH, REPORTS60_PATH, REPORT_PATH, _PATH, and finally REPORT. Again, I assume it's not there because the Developer Suite was not installed on my PC?

I am attaching an image of what I have in the registry. Where would I add the REPORTS_PATH? Although I don't think it will work.

I am at home, connecting to my companies servers through a VPN and then connecting to Oracle Developer through Citrix - so the developer would not be looking at "my" local reports path I would assume?
  • Attachment: registry.png
    (Size: 9.53KB, Downloaded 87 times)
Re: Location of .bmp of image in report [message #516916 is a reply to message #516912] Thu, 21 July 2011 07:37 Go to previous messageGo to next message
Littlefoot
Messages: 18822
Registered: June 2005
Location: Croatia, Europe
Senior Member
Account Moderator
Huh, right ... Citrix. I can't tell, I never used it. "My" Developer Suite is installed on my PC, so everything works OK here. I really wouldn't know what to suggest. Maybe someone else, who worked with Citrix, knows how to solve the problem. Sorry.
Re: Location of .bmp of image in report [message #516936 is a reply to message #516916] Thu, 21 July 2011 08:18 Go to previous messageGo to next message
TX_developer
Messages: 46
Registered: July 2011
Member
NP - thank you for trying. In the past I have always had the developer installed on my PC as well so I am new to this. You would think the helpdesk could solve this!
Re: Location of .bmp of image in report [message #516999 is a reply to message #516936] Thu, 21 July 2011 12:32 Go to previous message
Littlefoot
Messages: 18822
Registered: June 2005
Location: Croatia, Europe
Senior Member
Account Moderator
Maybe they are new to this too ./fa/917/0/
Previous Topic: REP-1219
Next Topic: How to kill a Report Job ID
Goto Forum:
  


Current Time: Thu Apr 17 02:27:49 CDT 2014

Total time taken to generate the page: 0.09807 seconds