Home » RDBMS Server » Enterprise Manager » EM Doesn't Work.(2 Merged) (Oracle 11g R2)
EM Doesn't Work.(2 Merged) [message #512916] Wed, 22 June 2011 16:58 Go to next message
aucrun
Messages: 114
Registered: February 2011
Senior Member
Hi,

Yesterday I had an problem with an batch program that hangged Oracle. I forced that program to end (CTRL+ALT+DEL) and it was fine.
Until I try to enter EM. The service OracleConsole was not active.
When I try to Run the service it doesnt work and when I try to use DBCA to configure EM again it gives me the next errors:

22/Jun/2011 22:29:02 oracle.sysman.emcp.EMReposConfig unlockMGMTAccount
CONFIG: Failed to unlock mgmt_view account
22/Jun/2011 22:29:02 oracle.sysman.emcp.EMReposConfig invoke
SEVERE: Failed to unlock all EM-related accounts
22/Jun/2011 22:29:02 oracle.sysman.emcp.EMConfig perform
SEVERE: Failed to unlock all EM-related accounts
Refer to the log file at D:\app\PauloSilva\cfgtoollogs\dbca\orcl\emConfig.log for more details.
22/Jun/2011 22:29:02 oracle.sysman.emcp.EMConfig perform
CONFIG: Stack Trace:
oracle.sysman.emcp.exception.EMConfigException: Failed to unlock all EM-related accounts
at oracle.sysman.emcp.EMReposConfig.invoke(EMReposConfig.java:349)
at oracle.sysman.emcp.EMReposConfig.invoke(EMReposConfig.java:158)
at oracle.sysman.emcp.EMConfig.perform(EMConfig.java:253)
at oracle.sysman.assistants.util.em.EMConfiguration.run(EMConfiguration.java:583)
at oracle.sysman.assistants.util.em.EMConfigStep.executeImpl(EMConfigStep.java:139)
at oracle.sysman.assistants.util.step.BasicStep.execute(BasicStep.java:210)
at oracle.sysman.assistants.util.step.BasicStep.callStep(BasicStep.java:251)
at oracle.sysman.assistants.dbca.backend.PostDBConfigureStep.executeImpl(PostDBConfigureStep.java:269)
at oracle.sysman.assistants.util.step.BasicStep.execute(BasicStep.java:210)
at oracle.sysman.assistants.util.step.Step.execute(Step.java:140)
at oracle.sysman.assistants.util.step.StepContext$ModeRunner.run(StepContext.java:2667)
at java.lang.Thread.run(Thread.java:595)
22/Jun/2011 22:29:02 oracle.sysman.emcp.EMConfig restoreOuiLoc
CONFIG: Restoring oracle.installer.oui_loc to D:\app\PauloSilva\product\11.2.0\dbhome_1\oui

Can anyone help me to obtain EM again, please??

Thanks!
Re: Enterprise Manager problem! [message #512917 is a reply to message #512916] Wed, 22 June 2011 17:07 Go to previous messageGo to next message
BlackSwan
Messages: 22685
Registered: January 2009
Senior Member
Refer to the log file at D:\app\PauloSilva\cfgtoollogs\dbca\orcl\emConfig.log for more details.

It would be helpful if you followed Posting Guidelines - http://www.orafaq.com/forum/t/88153/0/
EM Doesn't Work. [message #512919 is a reply to message #512916] Wed, 22 June 2011 17:07 Go to previous messageGo to next message
aucrun
Messages: 114
Registered: February 2011
Senior Member
Hi,

My EM doesn't work. I don't know why, but the Console Service doesn´t Run, and therefore I cannot enter EM.
When I try to configure it with DBCA it gives me the following errors:
22/Jun/2011 22:29:02 oracle.sysman.emcp.EMReposConfig unlockMGMTAccount
CONFIG: Failed to unlock mgmt_view account
22/Jun/2011 22:29:02 oracle.sysman.emcp.EMReposConfig invoke
SEVERE: Failed to unlock all EM-related accounts
22/Jun/2011 22:29:02 oracle.sysman.emcp.EMConfig perform
SEVERE: Failed to unlock all EM-related accounts
Refer to the log file at D:\app\PauloSilva\cfgtoollogs\dbca\orcl\emConfig.log for more details.
22/Jun/2011 22:29:02 oracle.sysman.emcp.EMConfig perform
CONFIG: Stack Trace: 
oracle.sysman.emcp.exception.EMConfigException: Failed to unlock all EM-related accounts
	at oracle.sysman.emcp.EMReposConfig.invoke(EMReposConfig.java:349)
	at oracle.sysman.emcp.EMReposConfig.invoke(EMReposConfig.java:158)
	at oracle.sysman.emcp.EMConfig.perform(EMConfig.java:253)
	at oracle.sysman.assistants.util.em.EMConfiguration.run(EMConfiguration.java:583)
	at oracle.sysman.assistants.util.em.EMConfigStep.executeImpl(EMConfigStep.java:139)
	at oracle.sysman.assistants.util.step.BasicStep.execute(BasicStep.java:210)
	at oracle.sysman.assistants.util.step.BasicStep.callStep(BasicStep.java:251)
	at oracle.sysman.assistants.dbca.backend.PostDBConfigureStep.executeImpl(PostDBConfigureStep.java:269)
	at oracle.sysman.assistants.util.step.BasicStep.execute(BasicStep.java:210)
	at oracle.sysman.assistants.util.step.Step.execute(Step.java:140)
	at oracle.sysman.assistants.util.step.StepContext$ModeRunner.run(StepContext.java:2667)
	at java.lang.Thread.run(Thread.java:595)


What can I do? Anyone can help me please?

Thanks!
Re: Enterprise Manager problem! [message #512920 is a reply to message #512917] Wed, 22 June 2011 17:10 Go to previous messageGo to next message
aucrun
Messages: 114
Registered: February 2011
Senior Member
Hi,

That piece of code was from emConfig.log.

You can delete this post because I've created another one at Enterprise Manager section.

Thakns!
Re: Enterprise Manager problem! [message #512921 is a reply to message #512920] Wed, 22 June 2011 17:11 Go to previous messageGo to next message
aucrun
Messages: 114
Registered: February 2011
Senior Member
Thanks for merging both posts in here.

Now, regarding the code I've placed above, it is a copy from emConfig.log file.

I've noticed that there was a couple of lines missing in the code I've placed above:
22/Jun/2011 21:53:34 oracle.sysman.emcp.util.PlatformInterface executeCommand
CONFIG: Error executing CMD /C D:\app\PauloSilva\product\11.2.0\dbhome_1\sysman\admin\scripts\emca\emcaDbUtil.bat "D:\app\PauloSilva\product\11.2.0\dbhome_1\sysman\admin\scripts;D:\app\PauloSilva\product\11.2.0\dbhome_1\bin;" D:/app/PauloSilva/product/11.2.0/dbhome_1/perl/bin\perl.exe D:\app\PauloSilva\product\11.2.0\dbhome_1\sysman\admin\scripts\emca\emcaDbUtil.pl D:\app\PauloSilva\product\11.2.0\dbhome_1 "(DESCRIPTION=(ADDRESS_LIST=(ADDRESS=(PROTOCOL=TCP)(HOST=itpeopleps)(PORT=1521)))(CONNECT_DATA=(SERVICE_NAME=orcl)))" SYS SYSDBA declare repos_pwd varchar2(30); view_user varchar2(30); view_user_pwd varchar2(30); view_user_acc_status varchar2(30); begin repos_pwd := ?; sysman.mgmt_view_priv.get_view_user(view_user); select account_status into view_user_acc_status from sys.dba_users where upper(username) = upper ( view_user ); IF view_user_acc_status like '%LOCKED%' THEN execute immediate 'alter user ' || view_user || ' account unlock'; END IF; IF view_user_acc_status like '%EXPIRED%' THEN sysman.mgmt_view_priv.set_view_user_creds ( repos_pwd ); sysman.mgmt_view_priv.GET_VIEW_USER_CREDS ( view_user, view_user_pwd ); execute immediate 'alter user ' || view_user || ' identified by ' || view_user_pwd || ''; END IF; end; ORCL 1 SYSMAN_PWD 

[Updated on: Wed, 22 June 2011 17:18]

Report message to a moderator

Re: Enterprise Manager problem! [message #512925 is a reply to message #512921] Wed, 22 June 2011 17:33 Go to previous messageGo to next message
BlackSwan
Messages: 22685
Registered: January 2009
Senior Member
>CONFIG: Failed to unlock mgmt_view account
>SEVERE: Failed to unlock all EM-related accounts
Consider manual correction to issues above.
Re: Enterprise Manager problem! [message #512927 is a reply to message #512925] Wed, 22 June 2011 17:38 Go to previous messageGo to next message
aucrun
Messages: 114
Registered: February 2011
Senior Member
Ok ... I've unlocked user mgmt_view.

Now should I use DBCA or just try to run the Console Service?

Thanks!
Re: Enterprise Manager problem! [message #513385 is a reply to message #512927] Mon, 27 June 2011 04:13 Go to previous message
aucrun
Messages: 114
Registered: February 2011
Senior Member
Hi again,

I've unlocked the MGMT_VIEW user but the problem remains!
User SYSMAN is already unlocked too.

Any other ideas?

Thanks!
Previous Topic: Enterprise Manager Not Working.
Next Topic: grid control server can't find target
Goto Forum:
  


Current Time: Wed Aug 20 14:26:22 CDT 2014

Total time taken to generate the page: 0.08887 seconds