Home » Developer & Programmer » Warehouse Builder » The specified location parameter is not valid (OWB10.2.0.1 [Oracle Work Flow 2.6.4)
The specified location parameter is not valid [message #507086] Thu, 12 May 2011 07:34
malikshahid85
Messages: 5
Registered: August 2010
Location: Islamabad
Junior Member

Problem Description: Recently we found following two errors in process flow while starting from owb control center.

Quote:

null
- ORA-20018: The specified location parameter is invalid
ORA-06512: at "ATBI_OWBOWNER.WB_RTI_EXCEPTIONS", line 107
ORA-06512: at "ATBI_OWBOWNER.WB_RT_STORE_REGISTRATION", line 293
ORA-06512: at line 1

oracle.wh.service.sdk.runtime.QueryException: null
- ORA-20018: The specified location parameter is invalid
ORA-06512: at "ATBI_OWBOWNER.WB_RTI_EXCEPTIONS", line 107
ORA-06512: at "ATBI_OWBOWNER.WB_RT_STORE_REGISTRATION", line 293
ORA-06512: at line 1


at oracle.wh.service.impl.runtime.RuntimePlatformServiceImpl.isStoreRegisteredByUser(RuntimePlatformServiceImpl.java:1209)

at oracle.wh.service.impl.runtime.EnvironmentUtils.getLocationState(EnvironmentUtils.java:517)

at oracle.wh.service.impl.runtime.RuntimePlatformServiceImpl.getLocationState(RuntimePlatformServiceImpl.java:1194)

at oracle.wh.ui.runtime.application.WHRuntimeCommandLocation.doUnregisterLocation(WHRuntimeCommandLocation.java:136)

at oracle.wh.ui.runtime.application.WHRuntimeCommandHandler.doCommand(WHRuntimeCommandHandler.java:1338)

at oracle.wh.ui.runtime.deploymentManager.DeploymentManagerEventHandler.handleUnregisterAction(DeploymentManagerEventHandler.java:65)

at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)

at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)

at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)

at java.lang.reflect.Method.invoke(Method.java:324)

at oracle.wh.ui.editor.listener.ReflectListener.invokeMethod(ReflectListener.java:41)

at oracle.wh.ui.editor.listener.ReflectActionListener.actionPerformed(ReflectActionListener.java:33)

at javax.swing.AbstractButton.fireActionPerformed(AbstractButton.java:1786)

at javax.swing.AbstractButton$ForwardActionEvents.actionPerformed(AbstractButton.java:1839)

at javax.swing.DefaultButtonModel.fireActionPerformed(DefaultButtonModel.java:420)

at javax.swing.DefaultButtonModel.setPressed(DefaultButtonModel.java:258)

at javax.swing.AbstractButton.doClick(AbstractButton.java:289)

at javax.swing.plaf.basic.BasicMenuItemUI.doClick(BasicMenuItemUI.java:1113)

at javax.swing.plaf.basic.BasicMenuItemUI$MouseInputHandler.mouseReleased(BasicMenuItemUI.java:943)

at java.awt.Component.processMouseEvent(Component.java:5100)

at java.awt.Component.processEvent(Component.java:4897)

at java.awt.Container.processEvent(Container.java:1569)

at java.awt.Component.dispatchEventImpl(Component.java:3615)

at java.awt.Container.dispatchEventImpl(Container.java:1627)

at java.awt.Component.dispatchEvent(Component.java:3477)

at java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:3483)

at java.awt.LightweightDispatcher.processMouseEvent(Container.java:3198)

at java.awt.LightweightDispatcher.dispatchEvent(Container.java:3128)

at java.awt.Container.dispatchEventImpl(Container.java:1613)

at java.awt.Window.dispatchEventImpl(Window.java:1606)

at java.awt.Component.dispatchEvent(Component.java:3477)

at java.awt.EventQueue.dispatchEvent(EventQueue.java:456)

at java.awt.EventDispatchThread.pumpOneEventForHierarchy(EventDispatchThread.java:201)

at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:151)

at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:145)

at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:137)

at java.awt.EventDispatchThread.run(EventDispatchThread.java:100)



Quote:

Locations are not registered. no objects have been deployed


Note: Locations are registered

When i try to reregister process flow locations or deploy and run any process flow through control center it give the above error and send location is not registered but location is registered.

I can successfully deploy process flows through OMBPLUS. i am also running process flows using sql script successfully. but control center don't let me register,deploy or run any process flow.

I have uploaded the diagonostic file

Kindly help me

[Updated on: Thu, 12 May 2011 08:36]

Report message to a moderator

Previous Topic: OWB Repository creation error
Next Topic: Problem deploying a post procedure in a mapping
Goto Forum:
  


Current Time: Wed Aug 27 04:20:11 CDT 2014

Total time taken to generate the page: 0.12111 seconds