Home » Fusion Middleware & Colab Suite » Business Intelligence » problem regarding Scheduler Setup under Solaris Environment (Oracle Business Intelligence 10.1.3.4.1, solaris)
problem regarding Scheduler Setup under Solaris Environment [message #501580] Wed, 30 March 2011 00:37
gogol_1987
Messages: 12
Registered: March 2011
Location: kolkata
Junior Member
hi Gems...

I am setting up the BI Analytics under Solaris environment. I have done the following the following things successfully...

1. copied the repository in the specific location of BI server machine
2. copied the report files in the specific location of BI server machine
3. changed the NQSCONFIG.INI accordingly
4. i have set the LD_LIBRARY_PATH and the PATH variables by the following commands..

export PATH=$PATH:/BI_HOME/OracleBI/server
echo $PATH=/sbclocal/autosys/bin:/sbin:/usr/sbin:/usr/bin:/usr/sfw/bin:/usr/ccs/bin:/usr/openwin/bin:/sbclocal/autosys/bin:
/sbcimp/run/tp/oracle/client/v10.2.0.4-64bit/bin:/usr/jdk/instances/jdk1.5.0/bin:/BI_HOME/OracleBI/server
export ANA_INSTALL_DIR=/BI_HOME/OracleBI
export SAROOTDIR=${ANA_INSTALL_DIR}
export SADATADIR=/BI_HOME/OracleBIData
export SATEMPDIR=/BI_HOME/OracleBIData/tmp
export SAWROOTDIR=$SAROOTDIR/web
export LD_LIBRARY_PATH=$LD_LIBRARY_PATH: /BI_HOME/OracleBI/server/Bin
export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:/BI_HOME/OracleBI/web/bin

4. Since the system has 64bit Oracle version, thats why I have mapped the system with 32bit by the following command..

cd /BI_HOME/OracleBI/server/Bin
ln -s $ORACLE_HOME/lib32/libclntsh.so.10.1 libclntsh.so.10.1

5. I have restarted the BI services

cd /BI_HOME/OracleBI/setup
./run-sa.sh start
./run-saw.sh start

6. the reports are running fine...now I have tried to setup the Scheduler that is SCHCONFIG.
I have executed the below commands..

cd /BI_HOME/OracleBI/setup
./common.sh
./sa-init.sh (I have executed this because obiee supports only 32 bit)
./sa-init64.sh (I have executed these because the system is of 64 bit)

7. after this, when i tried to execute the SCHCONFIG by the following commands, it is throwing error...

cd /BI_HOME/OracleBI/server/Bin
./schconfig

ld.so.1: schconfig: fatal: relocation error: file /BI_HOME/OracleBI/server/Bin/libnqportable.so: symbol AnaAtomicIncrement: referenced symbol not found.


I am stuck...please help me....


Previous Topic: Drill down in OBIEE(user level)
Next Topic: Informatica Sales Project
Goto Forum:
  


Current Time: Sat Apr 19 23:03:42 CDT 2014

Total time taken to generate the page: 0.04533 seconds