Home » Developer & Programmer » Reports & Discoverer » REP-1825: Before Report trigger returned FALSE. (Oracle Forms and Reports 10.2.0.3 - windows 2003 sp2)
REP-1825: Before Report trigger returned FALSE. [message #496101] Thu, 24 February 2011 08:16 Go to next message
ksharmac
Messages: 5
Registered: February 2011
Location: India
Junior Member
Hi,

I am oracle clinical 4.6. In Oracle clinical when i am trying to submit "Print DCF" it should run and generate the report in PDF format. But I am getting the following error message.

MSG-00010: 328900: SRW.RUN_REPORT failed.
Updating failure text.
REP-1825: Before Report trigger returned FALSE.


Thanks

Kalyan
Re: REP-1825: Before Report trigger returned FALSE. [message #496103 is a reply to message #496101] Thu, 24 February 2011 08:25 Go to previous messageGo to next message
cookiemonster
Messages: 10573
Registered: September 2008
Location: Rainy Manchester
Senior Member
Did you try looking that error message up in report builder help?
It says:
Quote:

REP-1825: Before Report trigger returned FALSE.
Cause:   Your report includes a Before Report trigger that returned a value of FALSE rather than TRUE. When a trigger returns a value of FALSE, report formatting stops.
Action:   Make sure that your report trigger is meant to return a value of FALSE.


It means exactly what it says. The report has a before report trigger. It returned false. For the report to run it needs to return true. Not knowing what code that trigger contains we can't say anything else.
Re: REP-1825: Before Report trigger returned FALSE. [message #496158 is a reply to message #496103] Thu, 24 February 2011 23:30 Go to previous messageGo to next message
ksharmac
Messages: 5
Registered: February 2011
Location: India
Junior Member
Hi,

The file contains the following code.

function BeforeReport return boolean is
begin
global.set_prev_dcf_id(0);
get_labels;
if :p_or_t = 'T' then
:master_from := :master_from||'_T';
:detail_from := :detail_from||'_T';
end if;
return (TRUE);
end;


Thanks

Kalyan
  • Attachment: rxcdrptl.rdf
    (Size: 400.00KB, Downloaded 92 times)
Re: REP-1825: Before Report trigger returned FALSE. [message #496162 is a reply to message #496158] Fri, 25 February 2011 00:05 Go to previous messageGo to next message
Littlefoot
Messages: 18826
Registered: June 2005
Location: Croatia, Europe
Senior Member
Account Moderator
Obviously, this trigger (itself) returns TRUE. But, maybe procedure(s) it calls (such as GET_LABELS) returns FALSE and stops execution?
Re: REP-1825: Before Report trigger returned FALSE. [message #496194 is a reply to message #496162] Fri, 25 February 2011 03:32 Go to previous messageGo to next message
cookiemonster
Messages: 10573
Registered: September 2008
Location: Rainy Manchester
Senior Member
Huh? How can a procedure with no boolean parameter return false? They could raise an error but in that case I'd be expecting a different error message.
Re: REP-1825: Before Report trigger returned FALSE. [message #496195 is a reply to message #496162] Fri, 25 February 2011 03:32 Go to previous messageGo to next message
ksharmac
Messages: 5
Registered: February 2011
Location: India
Junior Member
So what i need to do?
Re: REP-1825: Before Report trigger returned FALSE. [message #496196 is a reply to message #496195] Fri, 25 February 2011 03:35 Go to previous messageGo to next message
ksharmac
Messages: 5
Registered: February 2011
Location: India
Junior Member
Hi please find report queue manager screen shot.


  • Attachment: error.JPG
    (Size: 147.60KB, Downloaded 160 times)
Re: REP-1825: Before Report trigger returned FALSE. [message #496198 is a reply to message #496196] Fri, 25 February 2011 03:42 Go to previous messageGo to next message
cookiemonster
Messages: 10573
Registered: September 2008
Location: Rainy Manchester
Senior Member
Are you sure you're looking at the correct version of the report?
Re: REP-1825: Before Report trigger returned FALSE. [message #496199 is a reply to message #496198] Fri, 25 February 2011 03:44 Go to previous messageGo to next message
ksharmac
Messages: 5
Registered: February 2011
Location: India
Junior Member
Yes
Re: REP-1825: Before Report trigger returned FALSE. [message #496205 is a reply to message #496199] Fri, 25 February 2011 04:16 Go to previous messageGo to next message
cookiemonster
Messages: 10573
Registered: September 2008
Location: Rainy Manchester
Senior Member
If you run the report from report builder does it work?
Re: REP-1825: Before Report trigger returned FALSE. [message #540196 is a reply to message #496101] Fri, 20 January 2012 11:09 Go to previous messageGo to next message
clinical
Messages: 2
Registered: January 2012
Location: Copenhagen
Junior Member

Note that Oracle Clinical 4.6.x is using Oracle Reports 10gR3, so if you have customzied the DCF report in Oracle Reports 10gR2, you might received this strange error:

Terminated with error: <br>REP-1825: MSG-00010: 328900: SRW.RUN_REPORT failed. Updating faiulre text. REP-1825: Before Report trigger returned FALSE.

I had this happening for me with a customized report - even if the report did not have any Before report trigger! Therefore, if you develop reports for OC 4.6.x in Oracle Reports Developer (e.g. Report Builder 9.0.4.0.33 that comes with Oracle Developer Suite 10gR2) you must remember to use the Report Converter installed with the Application Server (OC middletier) to convert the .rdf into .rep. The rep file generated using Report Builder 9.0.4.0.33 (10gR2) won't run with OC 4.6.x.

Re: REP-1825: Before Report trigger returned FALSE. [message #542853 is a reply to message #496101] Fri, 10 February 2012 08:21 Go to previous message
clinical
Messages: 2
Registered: January 2012
Location: Copenhagen
Junior Member

Check if a log file was written. You might be able to find more info in the log file, e.g. DCF status must be changed etc. DCF reports can be triggy to generate as they rely on a certain work-flow.
Previous Topic: Garbage in Arabic PDF (merged 2)
Next Topic: 'afterpform': Fatal PL/SQL error occurred, PL/SQL: numeric or value error
Goto Forum:
  


Current Time: Fri Apr 18 17:56:49 CDT 2014

Total time taken to generate the page: 0.13044 seconds