Home » Developer & Programmer » Reports & Discoverer » problem_with_report_server_after_configuring_OS_environment_variable (oracle / forms /reports 10g + win XP sp2)
problem_with_report_server_after_configuring_OS_environment_variable [message #495455] Sat, 19 February 2011 12:16 Go to next message
m_shehpar
Messages: 64
Registered: October 2010
Location: Pakistan
Member
hi all.

i have a problem with my report server. when i attempt to start my report server the following error message is
prompted by OS (windows xp sp2):

javaw.exe - Entry Point Not Found

The procedure entry point psoasyn could not be located in the dynamic link library orapls10.dll
----------------------------------------------------------------

previously it worked all fine. i had a requirement wherein i had to create a database with a different name other
than "orcl". as a result i couldnt use my import/export utility. to fix this i had to modify my environment path
variable. after that i am facing this problem with the report server. every thing else is all fine....

why report server aint working? is it some thing to do with the environment variable???

please help me out at this

i use: oracle 10.2.0.1.0

Forms [32 Bit] Version 10.1.2.0.2 (Production)

Report Builder 10.1.2.0.2

"rwserver server=hbfp"

my new environment variable is
(C:\oracle\product\10.2.0\db_1\bin;C:\oracle\DevSuiteHome_1\jdk\jre\bin\classic;C:\oracle\DevSuiteHome_1\jdk\jre\bin;C:\oracle\DevSui teHome_1\jdk\jre\bin\client;C:\oracle\DevSuiteHome_1\jlib;C:\oracle\DevSuiteHome_1\bin;C:\oracle\DevSuiteHome_1\jre\1.4.2\bin\client; C:\oracle\DevSuiteHome_1\jre\1.4.2\bin;%SystemRoot%\system32;%SystemRoot%;%SystemRoot%\System32\Wbem)

hoping for help...

regards....
Re: problem_with_report_server_after_configuring_OS_environment_variable [message #495460 is a reply to message #495455] Sat, 19 February 2011 12:59 Go to previous messageGo to next message
Michel Cadot
Messages: 58861
Registered: March 2007
Location: Nanterre, France, http://...
Senior Member
Account Moderator
This is the same problem as your previous topic: you have to change the environment (ORACLE_HOME, PATH) to match with the tool you want to use.

You can choose the current environment using OUI (Oracle Universal Installer, see Startup > All programs > Oracle xxx > Oracle Installion Products > Universal Installer. Then, in OUI, choose Installed Products > Environment tab and choose the Home of the tool you want to use.

Regards
Michel

Re: problem_with_report_server_after_configuring_OS_environment_variable [message #495499 is a reply to message #495460] Sun, 20 February 2011 00:35 Go to previous messageGo to next message
m_shehpar
Messages: 64
Registered: October 2010
Location: Pakistan
Member
hi

so this means i could use only one of them at a time????
this was not the case when i used the database name as "orcl". i didnt even knew these problems... when i changed the database name i am facing these delimas.
isnt there any way out from this??? cant i use both of them???

waiting for help...

regards...
Re: problem_with_report_server_after_configuring_OS_environment_variable [message #495500 is a reply to message #495499] Sun, 20 February 2011 00:42 Go to previous messageGo to next message
m_shehpar
Messages: 64
Registered: October 2010
Location: Pakistan
Member
actually i frequently use the import/export utility. and report server is also an essential requirement so i want to keep both consistent...

when i used "orcl" database name every thing was copasetic, please help me out to fix these delimas with my own desired database name too...

regards...
Re: problem_with_report_server_after_configuring_OS_environment_variable [message #495501 is a reply to message #495499] Sun, 20 February 2011 00:45 Go to previous messageGo to next message
Michel Cadot
Messages: 58861
Registered: March 2007
Location: Nanterre, France, http://...
Senior Member
Account Moderator
You can use only one at the time of lauching your tool. You can switch from one home to the other one when you want to use another tool.
When the tool is launched it knows its environment, you can change the current environment without impacting the tools that are currently running.

Regards
Michel
Re: problem_with_report_server_after_configuring_OS_environment_variable [message #495502 is a reply to message #495501] Sun, 20 February 2011 00:55 Go to previous messageGo to next message
m_shehpar
Messages: 64
Registered: October 2010
Location: Pakistan
Member
thanks alot for help...
but can i ask by the way, why this aint the case when the database name is "orcl"???

i even checked this now again. i have two computers and i am practicing Oracle Replication. The computer where "orcl" database resides is all flaw less. it has no enivronment variable problem but the other one where i have chosen the database name as "hbfm", can use only environment variable.
this question drags thorns in my throat...
Re: problem_with_report_server_after_configuring_OS_environment_variable [message #495503 is a reply to message #495502] Sun, 20 February 2011 01:36 Go to previous message
Michel Cadot
Messages: 58861
Registered: March 2007
Location: Nanterre, France, http://...
Senior Member
Account Moderator
Sorry I don't understand the question. I don't understand what you actually have.
What does mean "this aint the case when the database name is "orcl"???"?
Database name has nothing to do with environment.
Environment depends on what you installed.

If you want a detailed answer for your case, you have to describe in details what you installed, in which order, in which home, which versions...

Regards
Michel
Previous Topic: How to create a report using lexical parameter
Next Topic: how to connect CR8 to oracle 11g
Goto Forum:
  


Current Time: Sat Aug 23 09:02:04 CDT 2014

Total time taken to generate the page: 0.10042 seconds