Home » RDBMS Server » Server Administration » Issues with component--11.2.0.2 upgrade (Orac,e,11gR2,RHEL5)
Issues with component--11.2.0.2 upgrade [message #477548] Fri, 01 October 2010 12:55 Go to next message
nadvi
Messages: 46
Registered: May 2006
Location: Canada
Member

Hi,

I am testing upgrade from 11.1.0.6 to 11.2.0.2 patchset on linux X86-64 version. And facing the following component related issue.

The following components cannot be upgraded as the corresponding upgrade scripts are missing:
OLAP Analytic Workspace ( /u01/app/oracle/product/11.2.0/dbhome_3/olap/admin/apsdbmig.sql )
OLAP Catalog ( /u01/app/oracle/product/11.2.0/dbhome_3/olap/admin/amddbmig.sql )
Spatial ( /u01/app/oracle/product/11.2.0/dbhome_3/md/admin/sdodbmig.sql )
Oracle OLAP API ( /u01/app/oracle/product/11.2.0/dbhome_3/olap/admin/xoqdbmig.sql )
If you want to upgrade these components, you must first install them, using the OUI, and then re-run the Upgrade Assistant. 
Do you want to continue with upgrade? 
Note: If you continue, the above components will not be considered as part of the upgrade process.*


Following is the status of the specified components from 11.1.0.6

COMP_ID COMP_NAME VERSION STATUS
AMD OLAP Catalog 11.1.0.6.0 VALID
SDO Spatial 11.1.0.6.0 VALID
APS OLAP Analytic Workspace 11.1.0.6.0 VALID

Should I install these components while installing 11.2.0.2 patchset prior upgrading? I was unable to find any component installation on OUI.

Also DBUA pre-upgrade asked to remove existing UltraSearch from 11.1.0.6 prior upgrading. Though I removed it, but not sure is that going to hamper the upgraded DB, as I'm not sure of the usage of this component as well.

Can anyone shed some light on it.

Thanks.

[Updated on: Fri, 01 October 2010 12:59] by Moderator

Report message to a moderator

Re: Issues with component--11.2.0.2 upgrade [message #477549 is a reply to message #477548] Fri, 01 October 2010 12:59 Go to previous messageGo to next message
Michel Cadot
Messages: 67762
Registered: March 2007
Location: Nanterre, France, http://...
Senior Member
Account Moderator
You have to:
1/ Install 11.2.0.1
2/ Patch the installation
3/ Upgrade the database

Regards
Michel
Re: Issues with component--11.2.0.2 upgrade [message #477550 is a reply to message #477549] Fri, 01 October 2010 13:10 Go to previous messageGo to next message
nadvi
Messages: 46
Registered: May 2006
Location: Canada
Member

Hi Michel,

Thanks for your reply.

As per metalink note: ID 1189783.1
Quote:

"Because the release 11.2.0.2 patch set is a full installation package, if you are installing Oracle Database on a system without an existing Oracle Database installation, then you can simply install the release 11.2.0.2 patch set. You are no longer required to install the base release, and then apply the patch set."


So I was trying installing 11.2.0.2 first and upgrade.
Also, As you said, I tried with 11.2.0.1 and upgrade but still faced the component issues.
Any idea?

Thanks

[Updated on: Fri, 01 October 2010 13:12] by Moderator

Report message to a moderator

Re: Issues with component--11.2.0.2 upgrade [message #477551 is a reply to message #477550] Fri, 01 October 2010 13:14 Go to previous messageGo to next message
Michel Cadot
Messages: 67762
Registered: March 2007
Location: Nanterre, France, http://...
Senior Member
Account Moderator
Use QUOTE tag to quote not CODE one.

No, no idea, you should open a SR to Oracle.

Regards
Michel
Re: Issues with component--11.2.0.2 upgrade [message #478276 is a reply to message #477551] Thu, 07 October 2010 11:32 Go to previous messageGo to next message
nadvi
Messages: 46
Registered: May 2006
Location: Canada
Member

Hi Michel,

This is normal when we upgrade from standard edition as the components are for Enterprise edition.
Though the mentioned components gets installed during fresh installation but Once the database is upgraded, starting with 10.2.0.2, the STATUS will be returned as 'OPTION OFF'.

Below Metalink note supports this quote.
Oracle OLAP Components listed as 'OPTION OFF' in Standard Edition Installation [ID 459153.1]

So, the component upgrade related errors can be ignored during upgrade .

Thanks for your guidence.
Re: Issues with component--11.2.0.2 upgrade [message #478351 is a reply to message #478276] Fri, 08 October 2010 02:57 Go to previous messageGo to next message
Michel Cadot
Messages: 67762
Registered: March 2007
Location: Nanterre, France, http://...
Senior Member
Account Moderator
Ah! you didn't say you use the standard edition.

Regards
Michel

[Updated on: Fri, 08 October 2010 03:01]

Report message to a moderator

Re: Issues with component--11.2.0.2 upgrade [message #478414 is a reply to message #478351] Fri, 08 October 2010 10:02 Go to previous messageGo to next message
nadvi
Messages: 46
Registered: May 2006
Location: Canada
Member

Sorry Michael, Forgot to mention that. I was confused with the DBUA instruction and also, if you do fresh Standard edition installation; the components appears as VALID.
Only, when you are upgrading, 'OPTION OFF' issue arises.

Anyway, thanks for your followup.
Re: Issues with component--11.2.0.2 upgrade [message #478418 is a reply to message #478414] Fri, 08 October 2010 10:13 Go to previous message
Michel Cadot
Messages: 67762
Registered: March 2007
Location: Nanterre, France, http://...
Senior Member
Account Moderator
In my opinion, it is a bug from dbca that is corrected by dbua. Wink

Regards
michel
Previous Topic: connection error
Next Topic: ORA-03135: connection lost contact
Goto Forum:
  


Current Time: Fri Mar 05 11:07:14 CST 2021