Home » RDBMS Server » Server Utilities » SQL Loader (SQL*Loader: Release 8.0.6.3.0 )
SQL Loader [message #472776] Mon, 23 August 2010 17:53 Go to next message
kjasthi
Messages: 7
Registered: August 2010
Location: Fremont
Junior Member
Hi all,
we are upgrading databse form 8i to 10g

while testing my program is getting error out.
here is the ctl file

LOAD DATA INFILE '/apps/dv1qtc/appl_top/xxcfi/11.5.0/interface/image/kpu/in/61771020_data.dat'
INTO TABLE KPU_INFILE_MASTER
APPEND
FIELDS TERMINATED BY ',' (
FILE_NAME CHAR(40),
EXT_BLOB FILLER CHAR,
FILE_BLOB LOBFILE(EXT_BLOB) TERMINATED BY EOF,
FETCH_DATE SYSDATE,
NEW_ENTRY char(1))

error message:
SQL*Loader-350: Syntax error at line 6.
Expecting "," or ")", found "FILLER".
EXT_BLOB FILLER CHAR,

Please suggest me a solution
Re: SQL Loader [message #472788 is a reply to message #472776] Mon, 23 August 2010 22:19 Go to previous messageGo to next message
Barbara Boehmer
Messages: 7991
Registered: November 2002
Location: California, USA
Senior Member
Your syntax is valid. However, you are using SQL*Loader Release 8.0.6.3.0. If you are loading the data into a 10g database, then you should be using the 10g version of SQL*Loader. This might be what is causing your problem.


Re: SQL Loader [message #472939 is a reply to message #472788] Tue, 24 August 2010 16:12 Go to previous messageGo to next message
kjasthi
Messages: 7
Registered: August 2010
Location: Fremont
Junior Member
Here I am connecting to remote database. will it be caused?
Re: SQL Loader [message #472940 is a reply to message #472939] Tue, 24 August 2010 17:02 Go to previous messageGo to next message
Barbara Boehmer
Messages: 7991
Registered: November 2002
Location: California, USA
Senior Member
I don't think loading into a remote database would cause the error. It is more likely the conflict of versions. I don't remember if 8.0 supported loading objects remotely or not.
Re: SQL Loader [message #472942 is a reply to message #472940] Tue, 24 August 2010 20:17 Go to previous messageGo to next message
kjasthi
Messages: 7
Registered: August 2010
Location: Fremont
Junior Member
Today I tried with old dev instance(9i) to check the issue but getting below error.
SQL*Loader-704: Internal error: ulconnect: OCIServerAttach [0]
ORA-12154: TNS:could not resolve service name

Please help me on this issue.
Re: SQL Loader [message #472943 is a reply to message #472942] Tue, 24 August 2010 20:18 Go to previous messageGo to next message
kjasthi
Messages: 7
Registered: August 2010
Location: Fremont
Junior Member
I have submitted the above from Oracle ERP.

I am getting below error when I run from cmd prompt

SQL*Loader-350: Syntax error at line 6.
Expecting "," or ")", found "FILLER".
EXT_BLOB FILLER CHAR,
Re: SQL Loader [message #472944 is a reply to message #472943] Tue, 24 August 2010 20:47 Go to previous messageGo to next message
BlackSwan
Messages: 22844
Registered: January 2009
Senior Member
please put yourself in our position. All we know is what you post.
I don't know for sure how many physical system are involved, what OS name & version or Oracle Version to 4 decimal places.
I don't know what command from which system was issued.
Too bad for us that you refuse to follow Posting Guidelines http://www.orafaq.com/forum/t/88153/0/ & use COPY and PASTE so we can actually see what you do.
Re: SQL Loader [message #472946 is a reply to message #472944] Tue, 24 August 2010 21:18 Go to previous messageGo to next message
kjasthi
Messages: 7
Registered: August 2010
Location: Fremont
Junior Member
Hi ,

I am sorry about that.

when I run from unix prompt(SSH tactia), I am able to see sql loader version.
my SQL*Loader: Release 8.0.6.3.0


when I run from Oracle ERP(911.5.9) I am able to see sql loader version as 9.2.0.5

my target database details: 9.2.0.6.0

Thanks
Kishore
Re: SQL Loader [message #472947 is a reply to message #472946] Tue, 24 August 2010 21:20 Go to previous messageGo to next message
kjasthi
Messages: 7
Registered: August 2010
Location: Fremont
Junior Member
platform is HP-Unix
Re: SQL Loader [message #472951 is a reply to message #472947] Tue, 24 August 2010 22:31 Go to previous messageGo to next message
BlackSwan
Messages: 22844
Registered: January 2009
Senior Member
we are upgrading databse form 8i to 10g
OK, I give up.
I do not understand what you are really trying to accomplish.
>we are upgrading databse form 8i to 10g
If above is true, then why are you using V8.0.6 SQLLDR at all and not using exp/imp?
What data on which system needs to go where?
How many Oracle DBs? What versions are Oracle DBs?
What problem are you REALLY trying to solve?
Re: SQL Loader [message #473102 is a reply to message #472951] Wed, 25 August 2010 18:26 Go to previous message
kjasthi
Messages: 7
Registered: August 2010
Location: Fremont
Junior Member
Hi Barbara Boehmer,



what you have anticipated is correct.
Thanks for your inputs..

Previous Topic: SQL Loader error
Next Topic: Re: SQL Loader loads all fields with double quotes into staging table (split from unrelated hijacke
Goto Forum:
  


Current Time: Wed Oct 01 14:03:24 CDT 2014

Total time taken to generate the page: 0.09126 seconds