Home » RDBMS Server » Backup & Recovery » ORA-19554: error allocating device, device type: SBT_TAPE, device name: (Oracle 10.2.0 Windows 2003 R2 SP2 x64)
ORA-19554: error allocating device, device type: SBT_TAPE, device name: [message #462642] Fri, 25 June 2010 07:46 Go to next message
lukesteggles
Messages: 1
Registered: June 2010
Junior Member
Hello
I'm trying to clear up an issue my colleagues have created with our Oracle database.
To cut a long story short, I've performed a recovery on the database but the following messages have been returned.
RMAN-03002: failure of restore command at 06/25/2010 12:05:01

ORA-19554: error allocating device, device type: SBT_TAPE, device name:

ORA-27211: Failed to load Media Management Library

When I try and type any commands into RMAN I get a message saying I am not connected to the target database.
When I go into OEM I see the database instance is down and the agent to connection Instance is down. The listener says it is up.

Can anyone offer any suggestions please?

many thanks
Luke

PS I'm new to Oracle so please be patient with my obvious questions. Smile
Re: ORA-19554: error allocating device, device type: SBT_TAPE, device name: [message #462657 is a reply to message #462642] Fri, 25 June 2010 08:26 Go to previous messageGo to next message
Michel Cadot
Messages: 57607
Registered: March 2007
Location: Nanterre, France, http://...
Senior Member
Account Moderator
ORA-27211: Failed to load Media Management Library
 *Cause:  User-supplied SBT_LIBRARY or libobk.so could not be loaded. Call
          to dlopen for media library returned error. See Additional
          information for error code.
 *Action: Retry the command with proper media library. Or re-install
          Media management module for Oracle.

Regards
Michel
Re: ORA-19554: error allocating device, device type: SBT_TAPE, device name: [message #511168 is a reply to message #462642] Thu, 09 June 2011 23:35 Go to previous messageGo to next message
rahu96
Messages: 1
Registered: June 2011
Location: Bangalore
Junior Member
Hi All,
I am getting the b elow erro while backing up the oracle DB using the Commvault backup application


Rman Script:
[run {
allocate channel ch1 type 'sbt_tape'
PARMS="BLKSIZE=262144,ENV=(CV_mmsApiVsn=2,CV_channelPar=ch1,ThreadCommandLine=BACKUP -jm 45 -a 2:110 -cl 31 -ins 20 -at 22 -j 24910 -jt 24910:3:1 -bal 1 -bap 0 -rap 0 -rcp 0 -mav 0 -ms 1 -data -cn neaoradbp01 -vm Instance001 -vm neaoradbp01.inco.net)"
TRACE 0;
setlimit channel ch1 maxopenfiles 8;
backup
incremental level = 0
filesperset = 32
database
include current controlfile ;
}
exit;
]
Rman Log:[
Recovery Manager: Release 10.2.0.4.0 - Production on Fri Jun 10 06:10:43 2011
Copyright (c) 1982, 2007, Oracle. All rights reserved.
RMAN>
RMAN>
connected to target database: CEG03PWM (DBID=2839914967)
using target database control file instead of recovery catalog
RMAN> 2> 3> 4> 5> 6> 7> 8> 9> 10> 11>
RMAN-00571: ===========================================================
RMAN-00569: =============== ERROR MESSAGE STACK FOLLOWS ===============
RMAN-00571: ===========================================================
RMAN-03009: failure of allocate command on ch1 channel at 06/10/2011 06:10:46
ORA-19554: error allocating device, device type: SBT_TAPE, device name:
ORA-27211: Failed to load Media Management Library
RMAN>
Recovery Manager complete.
]
==========================================================

above is the RMAN log for the same.

Can someoen help ?
Re: ORA-19554: error allocating device, device type: SBT_TAPE, device name: [message #511179 is a reply to message #511168] Fri, 10 June 2011 00:18 Go to previous messageGo to next message
Mahesh Rajendran
Messages: 10613
Registered: March 2002
Location: oracleDocoVille
Senior Member
Account Moderator
Did you install media manager?

http://download.oracle.com/docs/cd/B19306_01/backup.102/b14191/rcmconfg.htm#i1006526
http://download.oracle.com/docs/cd/B19306_01/backup.102/b14191/rcmtroub.htm#i1007192
Re: ORA-19554: error allocating device, device type: SBT_TAPE, device name: [message #511186 is a reply to message #511179] Fri, 10 June 2011 00:57 Go to previous message
babuknb
Messages: 1703
Registered: December 2005
Location: NJ
Senior Member

http://www.orafaq.com/forum/t/171443/80704/

You should find solution from my last post
Previous Topic: Backup
Next Topic: RMAN & TAPE Library TS3100
Goto Forum:
  


Current Time: Thu Apr 17 17:26:43 CDT 2014

Total time taken to generate the page: 0.06767 seconds