Home » Server Options » RAC & Failsafe » RAC 11g R2 - root.sh throws error - Configure Oracle Grid Infrastructure for a Cluster ... failed (Oracle RAC 11g R2,RedHat 5)
RAC 11g R2 - root.sh throws error - Configure Oracle Grid Infrastructure for a Cluster ... failed [message #460249] Thu, 10 June 2010 06:08 Go to next message
amit210001
Messages: 14
Registered: August 2009
Location: India
Junior Member
I have followed all the steps from -
http://www.oracle-base.com/articles/11g/OracleDB11gR2RACInstallationOnOEL5UsingVMwareServer2.php

Here my redhat VM on two different ESX server but both are in same subnet and i am able to ping both VM's from both VM's.

Everything going fine but when i ran the root.sh on rac2 machine then root.sh show some failed messages i.e.

====================================================
Preparing packages for installation...
cvuqdisk-1.0.7-1
Configure Oracle Grid Infrastructure for a Cluster ... failed
=====================================================

Root.sh also not identified the rac1 node on rac2 machine

i have executed the below command

./olsnodes
rac1

But it shows the only one node instead of two node.

Please check the attached output of root.sh which was ran on rac2 vm

Please let me know if i have miss anything.

Thanks,
-Amit
Re: RAC 11g R2 - root.sh throws error - Configure Oracle Grid Infrastructure for a Cluster ... faile [message #460329 is a reply to message #460249] Thu, 10 June 2010 10:09 Go to previous messageGo to next message
Mahesh Rajendran
Messages: 10615
Registered: March 2002
Location: oracleDocoVille
Senior Member
Account Moderator
Please post the contents of /etc/hosts file.
Re: RAC 11g R2 - root.sh throws error - Configure Oracle Grid Infrastructure for a Cluster ... faile [message #460331 is a reply to message #460249] Thu, 10 June 2010 10:12 Go to previous messageGo to next message
Mahesh Rajendran
Messages: 10615
Registered: March 2002
Location: oracleDocoVille
Senior Member
Account Moderator
Quoting the source writeup
Quote:
The Single Client Access Name (SCAN) should really be defined in the DNS or GNS and round-robin between one of 3 addresses, which are on the same subnet as the public and virtual IPs. In this article I've defined it as a single IP address in the "/etc/hosts" file, which is wrong and will cause the cluster verification to fail, but it allows me to complete the install without the presence of a DNS.

Hope you did the same.
Re: RAC 11g R2 - root.sh throws error - Configure Oracle Grid Infrastructure for a Cluster ... faile [message #460395 is a reply to message #460331] Fri, 11 June 2010 00:45 Go to previous messageGo to next message
amit210001
Messages: 14
Registered: August 2009
Location: India
Junior Member
Here are my host entries on rac1 and rac2

Rac1 Host entries

# Do not remove the following line, or various programs
# that require network functionality will fail.
127.0.0.1 localhost.localdomain localhost
# Public
10.97.106.151 rac1.localdomain rac1
10.97.106.152 rac2.localdomain rac2
# Private
10.97.0.151 rac1-priv.localdomain rac1-priv
10.97.0.152 rac2-priv.localdomain rac2-priv
# Virtual
10.97.106.153 rac1-vip.localdomain rac1-vip
10.97.106.154 rac2-vip.localdomain rac2-vip
# SCAN
10.97.106.251 rac-scan.localdomain rac-scan

Rac2 Host entries
# Do not remove the following line, or various programs
# that require network functionality will fail.
127.0.0.1 localhost.localdomain localhost
# Public
10.97.106.151 rac1.localdomain rac1
10.97.106.152 rac2.localdomain rac2
# Private
10.97.0.151 rac1-priv.localdomain rac1-priv
10.97.0.152 rac2-priv.localdomain rac2-priv
# Virtual
10.97.106.153 rac1-vip.localdomain rac1-vip
10.97.106.154 rac2-vip.localdomain rac2-vip
# SCAN
10.97.106.251 rac-scan.localdomain rac-scan

On rac2 the root.sh script not able to find the rac1 but as per the above article root.sh done the following stuff on node2 i.e. rac2

CRS-4123: Oracle High Availability Services has been started.
ohasd is starting
CRS-4402: The CSS daemon was started in exclusive mode but found an active CSS daemon on node rac1, number 1, and is terminating

but in my case it show's the same logs for node2 as shown in node1.

Please let me know if i miss anything.

Is there any way to fix the node without starting everything from scratch like installing the grid infra. again ?

Thanks,
-AMit

Thanks,
-Amit
Re: RAC 11g R2 - root.sh throws error - Configure Oracle Grid Infrastructure for a Cluster ... faile [message #460501 is a reply to message #460395] Fri, 11 June 2010 09:28 Go to previous message
Mahesh Rajendran
Messages: 10615
Registered: March 2002
Location: oracleDocoVille
Senior Member
Account Moderator
>>Is there any way to fix the node without starting everything from scratch like installing the grid infra. again ?
I have no idea. I would first investigate the root issue before starting over.
In your $ORACLE_HOME/grid/../.. there should be a log file for grid on node 2.
See if there is anything that is useful there.
If there was a failure in a particular step, it should be logged there.
Previous Topic: .ons offline
Next Topic: rac question
Goto Forum:
  


Current Time: Wed Aug 20 04:22:55 CDT 2014

Total time taken to generate the page: 0.10655 seconds