Home » Server Options » RAC & Failsafe » Problems with connecting to ASM instance (RedHat 5 x64)
Problems with connecting to ASM instance [message #459515] Sun, 06 June 2010 09:16 Go to next message
rodnower
Messages: 17
Registered: June 2010
Location: Israel
Junior Member
I have Oracle11 with RAC installed on RedHat 5.
I have two servers with two instances one on each one.
In each server I succeed connect to appropriate instance of database but not to instance of ASM.

I connect with user oracle11 and type:
export ORACLE_SID=+ASM1
sqlplus "/ as sysdba"
It connects but write:
Connected to an idle instance
and when I try to access to parameters or views I have errors.

For know that +ASM1 is the SID I type:
ps aux | grep pmon
and get:
asm_pmon_+ASM1

I tried also with +ASM but it was also unsuccessfully.

What is wrong here?
Re: Problems with connecting to ASM instance [message #459516 is a reply to message #459515] Sun, 06 June 2010 09:23 Go to previous messageGo to next message
BlackSwan
Messages: 23141
Registered: January 2009
Senior Member
ALWAYS
Post Operating System (OS) name & version for DB server system.
Post results of
SELECT * from v$version
or post Oracle version to 4 decimal places

It would be helpful if you followed Posting Guidelines - http://www.orafaq.com/forum/t/88153/0/

use COPY & PASTE so we can see what you & how Oracle responds
Re: Problems with connecting to ASM instance [message #459524 is a reply to message #459515] Sun, 06 June 2010 10:31 Go to previous messageGo to next message
ebrian
Messages: 2794
Registered: April 2006
Senior Member
Make sure you have the correct ORACLE_HOME set too.
Re: Problems with connecting to ASM instance [message #459570 is a reply to message #459516] Mon, 07 June 2010 02:30 Go to previous messageGo to next message
rodnower
Messages: 17
Registered: June 2010
Location: Israel
Junior Member
Thank you for replay.
I have been read Posting Guidelines, but I may not to copy too many things from my workstation, because computer that is connected to Internet is not the same one.

Here some more information:

cat /proc/version:
Linux version 2.6.18-164.el5 (workbuild@x86-003.build.bos.redhat.com (gcc version .. (Red Hat 4.1.2-46))

select * from v$version:
Oracle Database 11g Enterprise Edition
Release 11.2.0.1.0-64bit - Production
PL/SQL Release 11.2.0.1.0 - Production
Core 11.2.0.1.0 - Production
TNS for Linux: version 11.2.0.1.0 - Production
NLSRLL version 11.2.0.1.0 - Production

And I actually set also ORACLE_HOME of the ASM:

cat /etc/oratab:
+ASM1:/oracle11/product/11.2.0/grid:N
LIBD:/oracle11/product/11.2.0/db:N

Now I'm sure about SID of ASM, and I do:
su - oracle11

export ORACLE_HOME=/oracle11/product/11.2.0/grid/
export ORACLE_SID=+ASM1

cd $ORACLE_HOME/bin

pwd
/oracle11/product/11.2.0/grid/bin

./sqlplus /nolog
SQL> conn / as sysdba
Connected to an idle instance
Re: Problems with connecting to ASM instance [message #459571 is a reply to message #459524] Mon, 07 June 2010 02:30 Go to previous messageGo to next message
rodnower
Messages: 17
Registered: June 2010
Location: Israel
Junior Member
Yes I'm actually do this.

[Updated on: Mon, 07 June 2010 02:31]

Report message to a moderator

Re: Problems with connecting to ASM instance [message #459579 is a reply to message #459570] Mon, 07 June 2010 04:35 Go to previous messageGo to next message
ebrian
Messages: 2794
Registered: April 2006
Senior Member
rodnower wrote on Mon, 07 June 2010 03:30

export ORACLE_HOME=/oracle11/product/11.2.0/grid/

Set your home without the trailing '/':

export ORACLE_HOME=/oracle11/product/11.2.0/grid
Re: Problems with connecting to ASM instance [message #459902 is a reply to message #459579] Tue, 08 June 2010 23:03 Go to previous messageGo to next message
mkounalis
Messages: 147
Registered: October 2009
Location: Dallas, TX
Senior Member
What does 'crs_stat -t' show?
Re: Problems with connecting to ASM instance [message #459975 is a reply to message #459902] Wed, 09 June 2010 04:40 Go to previous messageGo to next message
ebrian
Messages: 2794
Registered: April 2006
Senior Member
mkounalis wrote on Wed, 09 June 2010 00:03
What does 'crs_stat -t' show?

Does it matter?

The database is up and therefore ASM must be up (as the OP has also indicated).
Re: Problems with connecting to ASM instance [message #459995 is a reply to message #459975] Wed, 09 June 2010 05:29 Go to previous message
rodnower
Messages: 17
Registered: June 2010
Location: Israel
Junior Member
Yeh!!! I won!!! Thank you all, thank you ebrian!!! The solution is: to set ORACLE_HOME without / at the end!
Previous Topic: ASM vs RAID for 11gR2 RAC Environment
Next Topic: .ons offline
Goto Forum:
  


Current Time: Thu Dec 18 12:31:49 CST 2014

Total time taken to generate the page: 0.08615 seconds