Home » Developer & Programmer » Reports & Discoverer » Oracle Fusion Middleware Reports11g - REP-51002: فشل الربط بخادم Reports Server wls_reports. (Reports 11g)
Oracle Fusion Middleware Reports11g - REP-51002: فشل الربط بخادم Reports Server wls_reports. [message #459496] Sun, 06 June 2010 03:39 Go to next message
ranamirfan
Messages: 529
Registered: January 2006
Location: Pakistan / Saudi Arabia
Senior Member

Dear All,

I m new in Forms & Reports 11g.
when I tried to run the report behind a button with following code gives error.

" REP-51002: فشل الربط بخادم Reports Server wls_reports."

My Report Server wls_reports server in Running Mode.

/*

declare
v_show_document VARCHAR2 (2000) :='/reports/rwservlet?';
v_connect VARCHAR2 (200) := 'userid=nisadmin_dev/nisadmin_dev@webnis';
v_report_server VARCHAR2 (30) := 'wls_reports';
v_report_name VARCHAR2(100) := 'F:\Irfan\NewReports\Currency.rdf';
v_format VARCHAR2(12) := 'html'; -- PDF or SPREADSHEET
begin
v_show_document := v_show_document
|| v_connect
-- Report server
|| '&server='
|| v_report_server
-- Report name
|| '&report='||v_report_name
-- Reports parameters
|| '&destype=CACHE'
|| '&desformat='||v_format
|| '&paramform=no'

;
web.show_document(v_show_document) ;
end;
/*

Kindly advise me.

Regards,


Irfan


Re: Oracle Fusion Middleware Reports11g - REP-51002: فشل الربط بخادم Reports Server wls_reports. [message #459519 is a reply to message #459496] Sun, 06 June 2010 09:37 Go to previous messageGo to next message
Littlefoot
Messages: 19636
Registered: June 2005
Location: Croatia, Europe
Senior Member
Account Moderator
What does " فشل الربط بخادم " mean?

Did you check that error message in Reports Online Help System? What does it say?
Re: Oracle Fusion Middleware Reports11g - REP-51002: فشل الربط بخادم Reports Server wls_reports. [message #459574 is a reply to message #459519] Mon, 07 June 2010 03:56 Go to previous messageGo to next message
ranamirfan
Messages: 529
Registered: January 2006
Location: Pakistan / Saudi Arabia
Senior Member

Thankx.
Yes,I was checked in Reports System Help.
"Verify that Reports Server is running and that the Reports Server name is correct."

Can you explain me how we find out Report Server name ? In weblogicServer Report Server name like WLS_Reports & Running Mode.

Looking forward to hearing from you.

regards,

Irfan

Re: Oracle Fusion Middleware Reports11g - REP-51002: فشل الربط بخادم Reports Server wls_reports. [message #459578 is a reply to message #459574] Mon, 07 June 2010 04:22 Go to previous messageGo to next message
Littlefoot
Messages: 19636
Registered: June 2005
Location: Croatia, Europe
Senior Member
Account Moderator
Which operating system do you use? On MS Windows XP, you'd go to Administrative Tools - Services. In there, you should see something like
OraceDevSuiteHome_904Reports[my_report_server]
(where "my_report_server" is, well, name of your report server. If it is not started, start it.

I wouldn't know whether the same goes for Weblogic server, sorry. I never used anything > 10g.
Re: Oracle Fusion Middleware Reports11g - REP-51002: فشل الربط بخادم Reports Server wls_reports. [message #459608 is a reply to message #459578] Mon, 07 June 2010 07:00 Go to previous messageGo to next message
ranamirfan
Messages: 529
Registered: January 2006
Location: Pakistan / Saudi Arabia
Senior Member

Dear I m using Windows XP.Yes I see there Oracle Reports Server [Rep60_HOITVOLTES5] .
1- We have Reports6i & Reports 11g on same drive & PC.
2- kindly let me know it is possible that oracle reports use same server for both version reports.
3- when I tried to restart Oracle Reports Server [Rep60_HOITVOLTES5] .It gives errors.
"
The Oracle Reports Server [Rep60_HOITVOLTES5] service terminated with service-specific error 186 (0xBA). "
4-I also tried to change TNSNAMES.ora with specific name like rep.world

I m unable to restart this Oracle Reports Server [Rep60_HOITVOLTES5] services.

Pls advise.

Regards,

Irfan
Re: Oracle Fusion Middleware Reports11g - REP-51002: فشل الربط بخادم Reports Server wls_reports. [message #572684 is a reply to message #459608] Sat, 15 December 2012 23:24 Go to previous messageGo to next message
Medo
Messages: 17
Registered: December 2012
Location: Qatar
Junior Member
Dear Ranamirfan

i have the same problim with deferent version
not solved yet but


if you could please check the Oracle Console

mabye the console not started

try this mabye will help.

Start>Control Panel>Administrative tools > Services

You have to check the console status
i.e : For me OracleDBConsole<Your SID Name>

this in 10G


Re: Oracle Fusion Middleware Reports11g - REP-51002: فشل الربط بخادم Reports Server wls_reports. [message #572685 is a reply to message #572684] Sun, 16 December 2012 00:00 Go to previous message
ranamirfan
Messages: 529
Registered: January 2006
Location: Pakistan / Saudi Arabia
Senior Member

Dear,
Quote:

Mon, 07 June 2010 17:00
Re: Oracle Fusion Middleware Reports11g - REP-51002: فشل الربط بخادم Reports Server wls_reports.

I've this error message due to Weblogic report Server down.
This problem solved after Starting the Weblogic Report Server.

Regards,
Irfan
Previous Topic: .RTF report execution through command prompt
Next Topic: HELP .. Rep-51002
Goto Forum:
  


Current Time: Tue Sep 23 12:22:55 CDT 2014

Total time taken to generate the page: 0.11171 seconds