Home » RDBMS Server » Enterprise Manager » Unable to bring up OEM when using different pfile ( Oracle 10g, RHEL 4.0 )
Unable to bring up OEM when using different pfile [message #459452] Sat, 05 June 2010 10:00 Go to next message
jxh461
Messages: 175
Registered: March 2005
Senior Member
Can someone tell me what is missing in this pfile that would cause enterprise manager not to appear ?

In the Oracle Database 10g: Administration Workshop II
The chapter 8 excersize calls for the database to be started using the pfile init_sgalab.ora . The purpose of this I suppose is to simulate a memory error.

When I get to the part where I need to use OEM to fix the problem, OEM does not come up. The contents of init_sgalab.ora are :

--------------------------------------------
background_dump_dest='/u01/app/oracle/admin/orcl/bdump'
compatible='10.2.0.1.0'
control_files='/u01/app/oracle/oradata/orcl/control01.ctl','/u01/app/oracle/oradata/orcl/control02.ctl','/u01/app/oracle/oradata/orcl /control03.ctl'
core_dump_dest='/u01/app/oracle/admin/orcl/cdump'
db_block_size=8192
db_cache_size=100m
db_domain='oracle.com'
db_file_multiblock_read_count=16
db_name='orcl'
db_recovery_file_dest='/u01/app/oracle/flash_recovery_area'
db_recovery_file_dest_size=4294967296
dispatchers='(PROTOCOL=TCP) (SERVICE=orclXDB)'
fast_start_mttr_target=30
java_pool_size=4m
job_queue_processes=2
large_pool_size=4m
log_checkpoint_timeout=0
open_cursors=300
pga_aggregate_target=25165824
processes=150
remote_login_passwordfile='EXCLUSIVE'
shared_pool_size=100m
sort_area_size=65536
undo_management='AUTO'
undo_tablespace='UNDOTBS1'
user_dump_dest='/u01/app/oracle/admin/orcl/udump'
parallel_max_servers=64
parallel_adaptive_multi_user=FALSE
sga_max_size=300m
sga_target=0
---------------------------------------------------

I am not sure what is missing in this file to be able to bring up OEM.


Also, I looked at the logs and this is the only error message I found that might be relevant in
/u01/app/oracle/product/10.2.0/db_1/jhlinux.home.com_orcl/sysman/log/emoms.log

2010-06-04 23:33:59,809 [HttpRequestHandler-8546123] ERROR eml.OMSHandshake processFailure.619 - OMSHandshake failed.(AGENT URL = http://jhlinux.home.com:3938/emd/main)(ERROR = INTERNAL_ERROR)


Please advise and thanks in advance.
Re: Unable to bring up OEM when using different pfile [message #459467 is a reply to message #459452] Sat, 05 June 2010 14:16 Go to previous messageGo to next message
ebrian
Messages: 2794
Registered: April 2006
Senior Member
What exactly did you change in this exercise?

Was the pfile created from the actual spfile?

Did OEM ever start correctly? Are you using a static IP?
Re: Unable to bring up OEM when using different pfile [message #459479 is a reply to message #459467] Sat, 05 June 2010 18:38 Go to previous messageGo to next message
jxh461
Messages: 175
Registered: March 2005
Senior Member
What exactly did you change in this exercise?
I just run a script that generates Java stored procedures.

Was the pfile created from the actual spfile?
No. This one was provided as part of the lab materials.

Did OEM ever start correctly?
It starts correctly when I don't involve this pfile.

Are you using a static IP? I think I am how can I confirm ?
Re: Unable to bring up OEM when using different pfile [message #459480 is a reply to message #459479] Sat, 05 June 2010 18:48 Go to previous messageGo to next message
BlackSwan
Messages: 21938
Registered: January 2009
Senior Member
On your system you should have a file similar to the following filename

/etc/sysconfig/network-scripts/ifcfg-eth0

post the contents back here & we can decide whether or not system has static IP# or not
Re: Unable to bring up OEM when using different pfile [message #459481 is a reply to message #459480] Sat, 05 June 2010 22:14 Go to previous messageGo to next message
jxh461
Messages: 175
Registered: March 2005
Senior Member
DEVICE=eth0
BOOTPROTO=dhcp
HWADDR=00:24:21:2A:83:8F
ONBOOT=yes
TYPE=Ethernet
DHCP_HOSTNAME=jhlinux.home.com
Re: Unable to bring up OEM when using different pfile [message #459482 is a reply to message #459481] Sat, 05 June 2010 22:21 Go to previous messageGo to next message
BlackSwan
Messages: 21938
Registered: January 2009
Senior Member
BOOTPROTO=dhcp
DHCP means system could get different IP# each reboot
Re: Unable to bring up OEM when using different pfile [message #459506 is a reply to message #459482] Sun, 06 June 2010 07:15 Go to previous messageGo to next message
jxh461
Messages: 175
Registered: March 2005
Senior Member
OK. So how exaclty does using another pfile affect the OEM if my ip is dynamic ?
Re: Unable to bring up OEM when using different pfile [message #459510 is a reply to message #459506] Sun, 06 June 2010 07:43 Go to previous messageGo to next message
ebrian
Messages: 2794
Registered: April 2006
Senior Member
Without knowing the exact sequence of events that you executed, as BlackSwan indicated, if you rebooted during the exercises, you may have gotten a different IP.

What does ifconfig -a and cat /etc/hosts show?

Also, does db console start if you go back to using the spfile?
Re: Unable to bring up OEM when using different pfile [message #459532 is a reply to message #459510] Sun, 06 June 2010 14:02 Go to previous messageGo to next message
jxh461
Messages: 175
Registered: March 2005
Senior Member
ifconfig -a does not work.


$ cat /etc/hosts
# Do not remove the following line, or various programs
# that require network functionality will fail.
127.0.0.1 jhlinux.home.com jhlinux localhost.localdomain localhost
Re: Unable to bring up OEM when using different pfile [message #459535 is a reply to message #459532] Sun, 06 June 2010 14:09 Go to previous messageGo to next message
ebrian
Messages: 2794
Registered: April 2006
Senior Member
/sbin/ifconfig -a

Also,

ebrian wrote on Sun, 06 June 2010 08:43
does db console start if you go back to using the spfile?

Re: Unable to bring up OEM when using different pfile [message #459537 is a reply to message #459535] Sun, 06 June 2010 14:26 Go to previous messageGo to next message
jxh461
Messages: 175
Registered: March 2005
Senior Member
$ /sbin/ifconfig -a
eth0 Link encap:Ethernet HWaddr 00:24:21:2A:83:8F
inet addr:192.168.1.101 Bcast:192.168.1.255 Mask:255.255.255.0
inet6 addr: fe80::224:21ff:fe2a:838f/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:123299 errors:0 dropped:0 overruns:0 frame:0
TX packets:16186 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:12863594 (12.2 MiB) TX bytes:2885142 (2.7 MiB)
Interrupt:217 Base address:0x2000

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:1358569 errors:0 dropped:0 overruns:0 frame:0
TX packets:1358569 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:191056670 (182.2 MiB) TX bytes:191056670 (182.2 MiB)

sit0 Link encap:IPv6-in-IPv4
NOARP MTU:1480 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)




[Updated on: Sun, 06 June 2010 14:28]

Report message to a moderator

Re: Unable to bring up OEM when using different pfile [message #459538 is a reply to message #459537] Sun, 06 June 2010 14:32 Go to previous messageGo to next message
jxh461
Messages: 175
Registered: March 2005
Senior Member
dbconsole starts fine

$ emctl status dbconsole
TZ set to US/Eastern
Oracle Enterprise Manager 10g Database Control Release 10.2.0.1.0
Copyright (c) 1996, 2005 Oracle Corporation. All rights reserved.
http://jhlinux.home.com:1158/em/console/aboutApplication
Oracle Enterprise Manager 10g is running.
------------------------------------------------------------------
Logs are generated in directory /u01/app/oracle/product/10.2.0/db_1/jhlinux.home.com_orcl/sysman/log
$
Re: Unable to bring up OEM when using different pfile [message #459540 is a reply to message #459538] Sun, 06 June 2010 14:41 Go to previous messageGo to next message
ebrian
Messages: 2794
Registered: April 2006
Senior Member
If dbconsole seems to start fine with the spfile, then I would try to create a pfile from the spfile and compare the differences between the pfile you create and the pfile the exercise wants you to use. I can't think of a specific parameter that would cause this type of problem.

You can create a pfile as:

SQL> create pfile='/tmp/temp_pfile.log' from spfile;


Are you certain there are no other pertinent error messages in the dbconsole log files?

[Updated on: Sun, 06 June 2010 14:45]

Report message to a moderator

Re: Unable to bring up OEM when using different pfile [message #459545 is a reply to message #459540] Sun, 06 June 2010 21:18 Go to previous messageGo to next message
jxh461
Messages: 175
Registered: March 2005
Senior Member
I did did a shutdown immediate using OEM and tried to start with special options using the suggested pfile. I was prompted to enter the database login credentials and at that point I received the following error message:

Listener refused the connection with the following error: ORA-12514, TNS:listener does not currently know of service requested in connect descriptor The Connection descriptor used by the client was: (DESCRIPTION=(ADDRESS_LIST=(ADDRESS=(PROTOCOL=TCP)(HOST=jhlinux.home.com)(PORT=1521)))(CONNECT_DATA=(SERVICE_NAME=orcl)))

I am not sure what is going on but I will do the comparison of the suggested pfile and the generated pfile from spfile.
Re: Unable to bring up OEM when using different pfile [message #459546 is a reply to message #459545] Sun, 06 June 2010 21:22 Go to previous messageGo to next message
BlackSwan
Messages: 21938
Registered: January 2009
Senior Member
>ORA-12514, TNS:listener does not currently know of service requested in connect descriptor

post tail end (last 50 - 60 lines) from listener.log file
Re: Unable to bring up OEM when using different pfile [message #459547 is a reply to message #459546] Sun, 06 June 2010 21:24 Go to previous messageGo to next message
ebrian
Messages: 2794
Registered: April 2006
Senior Member
It would appear that you do not have a static entry for the database in the listener.ora file that is why you are getting the ORA-12514 error message.
Re: Unable to bring up OEM when using different pfile [message #459653 is a reply to message #459547] Mon, 07 June 2010 15:10 Go to previous messageGo to next message
jxh461
Messages: 175
Registered: March 2005
Senior Member
Contents of listener.log are :


TNS-12514: TNS:listener does not currently know of service requested in connect descriptor
07-JUN-2010 16:06:09 * (CONNECT_DATA=(CID=(PROGRAM=)(HOST=__jdbc__)(USER=))(SERVICE_NAME=orcl)) * (ADDRESS=(PROTOCOL=tcp)(HOST=127.0.0.1)(PORT=10061)) * establish * orcl * 12514
TNS-12514: TNS:listener does not currently know of service requested in connect descriptor
07-JUN-2010 16:06:09 * (CONNECT_DATA=(CID=(PROGRAM=)(HOST=__jdbc__)(USER=))(SERVICE_NAME=orcl)) * (ADDRESS=(PROTOCOL=tcp)(HOST=127.0.0.1)(PORT=10062)) * establish * orcl * 12514
TNS-12514: TNS:listener does not currently know of service requested in connect descriptor
07-JUN-2010 16:06:09 * (CONNECT_DATA=(CID=(PROGRAM=)(HOST=__jdbc__)(USER=))(SERVICE_NAME=orcl)) * (ADDRESS=(PROTOCOL=tcp)(HOST=127.0.0.1)(PORT=10063)) * establish * orcl * 12514
TNS-12514: TNS:listener does not currently know of service requested in connect descriptor
07-JUN-2010 16:06:09 * (CONNECT_DATA=(CID=(PROGRAM=)(HOST=__jdbc__)(USER=))(SERVICE_NAME=orcl)) * (ADDRESS=(PROTOCOL=tcp)(HOST=127.0.0.1)(PORT=10065)) * establish * orcl * 12514
TNS-12514: TNS:listener does not currently know of service requested in connect descriptor
07-JUN-2010 16:06:09 * (CONNECT_DATA=(CID=(PROGRAM=)(HOST=__jdbc__)(USER=))(SERVICE_NAME=orcl)) * (ADDRESS=(PROTOCOL=tcp)(HOST=127.0.0.1)(PORT=10066)) * establish * orcl * 12514
TNS-12514: TNS:listener does not currently know of service requested in connect descriptor
07-JUN-2010 16:06:09 * (CONNECT_DATA=(CID=(PROGRAM=)(HOST=__jdbc__)(USER=))(SERVICE_NAME=orcl)) * (ADDRESS=(PROTOCOL=tcp)(HOST=127.0.0.1)(PORT=10067)) * establish * orcl * 12514
TNS-12514: TNS:listener does not currently know of service requested in connect descriptor
07-JUN-2010 16:06:14 * (CONNECT_DATA=(SID=orcl)(CID=(PROGRAM=emagent)(HOST=jhlinux.home.com)(USER=oracle))) * (ADDRESS=(PROTOCOL=tcp)(HOST=127.0.0.1)(PORT=10069)) * establish * orcl * 0
07-JUN-2010 16:06:18 * (CONNECT_DATA=(CID=(PROGRAM=)(HOST=__jdbc__)(USER=))(SERVICE_NAME=orcl)) * (ADDRESS=(PROTOCOL=tcp)(HOST=127.0.0.1)(PORT=10073)) * establish * orcl * 12514
TNS-12514: TNS:listener does not currently know of service requested in connect descriptor
07-JUN-2010 16:06:18 * (CONNECT_DATA=(CID=(PROGRAM=)(HOST=__jdbc__)(USER=))(SERVICE_NAME=orcl)) * (ADDRESS=(PROTOCOL=tcp)(HOST=127.0.0.1)(PORT=10074)) * establish * orcl * 12514
TNS-12514: TNS:listener does not currently know of service requested in connect descriptor
@
Re: Unable to bring up OEM when using different pfile [message #459657 is a reply to message #459653] Mon, 07 June 2010 15:29 Go to previous messageGo to next message
BlackSwan
Messages: 21938
Registered: January 2009
Senior Member
>(HOST=__jdbc__)
Interesting hostname!

ORACLE_SID=orcl is unknown to the listener.

post results from following SQL

select name from v$database;
Re: Unable to bring up OEM when using different pfile [message #459664 is a reply to message #459657] Mon, 07 June 2010 16:56 Go to previous messageGo to next message
jxh461
Messages: 175
Registered: March 2005
Senior Member
SQL> select name from v$database;

NAME
---------
ORCL

Re: Unable to bring up OEM when using different pfile [message #459665 is a reply to message #459664] Mon, 07 June 2010 17:16 Go to previous messageGo to next message
BlackSwan
Messages: 21938
Registered: January 2009
Senior Member
post results following commands

id
lsnrctl status
lsnrctl service
env | sort
Re: Unable to bring up OEM when using different pfile [message #459670 is a reply to message #459653] Mon, 07 June 2010 19:50 Go to previous messageGo to next message
ebrian
Messages: 2794
Registered: April 2006
Senior Member
I would assume you don't have a listener.ora file and/or the database (ORCL) does not have an entry in the listener.ora file.

$ sqlplus test/test@ora10g

SQL*Plus: Release 10.2.0.1.0 - Production on Mon Jun 7 20:44:55 2010

Copyright (c) 1982, 2005, Oracle.  All rights reserved.


Connected to:
Oracle Database 10g Enterprise Edition Release 10.2.0.1.0 - 64bit Production
With the Partitioning, Oracle Label Security, OLAP and Data Mining options

SQL> conn / as sysdba
Connected.
SQL> shutdown immediate
Database closed.
Database dismounted.
ORACLE instance shut down.
SQL> exit
Disconnected from Oracle Database 10g Enterprise Edition Release 10.2.0.1.0 - 64bit Production
With the Partitioning, Oracle Label Security, OLAP and Data Mining options

$ sqlplus test/test@ora10g

SQL*Plus: Release 10.2.0.1.0 - Production on Mon Jun 7 20:45:43 2010

Copyright (c) 1982, 2005, Oracle.  All rights reserved.

ERROR:
ORA-12514: TNS:listener does not currently know of service requested in connect
descriptor


Enter user-name: 
Re: Unable to bring up OEM when using different pfile [message #459676 is a reply to message #459670] Mon, 07 June 2010 22:41 Go to previous messageGo to next message
jxh461
Messages: 175
Registered: March 2005
Senior Member
$ id
uid=501(oracle) gid=501(oinstall) groups=501(oinstall),502(dba),503(oper) context=user_u:system_r:unconfined_t


$ lsnrctl status

LSNRCTL for Linux: Version 10.2.0.1.0 - Production on 07-JUN-2010 23:35:45

Copyright (c) 1991, 2005, Oracle. All rights reserved.

Connecting to (DESCRIPTION=(ADDRESS=(PROTOCOL=IPC)(KEY=EXTPROC1)))
STATUS of the LISTENER
------------------------
Alias LISTENER
Version TNSLSNR for Linux: Version 10.2.0.1.0 - Production
Start Date 04-JUN-2010 23:28:01
Uptime 3 days 0 hr. 7 min. 44 sec
Trace Level off
Security ON: Local OS Authentication
SNMP OFF
Listener Parameter File /u01/app/oracle/product/10.2.0/db_1/network/admin/listener.ora
Listener Log File /u01/app/oracle/product/10.2.0/db_1/network/log/listener.log
Listening Endpoints Summary...
(DESCRIPTION=(ADDRESS=(PROTOCOL=ipc)(KEY=EXTPROC1)))
(DESCRIPTION=(ADDRESS=(PROTOCOL=tcp)(HOST=jhlinux.home.com)(PORT=1521)))
Services Summary...
Service "PLSExtProc" has 1 instance(s).
Instance "PLSExtProc", status UNKNOWN, has 1 handler(s) for this service...
Service "orcl.oracle.com" has 1 instance(s).
Instance "orcl", status READY, has 1 handler(s) for this service...
Service "orclXDB.oracle.com" has 1 instance(s).
Instance "orcl", status READY, has 1 handler(s) for this service...
Service "orcl_XPT.oracle.com" has 1 instance(s).
Instance "orcl", status READY, has 1 handler(s) for this service...
Service "rman.jhlinux" has 1 instance(s).
Instance "rman", status READY, has 1 handler(s) for this service...
Service "rmanXDB.jhlinux" has 1 instance(s).
Instance "rman", status READY, has 1 handler(s) for this service...
Service "rman_XPT.jhlinux" has 1 instance(s).
Instance "rman", status READY, has 1 handler(s) for this service...
The command completed successfully


$ lsnrctl service
LSNRCTL for Linux: Version 10.2.0.1.0 - Production on 07-JUN-2010 23:37:16

Copyright (c) 1991, 2005, Oracle. All rights reserved.

Connecting to (DESCRIPTION=(ADDRESS=(PROTOCOL=IPC)(KEY=EXTPROC1)))
Services Summary...
Service "PLSExtProc" has 1 instance(s).
Instance "PLSExtProc", status UNKNOWN, has 1 handler(s) for this service...
Handler(s):
"DEDICATED" established:0 refused:0
LOCAL SERVER
Service "orcl.oracle.com" has 1 instance(s).
Instance "orcl", status READY, has 1 handler(s) for this service...
Handler(s):
"DEDICATED" established:147 refused:0 state:ready
LOCAL SERVER
Service "orclXDB.oracle.com" has 1 instance(s).
Instance "orcl", status READY, has 1 handler(s) for this service...
Handler(s):
"D000" established:0 refused:0 current:0 max:1022 state:ready
DISPATCHER <machine: jhlinux.home.com, pid: 17018>
(ADDRESS=(PROTOCOL=tcp)(HOST=jhlinux.home.com)(PORT=10051))
Service "orcl_XPT.oracle.com" has 1 instance(s).
Instance "orcl", status READY, has 1 handler(s) for this service...
Handler(s):
"DEDICATED" established:147 refused:0 state:ready
LOCAL SERVER
Service "rman.jhlinux" has 1 instance(s).
Instance "rman", status READY, has 1 handler(s) for this service...
Handler(s):
"DEDICATED" established:0 refused:0 state:ready
LOCAL SERVER
Service "rmanXDB.jhlinux" has 1 instance(s).
Instance "rman", status READY, has 1 handler(s) for this service...
Handler(s):
"D000" established:0 refused:0 current:0 max:1022 state:ready
DISPATCHER <machine: jhlinux.home.com, pid: 17934>
(ADDRESS=(PROTOCOL=tcp)(HOST=jhlinux.home.com)(PORT=33041))
Service "rman_XPT.jhlinux" has 1 instance(s).
Instance "rman", status READY, has 1 handler(s) for this service...
Handler(s):
"DEDICATED" established:0 refused:0 state:ready
LOCAL SERVER
The command completed successfully


$env | sort
COLORTERM=gnome-terminal
DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-WfnUx2Eif6
DESKTOP_SESSION=default
DESKTOP_STARTUP_ID=
DISPLAY=:0.0
G_BROKEN_FILENAMES=1
GDMSESSION=default
GNOME_DESKTOP_SESSION_ID=Default
GNOME_KEYRING_SOCKET=/tmp/keyring-GNBoju/socket
GTK_RC_FILES=/etc/gtk/gtkrc:/home/oracle/.gtkrc-1.2-gnome2
HISTSIZE=1000
HOME=/home/oracle
HOSTNAME=jhlinux.home.com
INPUTRC=/etc/inputrc
KDEDIR=/usr
LANG=en_US.UTF-8
LESSOPEN=|/usr/bin/lesspipe.sh %s
LOGNAME=oracle
LS_COLORS=no=00:fi=00:di=00;34:ln=00;36:pi=40;33:so=00;35:bd=40;33;01:cd=40;33;01:or=01;05;37;41:mi=01;05;37;41:ex=00;32:*.cmd=00;32: *.exe=00;32:*.com=00;32:*.btm=00;32:*.bat=00;32:*.sh=00;32:*.csh=00;32:*.tar=00;31:*.tgz=00;31:*.arj=00;31:*.taz=00;31:*.lzh=00;31:*. zip=00;31:*.z=00;31:*.Z=00;31:*.gz=00;31:*.bz2=00;31:*.bz=00;31:*.tz=00;31:*.rpm=00;31:*.cpio=00;31:*.jpg=00;35:*.gif=00;35:*.bmp=00; 35:*.xbm=00;35:*.xpm=00;35:*.png=00;35:*.tif=00;35:
MAIL=/var/spool/mail/oracle
NLS_DATE_FORMAT=yyyy-mm-dd hh24:mi:ss
OLDPWD=/u01/app/oracle/product/10.2.0/db_1/network/log
ORACLE_BASE=/u01/app/oracle
ORACLE_HOME=/u01/app/oracle/product/10.2.0/db_1
ORACLE_SID=orcl
PATH=/u01/app/oracle/product/10.2.0/db_1/bin:/usr/kerberos/bin:/usr/local/bin:/usr/bin:/bin:/usr/X11R6/bin:/home/oracle/bin
PWD=/home/oracle
SESSION_MANAGER=local/jhlinux.home.com:/tmp/.ICE-unix/14796
SHELL=/bin/bash
SHLVL=2
SSH_AGENT_PID=14826
SSH_ASKPASS=/usr/libexec/openssh/gnome-ssh-askpass
SSH_AUTH_SOCK=/tmp/ssh-RKJQO14796/agent.14796
TERM=xterm
USER=oracle
_=/usr/bin/env
WINDOWID=19926709
XAUTHORITY=/home/oracle/.Xauthority



[Updated on: Mon, 07 June 2010 22:43]

Report message to a moderator

Re: Unable to bring up OEM when using different pfile [message #459677 is a reply to message #459676] Mon, 07 June 2010 22:55 Go to previous messageGo to next message
BlackSwan
Messages: 21938
Registered: January 2009
Senior Member
THANKS for the requested feedback. It has ruled out many possible problem areas.

post results from following commands

cat /etc/hosts
tnsping orcl.oracle.com
lsnrctl stop
mv /u01/app/oracle/product/10.2.0/db_1/network/admin/listener.ora /u01/app/oracle/product/10.2.0/db_1/network/admin/listener.ora.bak
cat /u01/app/oracle/product/10.2.0/db_1/network/admin/sqlnet.ora
lsnrctl start
tnsping orcl.oracle.com
sleep 65
lsnrctl service
Re: Unable to bring up OEM when using different pfile [message #459875 is a reply to message #459677] Tue, 08 June 2010 11:35 Go to previous messageGo to next message
BlackSwan
Messages: 21938
Registered: January 2009
Senior Member
please note that both lsnrctl status & lsnrctl service report the SERVICE_NAME is "orcl.oracle.com" & not just "orcl"
Since a service named only "orcl" is not known to the listener, the appropriate error is reported/returned.
Re: Unable to bring up OEM when using different pfile [message #459897 is a reply to message #459875] Tue, 08 June 2010 16:06 Go to previous message
jxh461
Messages: 175
Registered: March 2005
Senior Member
Fix is to change the db_domain parameter in the suggested pfile from "db_domain=oracle.com" to "db_domain=''"

Thanks you all for helping me figure this out.
Previous Topic: dbconsole doesnot start after fresh installation
Next Topic: DBCA shows No Agents Found
Goto Forum:
  


Current Time: Wed Apr 16 14:44:18 CDT 2014

Total time taken to generate the page: 0.12114 seconds