Home » Fusion Middleware & Colab Suite » Weblogic & Application Server » Report Server (Oracle 10G , windows xp)
Report Server [message #451899] Sun, 18 April 2010 09:23 Go to next message
esraa90
Messages: 63
Registered: May 2008
Location: EGYPT
Member

Dear all,

Could any one help me.

I already finished running forms on 10G application server.

How could I configure reports to run through my 10G application server?


Best Regards


Re: Report Server [message #452451 is a reply to message #451899] Thu, 22 April 2010 03:26 Go to previous message
faris_sudan
Messages: 6
Registered: April 2010
Location: sudan
Junior Member
use this code:-
Declare
repid REPORT_OBJECT ;
v_rep varchar2(100);
rep_status varchar2(20);
PL PARAMLIST ;
parm varchar2(10);
Begin
If :RB='1' then
repid := find_report_object('reportnodename');
pl:=get_parameter_list('paraformlist');
if not id_null(pl) then
destroy_parameter_list(pl);
end if;
-- Adjust form report obeject
SET_REPORT_OBJECT_PROPERTY (repid,report_execution_mode,batch);
SET_REPORT_OBJECT_PROPERTY (repid,report_comm_mode,synchronous);
SET_REPORT_OBJECT_PROPERTY (repid,report_destype,cache);
SET_REPORT_OBJECT_PROPERTY (repid,report_desformat,'pdf'); --htmlcss
SET_REPORT_OBJECT_PROPERTY (repid,report_server,reportservname);
------------*****************************************************
pl:=create_parameter_list('paraformlist');
add_parameter(pl,'paramform',text_parameter,'no');
add_parameter(pl,'pf_1',text_parameter,parm);
add_parameter(pl,'pf_2',text_parameter,:parm1);
v_rep := RUN_REPORT_OBJECT(repid,pl);
rep_status := REPORT_OBJECT_STATUS(v_rep);
------------*****************************************************
WHILE rep_status in ('RUNNING','OPENING_REPORT','ENQUEUED') LOOP
rep_status := report_object_status(v_rep);
END LOOP;
------------*****************************************************
IF rep_status = 'FINISHED' THEN
/*Display report in the browser*/
WEB.SHOW_DOCUMENT('h t t p ://ora10g:7777/reports/rwservlet/getjobid'|| substr(v_rep,instr(v_rep,'_',-1)+1)||'?'||'server='||reportservname, '_blank');
ELSE
message(' Error when running report ');
END IF;
END;


u can find report server name from
apppath\report\conf

then u wel find file has aname like this"rep_urmachinename_"urreportservername


Previous Topic: how URL is assigned to different users when forms apps is launched?
Next Topic: Application page error
Goto Forum:
  


Current Time: Thu Apr 17 08:49:41 CDT 2014

Total time taken to generate the page: 0.13405 seconds