Home » Server Options » Data Guard » Unable to start ACTIVE DATAGUARD (11g, 11.1.0, SOLARIS)
Unable to start ACTIVE DATAGUARD [message #448253] Mon, 22 March 2010 05:29 Go to next message
suresh.wst
Messages: 48
Registered: June 2008
Location: Hyderabad
Member
Hi,

I am unable to start ACTIVE DATAGUARD in 11g.

SQL> startup
ORACLE instance started.

Total System Global Area 522092544 bytes
Fixed Size 2090224 bytes
Variable Size 180362000 bytes
Database Buffers 331350016 bytes
Redo Buffers 8290304 bytes
Database mounted.
Database opened.
SQL> ALTER DATABASE RECOVER MANAGED STANDBY DATABASE USING CURRENT LOGFILE DISCONNECT;

Database altered.

SQL> select count(*) from scott.test;
select count(*) from scott.test
*
ERROR at line 1:
ORA-01219: database not open: queries allowed on fixed tables/views only


I dont know where I did mistake, Please help me out.

Thanks,
Suresh
Re: Unable to start ACTIVE DATAGUARD [message #448268 is a reply to message #448253] Mon, 22 March 2010 07:37 Go to previous messageGo to next message
Yasir Hashmi
Messages: 304
Registered: April 2006
Senior Member
Hi,
You already have started your datagaurd by the statement:
SQL> ALTER DATABASE RECOVER MANAGED STANDBY DATABASE USING CURRENT LOGFILE DISCONNECT;


IT seems even if your database is open for read only access once you this command,oracle puts the database in mount mode and start r edo/log apply.

As you cannot simuntaneously open the database and apply redo, you get the error as the database now is in mount mode.
Re: Unable to start ACTIVE DATAGUARD [message #448284 is a reply to message #448253] Mon, 22 March 2010 08:29 Go to previous messageGo to next message
John Watson
Messages: 6403
Registered: January 2010
Location: Global Village
Senior Member
Is your compatibility set to at least 11.0 ? Just a suggestion - I can't test the effect of having it lower at the moment.
Re: Unable to start ACTIVE DATAGUARD [message #448369 is a reply to message #448253] Tue, 23 March 2010 01:08 Go to previous messageGo to next message
goldenshot2727
Messages: 6
Registered: March 2010
Location: delhi
Junior Member

ok , it should work, which verison/release of oracle you are using?

try > startp open readonly---old 8i command to open the same.

Sahil sOni

Re: Unable to start ACTIVE DATAGUARD [message #448371 is a reply to message #448284] Tue, 23 March 2010 01:10 Go to previous messageGo to next message
suresh.wst
Messages: 48
Registered: June 2008
Location: Hyderabad
Member
I have changed compatible to 11.1.0. It is working now. Thanks!!

Suresh
Re: Unable to start ACTIVE DATAGUARD [message #448373 is a reply to message #448284] Tue, 23 March 2010 01:11 Go to previous messageGo to next message
suresh.wst
Messages: 48
Registered: June 2008
Location: Hyderabad
Member
Hi John,

I have changed compatible to 11.1.0, it is working now. Thanks!!

Suresh
Re: Unable to start ACTIVE DATAGUARD [message #448377 is a reply to message #448253] Tue, 23 March 2010 01:36 Go to previous message
Yasir Hashmi
Messages: 304
Registered: April 2006
Senior Member
Ahh!!
I didn't notice you were talking about active datagaurd in 10g.

Good to see its working now.
Previous Topic: drop and create log files
Next Topic: Truncate table effect on physical standby
Goto Forum:
  


Current Time: Fri Sep 30 14:03:49 CDT 2016

Total time taken to generate the page: 0.07200 seconds