Home » Developer & Programmer » Forms » Problem WebUtil 10.1.2.2 Forms 10.1.2.2.0 (WebUtil 10.1.2.2 Forms 10.1.2.2.0, Windows XP)
icon9.gif  Problem WebUtil 10.1.2.2 Forms 10.1.2.2.0 [message #447741] Wed, 17 March 2010 12:50 Go to next message
TheYanga
Messages: 6
Registered: March 2010
Junior Member

Dear all

I readed all Notes for install WebUtil, and configurate all steps.

But my forms WU_TEST_106.fmb don't run correctly.

When I Open the forms and show canvas WEBUTIL_CANVAS
I getting the error " FRM-13008: Cannot find JavaBean Whit name "oracle.forms.webutil.session.SessionFunctions" "

I downloaded the forms WEBUTILCONF.fmb
and I did not getting any error or warning.

I think about file frmwebutil.jar don't have all class necessary, but I don't know where download the correct frmwebutil.jar

The error on runtime on WU_TEST_106.fmb is "FRM-40735: WHEN TIME EXPIRED Trigger raised unhandled exception ORA-065508 "
and all tab don't work.


Thanks for you help.
I apologies for my bad English.

PD



-------------------
-------------------------------------------------------
System Information & Environment Variables
-------------------------------------------------------

java.vm.version : 1.4.2_06-b03
os.name : Windows XP
os.version : 5.1
java.class.path : C:\ORACLE_R12\j2ee\OC4J_BI_Forms\applications\formsapp\formsweb\WEB-INF\lib\frmsrv.jar;C:\ORACLE_R12\jlib\repository.jar;C:\ORACLE_R1 2\jlib\ldapjclnt10.jar;C:\ORACLE_R12\jlib\debugger.jar;C:\ORACLE_R12\jlib\ewt3.jar;C:\ORACLE_R12\jlib\share.jar;C:\ORACLE_R12\jlib\ut j.jar;C:\ORACLE_R12\jlib\zrclient.jar;C:\ORACLE_R12\reports\jlib\rwrun.jar;C:\ORACLE_R12\forms\java\frmwebutil.jar;C:\ORACLE_R12\form s\java\gmap.jar;C:\ORACLE_R12\forms\java\jacob.jar;C:\ORACLE_R12\forms\java\frmall.jar;C:\ORACLE_R12\jdk\jre\lib\rt.jar;
user.dir : C:\ORACLE_R12\forms
user.home : C:\Documents and Settings\mmonge
user.language : es
Forms Run from Developer Suite, Forms Version =10.1.2.2.0
PATH=C:\ORACLE_R12\bin;C:\ORACLE_R12\jdk\jre\bin\client
LD_LIBRARY_PATH=<not defined>
CLASSPATH=C:\ORACLE_R12\j2ee\OC4J_BI_Forms\applications\formsapp\formsweb\WEB-INF\lib\frmsrv.jar;C:\ORACLE_R12\jlib\repository.jar;C: \ORACLE_R12\jlib\ldapjclnt10.jar;C:\ORACLE_R12\jlib\debugger.jar;C:\ORACLE_R12\jlib\ewt3.jar;C:\ORACLE_R12\jlib\share.jar;C:\ORACLE_R 12\jlib\utj.jar;C:\ORACLE_R12\jlib\zrclient.jar;C:\ORACLE_R12\reports\jlib\rwrun.jar;C:\ORACLE_R12\forms\java\frmwebutil.jar;C:\ORACL E_R12\forms\java\gmap.jar;C:\ORACLE_R12\forms\java\jacob.jar;C:\ORACLE_R12\forms\java\frmall.jar;C:\ORACLE_R12\jdk\jre\lib\rt.jar
ORACLE_HOME=C:\ORACLE_R12
FORMS_PATH=C:\ORACLE_R12\forms
JAVA_HOME=<not defined>
ORACLE_PATH=<not defined>
TNS_ADMIN=<not defined>
WEBUTIL_CONFIG=C:\ORACLE_R12\forms\server\webutil.cfg
LD_ASSUME_KERNEL=<not defined>

------------------------------------
Checking virtual directory
------------------------------------
Virtual directory for webutil is defined in C:\ORACLE_R12\j2ee\DevSuite\application-deployments\forms\formsweb\orion-web.xml
<virtual-directory virtual-path="/webutil" real-path="C:\ORACLE_R12/forms/webutil" />

Checking the webutil directory .........
The directory "C:\ORACLE_R12/forms/webutil" exists ...

----------------------------------------
Check Forms Configuration File
----------------------------------------

Forms Configuration File Name: C:\ORACLE_R12/forms/server/formsweb.cfg

Webutil Configuration Section.......
[webutil]
WebUtilArchive=frmwebutil.jar,jacob.jar
WebUtilLogging=off
WebUtilLoggingDetail=normal
WebUtilErrorMode=Alert
WebUtilDispatchMonitorInterval=5
WebUtilTrustInternal=true
WebUtilMaxTransferSize=16384
baseHTMLjinitiator=webutiljini.htm
baseHTMLjpi=webutiljpi.htm
archive_jini=frmall_jinit.jar,frmwebutil.jar,jacob.jar
archive=frmall.jar
lookAndFeel=oracle


----------------------------------------
Check Webutil Environment File
----------------------------------------

Environment File Used: default.env
PATH=C:\ORACLE_R12\forms
LD_LIBRARY_PATH=<not defined>
CLASSPATH=C:\ORACLE_R12\j2ee\OC4J_BI_Forms\applications\formsapp\formsweb\WEB-INF\lib\frmsrv.jar;C:\ORACLE_R12\jlib\repository.jar;C: \ORACLE_R12\jlib\ldapjclnt10.jar;C:\ORACLE_R12\jlib\debugger.jar;C:\ORACLE_R12\jlib\ewt3.jar;C:\ORACLE_R12\jlib\share.jar;C:\ORACLE_R 12\jlib\utj.jar;C:\ORACLE_R12\jlib\zrclient.jar;C:\ORACLE_R12\reports\jlib\rwrun.jar;C:\ORACLE_R12\forms\java\frmwebutil.jar;C:\ORACL E_R12\forms\java\gmap.jar;C:\ORACLE_R12\forms\java\jacob.jar;C:\ORACLE_R12\forms\java\frmall.jar;C:\ORACLE_R12\jdk\jre\lib\rt.jar
ORACLE_HOME=C:\ORACLE_R12
FORMS_PATH=C:\ORACLE_R12\forms
JAVA_HOME=<not defined>
ORACLE_PATH=<not defined>
TNS_ADMIN=<not defined>
WEBUTIL_CONFIG=C:\ORACLE_R12\forms\server\webutil.cfg
LD_ASSUME_KERNEL=<not defined>

------------------------------------
Check necessary files
------------------------------------
The library file "webutil exists in C:\ORACLE_R12\forms ...

Checking neccessary DLL files.........
The DLL file "C:\ORACLE_R12/forms/webutil\jacob.dll" exists ...
The DLL file "C:\ORACLE_R12/forms/webutil\ffisamp.dll" exists ...
The DLL file "C:\ORACLE_R12/forms/webutil\d2kwut60.dll" exists ...
The DLL file "C:\ORACLE_R12/forms/webutil\JNIsharedstubs.dll" exists ...

Checking neccessary JAR files .........
The JAR file "C:\ORACLE_R12\forms\java\jacob.jar" exists ...
The JAR file "C:\ORACLE_R12\forms\java\frmwebutil.jar" exists ...

Checking neccessary Java Scripts For IE .........
The Java script file "C:\ORACLE_R12\forms\java\forms_base_ie.js" exists ...
The Java script file "C:\ORACLE_R12\forms\java\forms_ie.js" exists ...

Checking neccessary HTML files .........
The HTML file "C:\ORACLE_R12\forms\server\base.htm" exists ...
The HTML file "C:\ORACLE_R12\forms\server\webutiljini.htm" exists ...
The HTML file "C:\ORACLE_R12\forms\server\webutiljpi.htm" exists ...

--------------------------------------------------
Checking webutil configuration file
--------------------------------------------------
The webutil configuration file "C:\ORACLE_R12\forms\server\webutil.cfg" exists ...

--------------------------------------------------
Checking ffisamp.dll settings
--------------------------------------------------
The library ffisamp.dll is defined "install.syslib.0.user.1=ffisamp.dll|40960|1.0|true"..... passed

--------------------------------------------------
Check Upload / Download options
--------------------------------------------------
Transfer Work Area : c:\temp
Database Transfer is Enabled
Application Server Transfer is Enabled
Application Server Access Control is Disabled
==================================================
S U M M A R Y
==================================================
0 Error(s)

0 Warning(s)
-----------
Re: Problem WebUtil 10.1.2.2 Forms 10.1.2.2.0 [message #447787 is a reply to message #447741] Wed, 17 March 2010 20:30 Go to previous messageGo to next message
TheYanga
Messages: 6
Registered: March 2010
Junior Member

I download the patch p7384879_10123_GENERIC.zip
and copy the files frmwebutil.jar,frmall_jinit.jar and frmall.jar

And add three files to CLASSPATH on default.env
and regedit FORMS_BUILDER_CLASSPATH

And my bean show when I Open the form.

But when I run the forms show me the next Error:

oracle.forms.webutil.clientInfo.GetClientInfo bean not found
WEBUTIL_CLIENTINFO.GET_SYSTEM_PROPERTY will not work.

someone could help me ?

Thanks and advance.
icon6.gif  Re: Problem WebUtil 10.1.2.2 Forms 10.1.2.2.0 [message #448154 is a reply to message #447787] Fri, 19 March 2010 18:22 Go to previous messageGo to next message
TheYanga
Messages: 6
Registered: March 2010
Junior Member

My Problem was solved.

I desinstall all java from my pc and install only the JInitatior by default.

Because before when was run load JAVA 6 and not load jacob.jar and frmwebutil.jar

I hope that post could help some people.




Thanks.
Re: Problem WebUtil 10.1.2.2 Forms 10.1.2.2.0 [message #449643 is a reply to message #448154] Wed, 31 March 2010 03:18 Go to previous message
sherkhan@infodynamic.net
Messages: 28
Registered: August 2009
Location: dubai
Junior Member

Hi,

we are facing the same problem.
we have configured the webutl and was working fine.but when we applied patch 10.1.2.3 than webutil is not working . can you please guide me.

thanks ,
sher
Previous Topic: Summit supply schema 9i
Next Topic: Add Stack Canvas on a Tab Canvas
Goto Forum:
  


Current Time: Wed Sep 28 22:53:31 CDT 2016

Total time taken to generate the page: 0.14121 seconds