Home » Developer & Programmer » Application Express, ORDS & MOD_PLSQL » problem with running query in the application
problem with running query in the application [message #447675] Wed, 17 March 2010 05:30 Go to next message
swapna053
Messages: 18
Registered: March 2010
Junior Member
Hello ,

I am using oracle 10g apex 3.2.

I have assosiated 2 schema "vpmys and vp" with one workspace.
In the application , i created a new page of report ,which is assosiated with one schema called "vp" and i wish to run this query

select * from vpmys.t_devotees
minus
select * from vp.t_devotees

Same database dmp is installed in both schema except that the no of rows may be more or less in one database.So first i need to know the added rows and what are they and then insert the same no of rows.

But this doesnt run in the application.
But it runs in the SQL Command window.

Thanks
Swapna
Re: problem with running query in the application [message #447765 is a reply to message #447675] Wed, 17 March 2010 15:04 Go to previous messageGo to next message
dbhossain
Messages: 155
Registered: August 2007
Location: Dhaka
Senior Member

Dear Swapna ,

I didn't find any difficulty or problem to use MINUS in the query source. i would like to suggest you please check out the data type and the values in the both table that match for each query.


Note : For your better clarification you can find the Attachment of using MINUS in the SQL Query source in Apex application.


Thanks and Regards,

-- Kamal Hossain.
dbhossain@yahoo.com
Re: problem with running query in the application [message #447796 is a reply to message #447675] Wed, 17 March 2010 23:59 Go to previous messageGo to next message
swapna053
Messages: 18
Registered: March 2010
Junior Member
Hello ,

The problem is not with minus.The problem is both the tables exists in 2 different schemas?The application is installed in one schema
Re: problem with running query in the application [message #447823 is a reply to message #447796] Thu, 18 March 2010 02:52 Go to previous messageGo to next message
dbhossain
Messages: 155
Registered: August 2007
Location: Dhaka
Senior Member

OK.

If it is the issue of Different schemas. then you must map your database schemas with your workspace. You can assign multiple schema to your workspace.

log into Internal Workspace with Admin user.

Go to shared components > Manage Workspace > Select your workspace > click "Workspace to Schema Assignments"
Re: problem with running query in the application [message #447839 is a reply to message #447823] Thu, 18 March 2010 03:52 Go to previous messageGo to next message
dbhossain
Messages: 155
Registered: August 2007
Location: Dhaka
Senior Member

Hello :

I tried with different schema. problem is you can assign multiple schema to a specific workspace but you can assign only a default schema of a single user.

So, when you execute the query it finds and check the default schema.


Hope i can give you the way out. Let me work on it and I will let you know.

Thank you.

-- kamal Hossain

[Updated on: Thu, 18 March 2010 03:55]

Report message to a moderator

Re: problem with running query in the application [message #449690 is a reply to message #447839] Wed, 31 March 2010 08:15 Go to previous messageGo to next message
JRowbottom
Messages: 5933
Registered: June 2006
Location: Sunny North Yorkshire, ho...
Senior Member
Have you tried creating a private or public synonym for the table in the other schems.

Re: problem with running query in the application [message #454220 is a reply to message #449690] Tue, 04 May 2010 08:09 Go to previous messageGo to next message
dr.s.raghunathan
Messages: 540
Registered: February 2008
Senior Member
i tried it but it is not working with different user since not able to map the user with different schema
Re: problem with running query in the application [message #454417 is a reply to message #454220] Wed, 05 May 2010 08:08 Go to previous message
delna.sexy
Messages: 941
Registered: December 2008
Location: Surat, The Diamond City
Senior Member
I haven't used, but Database link may solve your problem.

regards,
Delna
Previous Topic: Import previous version into Application Express
Next Topic: using external table
Goto Forum:
  


Current Time: Sun Sep 25 02:35:37 CDT 2016

Total time taken to generate the page: 0.09328 seconds