Home » Server Options » RAC & Failsafe » Fail over in RAC (10gr2 RAC ASM 10gR2 DB)
Fail over in RAC [message #447420] Mon, 15 March 2010 03:48 Go to next message
farnaw4u
Messages: 22
Registered: October 2006
Location: pakistan
Junior Member
Hi all

I have two node 10g R2 RAC on Linux AS 4. I did the following steps to test fail over which i cant succeed ,I did consult internet and tutorial but all in vain. Kindly help me what is
Wrong .

Fail over Test scenario steps
Both RAC node are fully functional.HR and Accounts database is running.

1) From my laptop i connected to Db using sqlplus( Oracle 6i Forms are installed in Laptop)

SQL> connect accounts/tiger@oracle_taf
connected.

2) Similarly i connected accounts applications from laptop.. it Connected.

3)Moreover i Connected trough Toad (accounts/tiger@oracle_taf) it Connected.


I queried v$instance and found the three times i got connected to the second rac node "linux2"

Then

4) I connected to RAC NODE 2 and issued shutdown abort.


5) I revised steps 1,2,3 but could not get connected. it returned error " Host does not exist"


Following is the entry in my laptops forms tnsnames.ora

ORACLE_TAF =
(DESCRIPTION =
(ADDRESS = (PROTOCOL = TCP)(HOST = linux1-vip)(PORT = 1521))
(ADDRESS = (PROTOCOL = TCP)(HOST = linux2-vip)(PORT = 1521))
(LOAD_BALANCE = yes)
(CONNECT_DATA =
(SERVER = DEDICATED)
(SERVICE_NAME = oracle_taf)
(FAILOVER_MODE =
(TYPE = SELECT)
(METHOD = BASIC)
(RETRIES = 180)
(DELAY = 5)
)
)
)

THEN i put virtual IPS instead of name

ORACLE_TAF =
(DESCRIPTION =
(ADDRESS = (PROTOCOL = TCP)(HOST = 192.168.1.200)(PORT = 1521))
(ADDRESS = (PROTOCOL = TCP)(HOST = 192.168.1.201)(PORT = 1521))
(LOAD_BALANCE = yes)
(CONNECT_DATA =
(SERVER = DEDICATED)
(SERVICE_NAME = oracle_taf)
(FAILOVER_MODE =
(TYPE = SELECT)
(METHOD = BASIC)
(RETRIES = 180)
(DELAY = 5)
)
)
)
Re: Fail over in RAC [message #456123 is a reply to message #447420] Fri, 14 May 2010 15:16 Go to previous message
denissun
Messages: 3
Registered: July 2009
Junior Member
Has the mystery been solved?

Could it be remote_listener setting in your server tnsnames.ora file?
Previous Topic: Upgrade from 10r2 to 11r2
Next Topic: Regarding RAC Installation
Goto Forum:
  


Current Time: Wed Jul 30 03:34:59 CDT 2014

Total time taken to generate the page: 0.05547 seconds