Home » RDBMS Server » Networking and Gateways » setting Default Listener (oracle 11.2.0 red hat linux 5.4)
setting Default Listener [message #447056] Thu, 11 March 2010 13:12 Go to next message
oravijay
Messages: 43
Registered: March 2010
Member
Hi Everybody

I am using oracle 11.2.0 in linux platform
i have created a listener for the asm database.
and i am using non default port of 1525
whenever i go for lsnrctl>status
always shows for the port 1521
i dont want the default port 1521 and
i have changed the local listener as listener1 with port 1525 protool tcp in spfile and registered with the asm database.
Is there any option to change the default listener as listener1.

also,everytime when i give lsnrctl>show current_listener
it is showing "listener"

i have set the current-listener to listener1
and save_config listener1
and reloaded.

After exit and enter lsnrctl>status
it will show for port 1521

When i attempt to start listener1 every time. it will prompt listener1 is already running.

Kindly let me know what is my mistake,

Thanks in Advance
vijay











Re: setting Default Listener [message #447057 is a reply to message #447056] Thu, 11 March 2010 13:25 Go to previous messageGo to next message
BlackSwan
Messages: 21949
Registered: January 2009
Senior Member
>Kindly let me know what is my mistake,

With Oracle, details matter & you do/did not provide any/enough details.

you report that you invoke "lsnrctl" but we don't know from which ORACLE_HOME/bin was used.

You need to make sure that ORACLE_HOME & PATH contain the desired & consistent values to support the action(s) you desire.

It would be helpful if you followed Posting Guidelines - http://www.orafaq.com/forum/t/88153/0/

[Updated on: Thu, 11 March 2010 13:28]

Report message to a moderator

Re: setting Default Listener [message #447058 is a reply to message #447056] Thu, 11 March 2010 13:30 Go to previous messageGo to next message
Michel Cadot
Messages: 57612
Registered: March 2007
Location: Nanterre, France, http://...
Senior Member
Account Moderator
Michel Cadot wrote on Thu, 11 March 2010 19:52
Copy and paste what you have (in text mode and folllowing OraFAQ Forum Guide), does not explain it.

Regards
Michel


Same applies to this topic as well as in your other topics.

Re: setting Default Listener [message #447128 is a reply to message #447056] Thu, 11 March 2010 23:31 Go to previous messageGo to next message
oravijay
Messages: 43
Registered: March 2010
Member
LSNRCTL> show current
Current Listener is LISTENER
LSNRCTL> set current_listener rahs2listner
Current Listener is rahs2listner
LSNRCTL> save_config rahs2listener
Connecting to (DESCRIPTION=(ADDRESS=(PROTOCOL=TCP)(HOST=192.168.x.xx)(PORT=1525)))
No changes to save for RAHS2LISTENER.
The command completed successfully
LSNRCTL> show current_listener
Current Listener is rahs2listner
LSNRCTL> exit
[rahs2orcl@nixon dbhome_1]$ lsnrctl

LSNRCTL for Linux: Version 11.2.0.1.0 - Production on 12-MAR-2010 21:21:02

Copyright (c) 1991, 2009, Oracle. All rights reserved.

Welcome to LSNRCTL, type "help" for information.

LSNRCTL> show current_listener
Current Listener is LISTENER


I have registered the listener with database.


[rahs2orcl@nixon dbhome_1]$ sqlplus /nolog

SQL*Plus: Release 11.2.0.1.0 Production on Fri Mar 12 21:22:55 2010

Copyright (c) 1982, 2009, Oracle. All rights reserved.

SQL> connect / as sysdba
Connected.
SQL> alter system register;

System altered.

SQL> show parameter local_listener

NAME TYPE VALUE
------------------------------------ ----------- ------------------------------
local_listener string (address=(protocol=tcp)(host=1
92.168.x.xx)(port=1525))


Kindly let me know why my current_listener is changed often


Regards
vijay








Re: setting Default Listener [message #447131 is a reply to message #447056] Thu, 11 March 2010 23:34 Go to previous messageGo to next message
oravijay
Messages: 43
Registered: March 2010
Member

I have reloaded the rahs2listener also,but the current_listener is changing often.

LSNRCTL> show current
Current Listener is LISTENER
LSNRCTL> set current_listener RAHS2LISTENER
Current Listener is RAHS2LISTENER
LSNRCTL> SAVE_CONFIG RAHS2LISTENER
Connecting to (DESCRIPTION=(ADDRESS=(PROTOCOL=TCP)(HOST=192.168.6.56)(PORT=1525)))
No changes to save for RAHS2LISTENER.
The command completed successfully
LSNRCTL> RELOAD RAHS2LISTENER
Connecting to (DESCRIPTION=(ADDRESS=(PROTOCOL=TCP)(HOST=192.168.6.56)(PORT=1525)))
The command completed successfully
LSNRCTL> EXIT
[rahs2orcl@nixon dbhome_1]$ lsnrctl

LSNRCTL for Linux: Version 11.2.0.1.0 - Production on 12-MAR-2010 21:27:42

Copyright (c) 1991, 2009, Oracle. All rights reserved.

Welcome to LSNRCTL, type "help" for information.

LSNRCTL> show current_listener
Current Listener is LISTENER

Regards
vijay
Re: setting Default Listener [message #447138 is a reply to message #447056] Thu, 11 March 2010 23:53 Go to previous messageGo to next message
oravijay
Messages: 43
Registered: March 2010
Member
Hi Every body

I have installed oracle 11.2.0 in red hat 5.4 and i have created a asm database
This database having 2 oracle_homes. they are
1) /u01/app/oracle/product/11.2.0/dbhome_1
2) /u01/app/oracle/product/11.2.0/grid

Also i am using Enterprise manager, which oracle home it will access, and which oracle home that i have to access

please advise

Regards
vijay
Re: setting Default Listener [message #447140 is a reply to message #447138] Thu, 11 March 2010 23:58 Go to previous messageGo to next message
BlackSwan
Messages: 21949
Registered: January 2009
Senior Member
>Also i am using Enterprise manager, which oracle home it will access, and which oracle home that i have to access

To which instance do you want EM to access?
It is your choice.
Re: setting Default Listener [message #447145 is a reply to message #447056] Fri, 12 March 2010 00:08 Go to previous messageGo to next message
oravijay
Messages: 43
Registered: March 2010
Member
Thanks

i want to use grid instance to access EM

but i cant able to set current listener.
It is changing often

Regards
vijay
Re: setting Default Listener [message #447212 is a reply to message #447056] Fri, 12 March 2010 07:01 Go to previous message
John Watson
Messages: 4082
Registered: January 2010
Location: Global Village
Senior Member
If you installed the full 11.2 Grid infrastructure, the environment is quite complicated. You would have SCAN listeners and a node listener (on different VIPs) and an ASM instance (note that you cannot have an ASM database, so you can't have created one), all running from the Grid home. Your RDBMS instance will be running from the database home.
When you installed, what option did you take? Was it "Install and configure grid infrastructure for a cluster" or "Install and configure grid infrastructure for a standalone server"? And did you choose to configure "Grid plug and play"?
Previous Topic: TNS Adopter Protocol error
Next Topic: create DATABASE LINK
Goto Forum:
  


Current Time: Sun Apr 20 01:14:34 CDT 2014

Total time taken to generate the page: 0.07259 seconds