Home » SQL & PL/SQL » Client Tools » Database won't start
Database won't start [message #446875] Wed, 10 March 2010 20:10 Go to next message
ridhi_sundar
Messages: 184
Registered: November 2007
Location: Bangalore
Senior Member
I am facing the problem in windows 7. I have oracle client 10g installed. When i run sqlplus from comand prompt it gives the error as:
C:\Users\srirams>sqlplus
SP2-1503: Unable to initialize Oracle call interface
SP2-0152: ORACLE may not be functioning properly

When I select the executable 'sql+' and run as administrator it works fine. Please if any one can give some light...

Thanks
Ridhi Sundar

Re: Database won't start [message #446877 is a reply to message #446875] Wed, 10 March 2010 20:15 Go to previous messageGo to next message
BlackSwan
Messages: 24912
Registered: January 2009
Senior Member
>I am facing the problem in windows 7. I have oracle client 10g installed.

Not a supported configuration.

>When I select the executable 'sql+' and run as administrator it works fine.

Multiple problems involving ENVIRONMENTAL VARIABLE differences & file ownership & OS protection issues.
Re: Database won't start [message #446906 is a reply to message #446875] Wed, 10 March 2010 23:38 Go to previous messageGo to next message
ramoradba
Messages: 2454
Registered: January 2009
Location: AndhraPradesh,Hyderabad,I...
Senior Member
1)whats your database version? (not the client)
2)Os which edition ?
3) Client which version ?(with 4 digits)
have a look at this....http://forums.oracle.com/forums/thread.jspa?threadID=338426
Quote:
Multiple problems involving ENVIRONMENTAL VARIABLE differences & file ownership & OS protection issues.
.

I have installed Oracle 11g in windows home primium edition and it is working without any problem (Not supported By Oracle)

sriram Smile

Re: Database won't start [message #447023 is a reply to message #446906] Thu, 11 March 2010 10:37 Go to previous messageGo to next message
ridhi_sundar
Messages: 184
Registered: November 2007
Location: Bangalore
Senior Member
Hi Sriram


-->Problem is not with the Database it is with client.

I am getting problem when trying to put sqlplus comand it tries to run sqlplus from the client.

-->OS is professional edition

--> client is 10.2.0.1

Thanks
Ridhi Sundar
Re: Database won't start [message #447038 is a reply to message #447023] Thu, 11 March 2010 11:45 Go to previous messageGo to next message
BlackSwan
Messages: 24912
Registered: January 2009
Senior Member
It would be helpful if you followed Posting Guidelines - http://www.orafaq.com/forum/t/88153/0/

>I am getting problem when trying to put sqlplus comand it tries to run sqlplus from the client.

My car is having a problem & won't go.
Tell me how to make my car go.
Re: Database won't start [message #447055 is a reply to message #447038] Thu, 11 March 2010 13:10 Go to previous messageGo to next message
ridhi_sundar
Messages: 184
Registered: November 2007
Location: Bangalore
Senior Member
On my 1st post itself I have given what error I am getting when i invoke sqlplus. I have given my OS version, Oracle client version. Any thing else you need me to specify? If so can you please clearly mention what information you need instead of putting these irrelevant words?

Thanks
Ridhi Sundar
Re: Database won't start [message #447059 is a reply to message #447055] Thu, 11 March 2010 13:33 Go to previous message
BlackSwan
Messages: 24912
Registered: January 2009
Senior Member
issue following command from both OS users; one that works & one that fails

SET

compare & contrast the results and fix what is wrong/different
Previous Topic: ORA-01031 and ORA-01034
Next Topic: Erwin tool installation / which one to install
Goto Forum:
  


Current Time: Thu Sep 29 05:37:01 CDT 2016

Total time taken to generate the page: 0.05024 seconds