Home » SQL & PL/SQL » Client Tools » ORA-01031 and ORA-01034 (Oracle 9i, WinXP)
icon4.gif  ORA-01031 and ORA-01034 [message #446819] Wed, 10 March 2010 10:54 Go to next message
imsaikat50
Messages: 8
Registered: March 2010
Junior Member
here is what I did actually...

C:\>oradim -new -sid Test100 -srvc OracleServiceTest100 -startmode a -pfile 'c:\oracle\ora92\database\inittest100.ora'

C:\>orapwd file=c:\oracle\ora92\database\PWDtest100.ora password=sys entries=2

C:\>set oracle_sid=test100

C:\>sqlplus /nolog

SQL*Plus: Release 9.2.0.1.0 - Production on Wed Mar 10 22:42:43 2010

Copyright (c) 1982, 2002, Oracle Corporation. All rights reserved.

SQL> conn /as sysdba
ERROR:
ORA-01031: insufficient privileges



SQL> conn sys/sys as sysdba
Connected to an idle instance.
SQL> startup nomount
ORA-01031: insufficient privileges

SQL> @f:\oracle\testdb.sql
create database TEST100
*
ERROR at line 1:
ORA-01034: ORACLE not available



i just tried to set up a new database called Test100 manually.
but i could not do anything here for these messages.

can any one help me on this issue .... my OS is winxp sp2.
Re: ORA-01031 and ORA-01034 [message #446823 is a reply to message #446819] Wed, 10 March 2010 10:59 Go to previous messageGo to next message
Michel Cadot
Messages: 63804
Registered: March 2007
Location: Nanterre, France, http://...
Senior Member
Account Moderator
And how's your previous topic? Did you solve it?
If so, a feedback should be welcome, I'm waiting for it before going on this one.
http://www.orafaq.com/forum/m/446614/102589/#msg_446614

Regards
Michel

[Updated on: Wed, 10 March 2010 11:00]

Report message to a moderator

Re: ORA-01031 and ORA-01034 [message #446829 is a reply to message #446823] Wed, 10 March 2010 11:11 Go to previous messageGo to next message
imsaikat50
Messages: 8
Registered: March 2010
Junior Member
no sir i could not resolve it.i need to re install Oracle but it did not worked even then.I deleted all registry entries also. lastly i had to re-install my OS. now i have no problem with Oradim commands. all commands are successfully completed now.

anyway, thanks for your kind information and advices.

however, can you help me on the current issue?
Re: ORA-01031 and ORA-01034 [message #446833 is a reply to message #446829] Wed, 10 March 2010 11:39 Go to previous messageGo to next message
Michel Cadot
Messages: 63804
Registered: March 2007
Location: Nanterre, France, http://...
Senior Member
Account Moderator
Are you sure your service is up?
Are you sure your current user is in ORA_DBA OS group?

Regards
Michel
icon4.gif  Re: ORA-01031 and ORA-01034 [message #446835 is a reply to message #446829] Wed, 10 March 2010 11:46 Go to previous messageGo to next message
imsaikat50
Messages: 8
Registered: March 2010
Junior Member
Now I found in the OraDIM.log file the following:

Wed Mar 10 23:37:56 2010
Instance deleted.
Wed Mar 10 23:40:04 2010
ORA-01078: failure in processing system parameters

Wed Mar 10 23:40:08 2010
Instance created.



and my pfile(initTest.ora) contains the following parameters :

db_name='Test100'
db_block_size=4096
db_cache_size=10M
background_dump_dest=C:\oracle\admin\Test100\bdump
core_dump_dest=C:\oracle\admin\Test100\cdump
user_dump_dest=C:\oracle\admin\Test100\udump
remote_login_passwordfile=none
control_files=C:\oracle\oradata\Test100\CONTROL01.CTL
java_pool_size=33554432
large_pool_size=8388608
shared_pool_size=50331648
log_buffer=102400
undo_management=AUTO
undo_tablespace=UNDOTBS
compatible=9.2.0.0


is there really any problem in the parameters ?
Re: ORA-01031 and ORA-01034 [message #446837 is a reply to message #446835] Wed, 10 March 2010 11:57 Go to previous messageGo to next message
Michel Cadot
Messages: 63804
Registered: March 2007
Location: Nanterre, France, http://...
Senior Member
Account Moderator
Quote:
my pfile(initTest.ora) contains

Quote:
pfile 'c:\oracle\ora92\database\inittest100.ora'

Are you sure you look at the correct file?

Regards
Michel
icon4.gif  Re: ORA-01031 and ORA-01034 [message #446842 is a reply to message #446819] Wed, 10 March 2010 12:19 Go to previous messageGo to next message
imsaikat50
Messages: 8
Registered: March 2010
Junior Member
yes. that was just a spelling mistake.

The contents are from inittest100.ora.
Re: ORA-01031 and ORA-01034 [message #446845 is a reply to message #446842] Wed, 10 March 2010 12:27 Go to previous messageGo to next message
Michel Cadot
Messages: 63804
Registered: March 2007
Location: Nanterre, France, http://...
Senior Member
Account Moderator
For me db_name value does not contain quote but directories and control_files (which MUST be multiplexed) do.
Check each parameter against the documentation.

Regards
Michel
icon4.gif  Re: ORA-01031 and ORA-01034 [message #446855 is a reply to message #446845] Wed, 10 March 2010 12:47 Go to previous messageGo to next message
imsaikat50
Messages: 8
Registered: March 2010
Junior Member
i have changed the parameters as per your suggestion but still getting the following error:


Thu Mar 11 00:43:06 2010
ORA-01034: ORACLE not available
ORA-27101: shared memory realm does not exist

Thu Mar 11 00:43:06 2010
Instance deleted.
Thu Mar 11 00:43:10 2010
ORA-01078: failure in processing system parameters

Thu Mar 11 00:43:14 2010
Instance created.


my latest PFile contains:

db_name=Test100
db_block_size=4096
db_cache_size=10M
background_dump_dest='C:\oracle\admin\Test100\bdump'
core_dump_dest='C:\oracle\admin\Test100\cdump'
user_dump_dest='C:\oracle\admin\Test100\udump'
remote_login_passwordfile=none
control_files=('C:\oracle\oradata\Test100\CONTROL01.CTL','C:\oracle\oradata\Test100\CONTROL02.CTL')
shared_pool_size=50331648
java_pool_size=33554432
large_pool_size=8388608
log_buffer=102400
undo_management=AUTO
undo_tablespace=UNDOTBS
compatible=9.2.0.1.0
Re: ORA-01031 and ORA-01034 [message #446879 is a reply to message #446855] Wed, 10 March 2010 21:13 Go to previous message
BlackSwan
Messages: 24905
Registered: January 2009
Senior Member
>Thu Mar 11 00:43:14 2010
>Instance created.

Congratulations on new DB!
Previous Topic: Loop Select Statement
Next Topic: Database won't start
Goto Forum:
  


Current Time: Mon Sep 26 21:28:35 CDT 2016

Total time taken to generate the page: 0.11478 seconds