Home » Server Options » RAC & Failsafe » Precheck for cluster installation--failed (Oracle 10g Linux x86-64)
Precheck for cluster installation--failed [message #446556] Tue, 09 March 2010 05:53 Go to next message
arunshrish
Messages: 74
Registered: May 2008
Location: Chennai
Member
Hi all,

While I run the cluster installation pre check command as below,

./cluvfy stage -pre crsinst -n "pmwdbdwh01,pmwdbdwh02" -verbose

I get the following message ,

Check: Hard resource limit for "open file descriptors"
Node Name Available Required Comment
------------ ------------------------ ------------------------ ----------
pmwdbdwh02 63536 65536 failed
pmwdbdwh01 63536 65536 failed
Result: Hard resource limit check failed for "open file descriptors".


Can someone please help me out to clear this failure.

Thanks in advance,
Arun
Re: Precheck for cluster installation--failed [message #446574 is a reply to message #446556] Tue, 09 March 2010 06:24 Go to previous messageGo to next message
John Watson
Messages: 4677
Registered: January 2010
Location: Global Village
Senior Member
You can ignore this, it will not cause the installation to fail. It will show up again when you run OUI, but don't worry. Of course if you do need that many open files, you will need to fix it eventually: it is referring to your fs_file-max kernel parameter.
Re: Precheck for cluster installation--failed [message #446581 is a reply to message #446574] Tue, 09 March 2010 06:52 Go to previous messageGo to next message
arunshrish
Messages: 74
Registered: May 2008
Location: Chennai
Member
Hi John,

Thanks for the reply. I checked sysctl.conf file and couldnt find the parameter that you mentioned.

So If I add fs_file-max parameter to sysctl.conf file will it be fine?

Thanks,
Arun.
Re: Precheck for cluster installation--failed [message #446638 is a reply to message #446581] Tue, 09 March 2010 14:43 Go to previous message
John Watson
Messages: 4677
Registered: January 2010
Location: Global Village
Senior Member
Sure. Though I see I made a typo, it is actually fs.file-max which will be why you couldn't find it.
Remember that you may need to adjust your ulimit to get rid of any limits and add a couple of entries to your /etc/security/limits.conf file too, this should do:

* hard nofile 65536
* soft nofile 4096
* hard nproc 16384
* soft nproc 2047

Previous Topic: Action_script for Windows?
Next Topic: RAC Setup
Goto Forum:
  


Current Time: Wed Oct 22 08:22:01 CDT 2014

Total time taken to generate the page: 0.05485 seconds