Home » SQL & PL/SQL » Client Tools » Table or view does not exist (Toad, 9.1.0.62, Windows 2003 server R2)
Table or view does not exist [message #445387] Mon, 01 March 2010 06:35 Go to next message
srini_thiru
Messages: 133
Registered: May 2008
Senior Member

Hi,

In toad 9.1.0.62 version, when i open a package in schema browser. It shows table or view doesn't exist.

But the package seems to be in valid state.

I also used other schema's to open that schema packages it opens with no problems.

Please help.

Re: Table or view does not exist [message #445388 is a reply to message #445387] Mon, 01 March 2010 06:37 Go to previous messageGo to next message
cookiemonster
Messages: 12321
Registered: September 2008
Location: Rainy Manchester
Senior Member
Try compiling the package with sqlplus
Re: Table or view does not exist [message #445393 is a reply to message #445388] Mon, 01 March 2010 08:20 Go to previous messageGo to next message
srini_thiru
Messages: 133
Registered: May 2008
Senior Member

The package is already in the valid state. I want to view the code of that package. When i click the package in toad --> Schema browser --> packages. It show table or view doesn't exist.

Re: Table or view does not exist [message #445394 is a reply to message #445387] Mon, 01 March 2010 08:24 Go to previous messageGo to next message
cookiemonster
Messages: 12321
Registered: September 2008
Location: Rainy Manchester
Senior Member
Then it sounds like a bug in your version of TOAD. In which case you'd be better off using Quests forums.
Re: Table or view does not exist [message #445401 is a reply to message #445394] Mon, 01 March 2010 09:32 Go to previous messageGo to next message
srini_thiru
Messages: 133
Registered: May 2008
Senior Member

Thanks for your direction.

But when i grant DBA privilege to that user then i can view the package. It sounds like some privilege needed to view the packages of own schema.

Re: Table or view does not exist [message #445402 is a reply to message #445401] Mon, 01 March 2010 09:35 Go to previous message
BlackSwan
Messages: 24915
Registered: January 2009
Senior Member
> It sounds like some privilege needed to view the packages of own schema.

or logged in schema is really not owner of package.
Previous Topic: cant connect to isql plus
Next Topic: Run Toad off a USB Flash
Goto Forum:
  


Current Time: Sat Oct 01 07:36:45 CDT 2016

Total time taken to generate the page: 0.08588 seconds