Home » Developer & Programmer » Forms » /oas/product/j2ee/OC4J_BI_Forms/applications/formsapp/formsweb/WEB-INF/lib/frmsrv.jar: (webutil)
/oas/product/j2ee/OC4J_BI_Forms/applications/formsapp/formsweb/WEB-INF/lib/frmsrv.jar: [message #445312] Sun, 28 February 2010 08:33 Go to next message
morchid21
Messages: 12
Registered: November 2009
Location: casablanca
Junior Member
Hello,

When I try to download file from client to server a found the following error.
/oas/product/j2ee/OC4J_BI_Forms/applications/formsapp/formsweb/WEB-INF/lib/frmsrv.jar:
Please ca, some one help me to solve this.

Regards
Re: /oas/product/j2ee/OC4J_BI_Forms/applications/formsapp/formsweb/WEB-INF/lib/frmsrv.jar: [message #445313 is a reply to message #445312] Sun, 28 February 2010 08:42 Go to previous messageGo to next message
Michel Cadot
Messages: 64120
Registered: March 2007
Location: Nanterre, France, http://...
Senior Member
Account Moderator
This is not an error, this is the name of a file.
Post more of you have.

Regards
Michel
Re: /oas/product/j2ee/OC4J_BI_Forms/applications/formsapp/formsweb/WEB-INF/lib/frmsrv.jar: [message #445315 is a reply to message #445313] Sun, 28 February 2010 08:55 Go to previous messageGo to next message
morchid21
Messages: 12
Registered: November 2009
Location: casablanca
Junior Member
this is the error that webutil generate no more clarification also in the log that I craete I found only the following line, I don't know what's the problem, I hope that you can help me.
172.20.15.47:amorchid: /oas/product/j2ee/OC4J_BI_Forms/applications/formsapp/formsweb/WEB-INF/lib/frmsrv.jar:
Re: /oas/product/j2ee/OC4J_BI_Forms/applications/formsapp/formsweb/WEB-INF/lib/frmsrv.jar: [message #445324 is a reply to message #445312] Sun, 28 February 2010 12:17 Go to previous messageGo to next message
morchid21
Messages: 12
Registered: November 2009
Location: casablanca
Junior Member
for more information i m using oas 10.1.2.3, and webutil in order to exchange data beetwen client and server, but when I try to execute a transfer to oas webutil_file_transfer.Client_To_AS_with_progress the error message occured : /oas/product/j2ee/OC4J_BI_Forms/applications/formsapp/formsweb/WEB-INF/lib/frmsrv.jar:
I don't know why. Please I need your help.
Re: /oas/product/j2ee/OC4J_BI_Forms/applications/formsapp/formsweb/WEB-INF/lib/frmsrv.jar: [message #445338 is a reply to message #445324] Sun, 28 February 2010 23:12 Go to previous messageGo to next message
tamzidulamin
Messages: 132
Registered: October 2009
Location: Dhaka
Senior Member
post your webutil_file_transfer.Client_To_AS_with_progress
code.


Tamzidul Amin.
Re: /oas/product/j2ee/OC4J_BI_Forms/applications/formsapp/formsweb/WEB-INF/lib/frmsrv.jar: [message #445342 is a reply to message #445312] Sun, 28 February 2010 23:38 Go to previous messageGo to next message
morchid21
Messages: 12
Registered: November 2009
Location: casablanca
Junior Member
This is my procedure, as in webutil demo.

PROCEDURE UPLOAD_AS IS
l_success boolean;
l_bare_filename varchar2(50);
BEGIN
l_bare_filename := substr(:upload.file_name,instr(:upload.file_name,'\',-1)+1);
message('l_bare_filename = '||l_bare_filename);pause;
message('serverFile = '||'/pcard20/hpsweb/letters/'||l_bare_filename);pause;
l_success := webutil_file_transfer.Client_To_AS_with_progress
(clientFile => :upload.file_name
,serverFile => '/pcard20/hpsweb/letters/'||l_bare_filename
,progressTitle => 'Upload to Application Server in progress'
,progressSubTitle => 'Please wait'
,asynchronous => false
,callbackTrigger => null
);
if l_success
then
message('File uploaded successfully to the Application Server');
else
message('File upload to Application Server failed');
end if;

exception
when others
then
message('File upload failed: '||sqlerrm);


END;
Re: /oas/product/j2ee/OC4J_BI_Forms/applications/formsapp/formsweb/WEB-INF/lib/frmsrv.jar: [message #447391 is a reply to message #445342] Mon, 15 March 2010 00:40 Go to previous messageGo to next message
djmartin
Messages: 10180
Registered: March 2005
Location: Canberra ACT Australia
Senior Member
Account Moderator
Sorry that I have been so long in replying. Have you solved your problem?

In future, please use 'code' tags around your code.

David
Re: /oas/product/j2ee/OC4J_BI_Forms/applications/formsapp/formsweb/WEB-INF/lib/frmsrv.jar: [message #447418 is a reply to message #445312] Mon, 15 March 2010 03:32 Go to previous messageGo to next message
morchid21
Messages: 12
Registered: November 2009
Location: casablanca
Junior Member
Hi,

Not yet, I can't found solution to my problem if someone can help me that will be great,

thank's in advance.

Rergards;

Re: /oas/product/j2ee/OC4J_BI_Forms/applications/formsapp/formsweb/WEB-INF/lib/frmsrv.jar: [message #448547 is a reply to message #447418] Wed, 24 March 2010 01:07 Go to previous message
djmartin
Messages: 10180
Registered: March 2005
Location: Canberra ACT Australia
Senior Member
Account Moderator
Does it fail if the file name is not more than 8.3 characters?

Please place a 'pause' command after your 'after transfer' message so that the screen will be refreshed. What is the error that is displayed on the screen. Perhaps use a screen shot (trimmed and saved as a 'jpg') to show us what is being displayed.

David
Previous Topic: store PDF in the database
Next Topic: FORMS ERROR PDE-PLI018 (merged 4)
Goto Forum:
  


Current Time: Tue Dec 06 12:32:03 CST 2016

Total time taken to generate the page: 0.13634 seconds