Home » RDBMS Server » Server Administration » Error in creating database
Error in creating database [message #443707] Wed, 17 February 2010 01:30 Go to next message
babar82
Messages: 108
Registered: March 2009
Location: Karachi
Senior Member
Hi,
I have created a database in Oracle10g which is working fine. Now when I try to create another the system gives the following error.

ORA-12560: TNS protocol adapter error.

kindly help
Re: Error in creating database [message #443713 is a reply to message #443707] Wed, 17 February 2010 01:43 Go to previous messageGo to next message
ramoradba
Messages: 2454
Registered: January 2009
Location: AndhraPradesh,Hyderabad,I...
Senior Member
Please dont multi post your Question.

Don`t say anything Just show What you tried....


sriram Smile
Re: Error in creating database [message #443718 is a reply to message #443707] Wed, 17 February 2010 01:55 Go to previous messageGo to next message
Michel Cadot
Messages: 64103
Registered: March 2007
Location: Nanterre, France, http://...
Senior Member
Account Moderator
Correctly set ORACLE_HOME and ORACLE_SID.

Regards
Michel
Re: Error in creating database [message #443778 is a reply to message #443718] Wed, 17 February 2010 05:08 Go to previous messageGo to next message
babar82
Messages: 108
Registered: March 2009
Location: Karachi
Senior Member
can u write the commands.
Re: Error in creating database [message #443780 is a reply to message #443778] Wed, 17 February 2010 05:23 Go to previous messageGo to next message
Michel Cadot
Messages: 64103
Registered: March 2007
Location: Nanterre, France, http://...
Senior Member
Account Moderator
I can't as you don't specify your OS.

Regards
Michel
Re: Error in creating database [message #443841 is a reply to message #443707] Wed, 17 February 2010 10:08 Go to previous messageGo to next message
BlackSwan
Messages: 25036
Registered: January 2009
Location: SoCal
Senior Member
>I have created a database in Oracle10g which is working fine. Now when I try to create another the system gives the following error.
>ORA-12560: TNS protocol adapter error.

Is any type of Operating System Vitrualization installed on this system?
Re: Error in creating database [message #443900 is a reply to message #443841] Wed, 17 February 2010 23:35 Go to previous messageGo to next message
babar82
Messages: 108
Registered: March 2009
Location: Karachi
Senior Member
Well when I set the SID and HOME the database is created, but do I need to set it every time I start my computer because when I have checked the SID and HOME the system show the following SID and HOME

SID: %ORACLE_SID%
HOME: %ORACLE_HOME%
Re: Error in creating database [message #443913 is a reply to message #443900] Thu, 18 February 2010 00:22 Go to previous messageGo to next message
Michel Cadot
Messages: 64103
Registered: March 2007
Location: Nanterre, France, http://...
Senior Member
Account Moderator
Use a DOS box, post the result of SET, execute sqlplus and post the result (post means copy and paste in text not screen shot).

Regards
Michel

[Updated on: Thu, 18 February 2010 00:23]

Report message to a moderator

Re: Error in creating database [message #445961 is a reply to message #443707] Thu, 04 March 2010 22:33 Go to previous message
lalitm_2003
Messages: 86
Registered: May 2005
Location: delhi
Member
Hi Barbar82,
Not sure how exactly you are setting the environment variables.
On windows, The other way you can choose to set the oracle_sid and oracle_home permanently is under you environment variables.
Then you need not to set the oracle_sid and oracle_home everytime when you start your computer.

c:>echo %ORACLE_SID%
lm



And as Michel asked to send the output of set command will confirm you environment variable setting after the changes.
C:\Documents and Settings\Administrator>set
NUMBER_OF_PROCESSORS=1
oracle_sid=lm
...
Previous Topic: Parallel
Next Topic: Oudated alert log
Goto Forum:
  


Current Time: Sun Dec 04 04:24:07 CST 2016

Total time taken to generate the page: 0.13722 seconds