Home » RDBMS Server » Networking and Gateways » ORA-12560 Protocol Adapter error (Client 10.1.0.4.2 EM 10.1.0.4.0)
ORA-12560 Protocol Adapter error [message #443550] Tue, 16 February 2010 03:40 Go to next message
chekov
Messages: 4
Registered: September 2009
Location: Netherlands
Junior Member
Hello can anyone help?

I am trying to connect via SQLPLUS to the standalone oracle database i have installed details as follows:

Host DT1089.myname.local
Database emrep.myname.local
Instance emrep
In EM database is up and running OK

Tnsnames is located at C:\OracleHomes\db10g\NETWORK\ADMIN

EMREP =
(DESCRIPTION =
(ADDRESS = (PROTOCOL = TCP)(HOST = DT-1089.myname.local)(PORT = 1521))
(CONNECT_DATA =
(SERVER = DEDICATED)
(SERVICE_NAME = emrep.myname.local)
)
)

I try to log on with command line
C:> sqlplus system/***** @ emrep
**** = password for user system

but get the following error:
ORA-12560 Protocol Adapter error

Can anyone tell what the problem might be here

Thanks in advance




Re: ORA-12560 Protocol Adapter error [message #443555 is a reply to message #443550] Tue, 16 February 2010 04:30 Go to previous messageGo to next message
ramoradba
Messages: 2452
Registered: January 2009
Location: AndhraPradesh,Hyderabad,I...
Senior Member
Z:\>sqlplus scott/tejateja

SQL*Plus: Release 10.2.0.1.0 - Production on Tue Feb 16 15:58:09 2010

Copyright (c) 1982, 2005, Oracle.  All rights reserved.

ERROR:
ORA-12560: TNS:protocol adapter error


Z:\>set oracle_sid=satya

Z:\>sqlplus scott/tejateja

SQL*Plus: Release 10.2.0.1.0 - Production on Tue Feb 16 15:58:53 2010

Copyright (c) 1982, 2005, Oracle.  All rights reserved.


Connected to:
Oracle Database 10g Enterprise Edition Release 10.2.0.1.0 - Production
With the Partitioning, OLAP and Data Mining options

SQL>

Quote:

ORA-12560: TNS:protocol adapter error
Cause: A generic protocol adapter error occurred.

Action: Check addresses used for proper protocol specification. Before reporting this error,
look at the error stack and check for lower level transport errors.
For further details, turn on tracing and reexecute the operation.
Turn off tracing when the operation is complete.


Check your service name.
Execute tnsping emrep
and post the details.

sriram Smile

[Updated on: Tue, 16 February 2010 04:31]

Report message to a moderator

Re: ORA-12560 Protocol Adapter error [message #443560 is a reply to message #443550] Tue, 16 February 2010 04:59 Go to previous messageGo to next message
chekov
Messages: 4
Registered: September 2009
Location: Netherlands
Junior Member
Hi

tried this but it still doesnt work - same error message

The strange thing is that i can connect with SQL developer
with settings

Hostname: DT-1089.myname.local
Port 1521
SID emrep

However there the connection tpye is with the system user id but with BASIC connection type and Role DEFAULT

Note that both client and dbase are on the same physical machine

AP
Re: ORA-12560 Protocol Adapter error [message #443614 is a reply to message #443560] Tue, 16 February 2010 08:52 Go to previous messageGo to next message
BlackSwan
Messages: 22792
Registered: January 2009
Senior Member
post results of following command


SET
Re: ORA-12560 Protocol Adapter error [message #443754 is a reply to message #443560] Wed, 17 February 2010 03:53 Go to previous messageGo to next message
chekov
Messages: 4
Registered: September 2009
Location: Netherlands
Junior Member
ALLUSERSPROFILE=C:\Documents and Settings\All Users
CI_HOLOS_CLI=C:\Program Files\Seagate Software\Open Olap\
ClusterLog=C:\WINDOWS\Cluster\cluster.log
CommonProgramFiles=C:\Program Files\Common Files
COMPUTERNAME=DT-1089
ComSpec=C:\WINDOWS\system32\cmd.exe
DEFLOGDIR=C:\Documents and Settings\All Users\Application Data\McAfee\DesktopPro
tection
Fop093Location=C:\Program Files\Common Files\Sevensteps\fop-0.93
FopLocation=C:\Program Files\Common Files\Sevensteps\fop-0.20.5
FP_NO_HOST_CHECK=NO
HOMEDRIVE=C:
invPtr=C:\OracleHomes\agent10g\oraInst.loc
LOGONSERVER=\\VD1DS123
NUMBER_OF_PROCESSORS=4
oracle_sid=emrep
OS=Windows_NT
Path=C:\OracleHomes\agent10g\jlib;C:\OracleHomes\agent10g\bin;C:\OracleHomes\oms
10g\bin;C:\OracleHomes\oms10g\jlib;C:\Program Files\Seagate Software\NOTES\;C:\P
rogram Files\Seagate Software\NOTES\DATA\;C:\WINDOWS\system32;C:\WINDOWS;C:\WIND
OWS\System32\Wbem;C:\Program Files\Common Files\Sevensteps\LEADTools\;c:\Program
Files\Microsoft SQL Server\90\Tools\binn\;C:\Program Files\Common Files\Adobe\A
GL;C:\B7\system\bin32;C:\B7\DEMO\bin32
PATHEXT=.COM;.EXE;.BAT;.CMD;.VBS;.VBE;.JS;.JSE;.WSF;.WSH
PERL5LIB=C:\OracleHomes\oms10g\perl\5.6.1\lib\MSWin32-x86;C:\OracleHomes\oms10g\
perl\5.6.1\lib;C:\OracleHomes\oms10g\perl\5.6.1\lib\MSWin32-x86;C:\OracleHomes\o
ms10g\perl\site\5.6.1;C:\OracleHomes\oms10g\perl\site\5.6.1\lib;C:\OracleHomes\o
ms10g\sysman\admin\scripts
PROCESSOR_ARCHITECTURE=x86
PROCESSOR_IDENTIFIER=x86 Family 6 Model 15 Stepping 11, GenuineIntel
PROCESSOR_LEVEL=6
PROCESSOR_REVISION=0f0b
ProgramFiles=C:\Program Files
PROMPT=$P$G
SESSIONNAME=Console
SystemDrive=C:
SystemRoot=C:\WINDOWS
VS90COMNTOOLS=C:\Program Files\Microsoft Visual Studio 9.0\Common7\Tools\
VSEDEFLOGDIR=C:\Documents and Settings\All Users\Application Data\McAfee\Desktop
Protection
windir=C:\WINDOWS
Re: ORA-12560 Protocol Adapter error [message #443765 is a reply to message #443550] Wed, 17 February 2010 04:47 Go to previous messageGo to next message
John Watson
Messages: 4569
Registered: January 2010
Location: Global Village
Senior Member
One point that will cause network problems in future (I don't know about your immediate problem) is that your host name has a hyphen. This is illegal (see the RFC 952 - DoD Internet host table specification) and there are numerous Metalink articles (393430.1, 884163.1, many more...) detailing this, the problem typically shows up with only certain products in certain situations.
Re: ORA-12560 Protocol Adapter error [message #443805 is a reply to message #443550] Wed, 17 February 2010 06:44 Go to previous messageGo to next message
chekov
Messages: 4
Registered: September 2009
Location: Netherlands
Junior Member
Solved problem by adding new listener2 with PROTOCOL = IPC in place of TCP(apparently used where client and server on same machine). Configured with service name.

LISTENER2 =
(DESCRIPTION_LIST =
(DESCRIPTION =
(ADDRESS_LIST =
(ADDRESS = (PROTOCOL = IPC)(KEY = emrep.myname.local))
)
)
)

Can connect now using sqlplus hr/hr@emrep

Thanks all for help!
Re: ORA-12560 Protocol Adapter error [message #443806 is a reply to message #443805] Wed, 17 February 2010 06:46 Go to previous message
ramoradba
Messages: 2452
Registered: January 2009
Location: AndhraPradesh,Hyderabad,I...
Senior Member
Thanks for the feedback

sriram
Previous Topic: Database link is not working (merged by CM)
Next Topic: ora-01033: Oracle initialization or shutdown in progress
Goto Forum:
  


Current Time: Sat Sep 20 17:05:29 CDT 2014

Total time taken to generate the page: 0.19919 seconds