Home » SQL & PL/SQL » Client Tools » Sqlplus not found Message file sp1<lang>.msb not found (oracle 10g, linux rhel 5)
Sqlplus not found Message file sp1<lang>.msb not found [message #441190] Fri, 29 January 2010 06:25 Go to next message
zeelombe
Messages: 7
Registered: January 2010
Location: LUSAKA ZAMBIA
Junior Member

hi, people i need help resolving this problem

bash: sqlplus: command not found
Error 6 initializing SQL*Plus
Message file sp1<lang>.msb not found
SP2-0750: You may need to set ORACLE_HOME to your Oracle software directory

i install oracle 10gR and the process was successful i could do everything. the problem started when i install Zend Core for oracle, the install of zend was successful but i now can't start sqlplus.

what cani do

regards
Re: Sqlplus not found Message file sp1<lang>.msb not found [message #441191 is a reply to message #441190] Fri, 29 January 2010 06:29 Go to previous messageGo to next message
Michel Cadot
Messages: 59131
Registered: March 2007
Location: Nanterre, France, http://...
Senior Member
Account Moderator
Quote:
You may need to set ORACLE_HOME to your Oracle software directory

Did you do that?

Regards
Michel
Re: Sqlplus not found Message file sp1<lang>.msb not found [message #441192 is a reply to message #441190] Fri, 29 January 2010 06:30 Go to previous messageGo to next message
ramoradba
Messages: 2452
Registered: January 2009
Location: AndhraPradesh,Hyderabad,I...
Senior Member
From Oracle FAQ


Quote:
Sometimes when SQL*Plus is run, you see the error:
Message file sp1<Lang>.msb not found
Error 6 initializing SQL*Plus

This occurs when SQL*Plus was unable to find a message file during program initialization. The most common cause is that ORACLE_HOME has not been set. This prevents the message files being found and SQL*Plus would be unable to display error messages or text required for normal operation. Other causes are when the message file is corrupt or cannot be read.

Make sure that all the environment variables or registry entries needed to run SQL*Plus are set. The variables are platform specific but may include ORACLE_HOME, ORACLE_SID, NLS_LANG, ORA_NLS33, and LD_LIBRARY_PATH.

Also check that the file sp1XX.msb is present in the $ORACLE_HOME/sqlplus/mesg or %ORACLE_HOME%\sqlplus\mesg directory. The "XX" stands for the country prefix associated with your NLS_LANG environment variable. SQL*Plus reads only one of the sp1XX.msb files. For example sp1ja.msb is read if NLS_LANG is JAPANESE_JAPAN.JA16EUC. If NLS_LANG is not set, then the default (English language) sp1us.msb is used. Check that the appropriate file is of non-zero size and that the file permissions allow you to read it. Note the ".msb" files are binary. The contents may be meaningless when viewed or printed. If you are unsure which language file is being used, try unsetting NLS_LANG and run SQL*Plus to verify it can read the sp1us.msb file.

The error message has changed in SQL*Plus Release 9.0.1 to be more informative:
Error 6 initializing SQL*Plus
Message file sp1<Lang>.msb not found
SP2-0750: You may need to set ORACLE_HOME to your Oracle software directory

Modified: 28-MAR-04 Ref #: ID-4828


sriram Smile
Re: Sqlplus not found Message file sp1<lang>.msb not found [message #441194 is a reply to message #441191] Fri, 29 January 2010 06:46 Go to previous messageGo to next message
zeelombe
Messages: 7
Registered: January 2010
Location: LUSAKA ZAMBIA
Junior Member

yes i have but still am getting the same problem
Re: Sqlplus not found Message file sp1<lang>.msb not found [message #441195 is a reply to message #441194] Fri, 29 January 2010 06:48 Go to previous messageGo to next message
ThomasG
Messages: 3099
Registered: April 2005
Location: Heilbronn, Germany
Senior Member
Prove it.

Post the output of

set


and of

ls $ORACLE_HOME/sqlplus/mesg
Re: Sqlplus not found Message file sp1<lang>.msb not found [message #441198 is a reply to message #441194] Fri, 29 January 2010 06:59 Go to previous messageGo to next message
zeelombe
Messages: 7
Registered: January 2010
Location: LUSAKA ZAMBIA
Junior Member

@nz01 ~]$ ls $ORACLE_HOME/sqlplus/mesg
cpyus.msb cpyus.msg sp1us.msb sp1us.msg sp2us.msb sp2us.msg
Re: Sqlplus not found Message file sp1<lang>.msb not found [message #441202 is a reply to message #441198] Fri, 29 January 2010 07:04 Go to previous messageGo to next message
zeelombe
Messages: 7
Registered: January 2010
Location: LUSAKA ZAMBIA
Junior Member

the other fact is that am new to linux so i may not know all the required commands to check some setting so please i would appreciate if you could be indicating the full commands as u help.

so how do u check the nls_lang
Re: Sqlplus not found Message file sp1<lang>.msb not found [message #441208 is a reply to message #441202] Fri, 29 January 2010 07:27 Go to previous messageGo to next message
ThomasG
Messages: 3099
Registered: April 2005
Location: Heilbronn, Germany
Senior Member
That you would do with the "set" command I already mentioned.
Re: Sqlplus not found Message file sp1<lang>.msb not found [message #441209 is a reply to message #441202] Fri, 29 January 2010 07:34 Go to previous messageGo to next message
zeelombe
Messages: 7
Registered: January 2010
Location: LUSAKA ZAMBIA
Junior Member

@nz01 ~]$ set
BASH=/bin/bash
BASH_ARGC=()
BASH_ARGV=()
BASH_LINENO=()
BASH_SOURCE=()
BASH_VERSINFO=([0]="3" [1]="2" [2]="25" [3]="1" [4]="release" [5]="i686-redhat-linux-gnu")
BASH_VERSION='3.2.25(1)-release'
COLORS=/etc/DIR_COLORS.xterm
COLORTERM=gnome-terminal
COLUMNS=80
CVS_RSH=ssh
DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-XNce5vJATG,guid=5b9aeea9d48229fa410352004b6288e8
DESKTOP_SESSION=default
DESKTOP_STARTUP_ID=
DIRSTACK=()
DISPLAY=:0.0
EUID=500
GDMSESSION=default
GDM_XSERVER_LOCATION=local
GNOME_DESKTOP_SESSION_ID=Default
GNOME_KEYRING_SOCKET=/tmp/keyring-MIqtFI/socket
GROUPS=()
GTK_RC_FILES=/etc/gtk/gtkrc:/home/oracle/.gtkrc-1.2-gnome2
G_BROKEN_FILENAMES=1
HISTFILE=/home/oracle/.bash_history
HISTFILESIZE=1000
HISTSIZE=1000
HOME=/home/oracle
HOSTNAME=nz01
HOSTTYPE=i686
IFS=$' \t\n'
INPUTRC=/etc/inputrc
LANG=en_US.UTF-8
LD_LIBRARY_PATH=:/lib:/home/oracle/oracle/product/10.2.0/db_1/lib:/home/oracle/oracle/product/10.2.0/db_1/lib
LESSOPEN='|/usr/bin/lesspipe.sh %s'
LINES=24
LOGNAME=valdba
LS_COLORS='no=00:fi=00:di=00;34:ln=00;36:pi=40;33:so=00;35:bd=40;33;01:cd=40;33;01:or=01;05;37;41:mi=01;05;37;41:ex=00;32:*.cmd=00;32 :*.exe=00;32:*.com=00;32:*.btm=00;32:*.bat=00;32:*.sh=00;32:*.csh=00;32:*.tar=00;31:*.tgz=00;31:*.arj=00;31:*.taz=00;31:*.lzh=00;31:* .zip=00;31:*.z=00;31:*.Z=00;31:*.gz=00;31:*.bz2=00;31:*.bz=00;31:*.tz=00;31:*.rpm=00;31:*.cpio=00;31:*.jpg=00;35:*.gif=00;35:*.bmp=00 ;35:*.xbm=00;35:*.xpm=00;35:*.png=00;35:*.tif=00;35:'
MACHTYPE=i686-redhat-linux-gnu
MAIL=/var/spool/mail/valdba
MAILCHECK=60
OPTERR=1
OPTIND=1
ORACLE_HOME=/home/oracle/oracle/product/10.2.0/db_1
ORACLE_SID=valdb
OSTYPE=linux-gnu
PATH=/home/oracle/oracle/product/10.2.0/db_1/bin:/home/oracle/oracle/product/10.2.0/db_1/bin:/bin:/usr/lib/qt-3.3/bin:/usr/kerberos/b in:/usr/local/bin:/usr/bin:/bin:/usr/X11R6/bin:/home/oracle/bin
PIPESTATUS=([0]="0")
PPID=13041
PROMPT_COMMAND='echo -ne "\033]0;${USER}@${HOSTNAME%%.*}:${PWD/#$HOME/~}"; echo -ne "\007"'
PS1='[\u@\h \W]\$ '
PS2='> '
PS4='+ '
PWD=/home/oracle
QTDIR=/usr/lib/qt-3.3
QTINC=/usr/lib/qt-3.3/include
QTLIB=/usr/lib/qt-3.3/lib
SESSION_MANAGER=local/nz01:/tmp/.ICE-unix/3414
SHELL=/bin/bash
SHELLOPTS=braceexpand:emacs:hashall:histexpand:history:interactive-comments:monitor
SHLVL=2
SSH_AGENT_PID=3460
SSH_ASKPASS=/usr/libexec/openssh/gnome-ssh-askpass
SSH_AUTH_SOCK=/tmp/ssh-OBMGEV3414/agent.3414
TERM=xterm
UID=500
USER=valdba
USERNAME=valdba
WINDOWID=23090256
XAUTHORITY=/tmp/.gdm90RE7U
_=/home/oracle/oracle/product/10.2.0/db_1/sqlplus/mesg
consoletype=pty
qt_prefix=/usr/lib/qt-3.3
Re: Sqlplus not found Message file sp1<lang>.msb not found [message #441210 is a reply to message #441202] Fri, 29 January 2010 07:36 Go to previous messageGo to next message
ramoradba
Messages: 2452
Registered: January 2009
Location: AndhraPradesh,Hyderabad,I...
Senior Member
See this....



UNIXForDBAs.....

http://unix-commands.blogspot.com/

Online man pages of unix/linux

sriram Smile
Re: Sqlplus not found Message file sp1<lang>.msb not found [message #441219 is a reply to message #441210] Fri, 29 January 2010 09:18 Go to previous messageGo to next message
ThomasG
Messages: 3099
Registered: April 2005
Location: Heilbronn, Germany
Senior Member
Also, the cause of the error then is that your NLS_LANG variable is not set (since it isn't shown in the output of the set command)

Since you only have the US language files, you have to set it to American, for example with:

export NLS_LANG=American_America.we8iso8859p15


The code page after the dot might depend on the codepages installed on the system and on the codepage the database is in, though.

[Updated on: Fri, 29 January 2010 09:19]

Report message to a moderator

Re: Sqlplus not found Message file sp1<lang>.msb not found [message #441426 is a reply to message #441219] Mon, 01 February 2010 01:58 Go to previous messageGo to next message
zeelombe
Messages: 7
Registered: January 2010
Location: LUSAKA ZAMBIA
Junior Member

hello, i tried the setting the nls_lang as advised but to no avail. any new ideas
Re: Sqlplus not found Message file sp1<lang>.msb not found [message #441434 is a reply to message #441190] Mon, 01 February 2010 02:13 Go to previous messageGo to next message
zeelombe
Messages: 7
Registered: January 2010
Location: LUSAKA ZAMBIA
Junior Member

actually after doing the "export NLS_LANG=American_America.WE8ISO8859P15" the error that i am getting is NLS initiation error

Error 5 initializing SQL*Plus
NLS initialization error
Re: Sqlplus not found Message file sp1<lang>.msb not found [message #441507 is a reply to message #441434] Mon, 01 February 2010 09:19 Go to previous messageGo to next message
ThomasG
Messages: 3099
Registered: April 2005
Location: Heilbronn, Germany
Senior Member
That can happen when NLS_LANG is set to something completely wrong.

Maybe try other languages / character sets. And have a look at the NLS_LANG FAQ.

Re: Sqlplus not found Message file sp1<lang>.msb not found [message #594162 is a reply to message #441190] Sat, 24 August 2013 02:36 Go to previous messageGo to next message
niladri.banerjee
Messages: 2
Registered: August 2013
Location: India
Junior Member
Just set ORACLE_HOME

Right Click on My Computers > Properties > Advanced System Settings > Go to Advanced Tab > Environment Variables > New >

Variable Name ORACLE_HOME
Path = Path where you installed oracle -> For eg : C:\oracle

You should be good to go.. !!!
Re: Sqlplus not found Message file sp1<lang>.msb not found [message #594172 is a reply to message #594162] Sat, 24 August 2013 08:13 Go to previous messageGo to next message
Littlefoot
Messages: 19610
Registered: June 2005
Location: Croatia, Europe
Senior Member
Account Moderator
Niladri, apart from the fact that this discussion originally took place more than 3.5 years ago (so it is rather unbelievable that the OP didn't fix it yet), he said that he uses Linux RHEL 5 operating system. I doubt that one can follow what you instructed (right click on this and that, set path to C:\oracle) - terms you used are valid for MS Windows (which version? Is it 7?), not Linux.

Therefore, welcome to OraFAQ Forum; when you choose to participate another discussion, try to pick a newer one, and try to post valid information for the situation described.
Re: Sqlplus not found Message file sp1<lang>.msb not found [message #594174 is a reply to message #594172] Sat, 24 August 2013 10:23 Go to previous messageGo to next message
niladri.banerjee
Messages: 2
Registered: August 2013
Location: India
Junior Member
Yes Both of you are correct..I overlooked the first statement When I saw the following

bash: sqlplus: command not found
Error 6 initializing SQL*Plus
Message file sp1<lang>.msb not found
SP2-0750: You may need to set ORACLE_HOME to your Oracle software directory

I missed the "bash: sqlplus: command not found" part of it. I was getting following message in Windows...

Error 6 initializing SQL*Plus
Message file sp1<lang>.msb not found
SP2-0750: You may need to set ORACLE_HOME to your Oracle software directory.

But when it is Windows, the answer I posted is 100% correct (of course you can verify if I said anything wrong and let me know in case I am) but what I said does not hold true for Linux.. Agreed !!!

And I don't think it is a harm to post information in old forums if you find any information. If it is useful or not useful is subjected to discretion of the people whom it is addressed and the subject matter...

Thanks...
Re: Sqlplus not found Message file sp1<lang>.msb not found [message #594175 is a reply to message #594174] Sat, 24 August 2013 10:25 Go to previous messageGo to next message
BlackSwan
Messages: 22789
Registered: January 2009
Senior Member
niladri.banerjee ,

Please read and follow the forum guidelines, to enable us to help you:

http://www.orafaq.com/forum/t/88153/0/
Re: Sqlplus not found Message file sp1<lang>.msb not found [message #594178 is a reply to message #594174] Sun, 25 August 2013 02:20 Go to previous message
Littlefoot
Messages: 19610
Registered: June 2005
Location: Croatia, Europe
Senior Member
Account Moderator
niladri.banerjee

And I don't think it is a harm to post information in old forums if you find any information.

I don't see any problem in this either. Everything you said in your first message is valid as far as MS Windows is concerned, but - as you know, you missed the operating system.

If you posted some information that regards setting ORACLE_HOME on Linux, that would be fine.

OK then, everything seems to be clear to both (all) of us. I hope you'll enjoy your stay here!
Previous Topic: SQL*Plus not SPOOLing
Next Topic: Sql developer not working constantly
Goto Forum:
  


Current Time: Thu Sep 18 13:35:43 CDT 2014

Total time taken to generate the page: 0.14547 seconds