Home » Developer & Programmer » Forms » FRM-41211 and FRM-40738 (Windows XP sp3)
FRM-41211 and FRM-40738 [message #440463] Mon, 25 January 2010 01:42 Go to next message
sandip109
Messages: 5
Registered: January 2010
Location: India
Junior Member

Dear all i am using Forms Reports 10g.
I have a report which i have to call in my form with some parameters .
But when i try to call the report then it is showing Error .
And the error is :-
frm-41211 integration error: SSL failure running another product
Then another error is :-
FRM-40738 Argument1 to builtin REPORT_OBJECT_STATUS cannot be null 2

And imy requirment is when i press the print button it should print and should disply in PDF format.
Please help me.

My code is :-
DECLARE
repid REPORT_OBJECT;
v_rep VARCHAR2(100);
rep_status VARCHAR2(20);
plid ParamList;
vParamValue number;
BEGIN
plid := Get_parameter_List('tmp');
IF NOT Id_Null(plid) THEN
Destroy_parameter_List( plid );
END IF;
plid := Create_parameter_List('tmp');
Add_Parameter(PLid, 'P_Block', Text_Parameter, :block_query.item_block);
Add_Parameter(PLid, 'P_Category', Text_Parameter, :block_query.item_category);
Add_Parameter(PLid, 'P_Dept', Text_Parameter, :block_query.item_dept);
Add_Parameter(PLid, 'P_FLOOR', Text_Parameter, :block_query.item_floor);
Add_Parameter(PLid, 'P_IP', Text_Parameter, :block_query.item_ip);
Add_Parameter(PLid, 'P_Room', Text_Parameter, :block_query.item_room);
Add_Parameter(PLid, 'P_Userid', Text_Parameter, :block_query.item_usr_id);
Add_Parameter(PLid, 'PARAMFORM', Text_Parameter, 'NO');

repid := FIND_REPORT_OBJECT('REPORT_test1');
SET_REPORT_OBJECT_PROPERTY(repid,REPORT_COMM_MODE,SYNCHRONOUS);
SET_REPORT_OBJECT_PROPERTY(repid,REPORT_DESTYPE,cache);

SET_REPORT_OBJECT_PROPERTY(repid,REPORT_DESFORMAT,'PDF');

SET_REPORT_OBJECT_PROPERTY(repid,REPORT_OTHER, 'paramform=no');

SET_REPORT_OBJECT_PROPERTY(repid,REPORT_SERVER,'rep_a_f2_itt_pc_4');

v_rep := RUN_REPORT_OBJECT(repid,plid);
rep_status := REPORT_OBJECT_STATUS(v_rep);

WHILE rep_status in ('RUNNING','OPENING_REPORT','ENQUEUED')
LOOP
rep_status := report_object_status(v_rep);
END LOOP;


End;
Re: FRM-41211 and FRM-40738 [message #445446 is a reply to message #440463] Mon, 01 March 2010 23:32 Go to previous message
djmartin
Messages: 10180
Registered: March 2005
Location: Canberra ACT Australia
Senior Member
Account Moderator
Sorry that I have been so long in replying. Have you solved your problem?

Use 'web.show_document' as it will start the report server if it is not running where your method will not.

David
Previous Topic: ERROR IN SENDING EMAILS FROM A FORM
Next Topic: Forms developer not starting up (f90desm)
Goto Forum:
  


Current Time: Thu Sep 29 20:58:08 CDT 2016

Total time taken to generate the page: 0.23432 seconds