Home » Infrastructure » Other Operating Systems » UTL_FILE on VAX VMS (OS=VAX VMS V5.5-2, Oracle=7.1.3.2.0, PL/SQL=2.1.3.2.0)
UTL_FILE on VAX VMS [message #440360] Fri, 22 January 2010 15:36 Go to next message
mcykowski
Messages: 1
Registered: January 2010
Junior Member
Does anyone know if or how I can get UTL_FILE PL/SQL installed on my VAX VMS system? My research tells me that UTL_FILE was released only with Oracle 7.3 and above. Any way to get around this restriction to get UTL_FILE installed with Oracle 7.1.3.2.0?

Is it worth it to try and change the INIT.ORA and see what happens? Not being a DBA, would this mess up Oracle forever? Confused

The OS is VAX VMS V5.5-2, Oracle version is 7.1.3.2.0, and PL/SQL version is 2.1.3.2.0.
Re: UTL_FILE on VAX VMS [message #440382 is a reply to message #440360] Sat, 23 January 2010 02:04 Go to previous messageGo to next message
Michel Cadot
Messages: 59076
Registered: March 2007
Location: Nanterre, France, http://...
Senior Member
Account Moderator
If the package was released in a version after yours then generally speaking you cannot use it in a previous version.
In the case of UTL_FILE, 2 things have been added in Oracle:
- a new parameter UTL_FILE_DIR which is not known from your version
- new subprograms inside the Oracle engine to access files and you have not these subprograms.

So, in short, you can't.

Regards
Michel
Re: UTL_FILE on VAX VMS [message #440854 is a reply to message #440360] Wed, 27 January 2010 06:58 Go to previous message
daverich
Messages: 23
Registered: January 2010
Location: UK
Junior Member
To find out if utl_file is installed in your database run
select owner, object_name, object_type from dba_objects where object_name like '%UTL_FILE%';


If the package is there then you have to set a parameter in your init.ora file and restart your database.

If you are using VMS then you will be giving a path like
utl_file_dir = ORATEST_SYS$COMMON:[TMP]

This is the directory that utl_file can read/write. You will need execute permission to use UTL_FILE (DBA should be able to give that)

But as Michel Cadot said, your version does not support it, so you can't do that...if that is the case.

[Updated on: Wed, 27 January 2010 07:02]

Report message to a moderator

Previous Topic: Do Oracle 9i server installation requires license
Next Topic: how to create setup in d2k for my project
Goto Forum:
  


Current Time: Tue Sep 16 02:28:28 CDT 2014

Total time taken to generate the page: 0.10668 seconds