Home » RDBMS Server » Enterprise Manager » Instance registered under old domain name (Enterprise Manager, 10g, Unix)
Instance registered under old domain name [message #440000] Wed, 20 January 2010 09:10 Go to next message
bscholl
Messages: 9
Registered: May 2008
Junior Member
I create an instance with oracle scripts,.. postDBCreation.sql : -SERVICE_NAME cag1.crick.cagis.gov should be cag1.mycrof.cagis.gov .... ultraSearchCfg.sql SERVICE_NAME=cag1.crick.cagis.gov should be ca1.mycrof.cagis.gov .. Impact: All DBlinks show as LINKNAME.CRICK.CAGIS.GOV and this instance is labeled CAG1.CRICK.CAGIS.GOV in the Grid Control Console.
icon6.gif  Re: Instance registered under old domain name [message #440002 is a reply to message #440000] Wed, 20 January 2010 09:20 Go to previous messageGo to next message
LKBrwn_DBA
Messages: 413
Registered: July 2003
Location: WPB, FL
Senior Member
And what is preventing you from changing the service name and re-creating the db-links?
Shocked
-- Or -- if the issue is only on EM, then you need to re-create the repository.
*

[Updated on: Wed, 20 January 2010 09:22]

Report message to a moderator

Re: Instance registered under old domain name [message #440003 is a reply to message #440000] Wed, 20 January 2010 09:21 Go to previous messageGo to next message
BlackSwan
Messages: 21941
Registered: January 2009
Senior Member
changing GLOBAL_NAME can result in DBLINKs to break or cease to function.
To fix, then DROP & (re)CREATE DBLINK


It would be helpful if you followed Posting Guidelines - http://www.orafaq.com/forum/t/88153/0/

[Updated on: Wed, 20 January 2010 09:22]

Report message to a moderator

Re: Instance registered under old domain name [message #440006 is a reply to message #440000] Wed, 20 January 2010 09:39 Go to previous messageGo to next message
bscholl
Messages: 9
Registered: May 2008
Junior Member
I guess there are multiple issues:

1. DBLinks show as DBlinkname.crick.cagis.gov
The global_names parameter is FALSE
The db_domain is correct mycrof.cagis.gov

2. Enterprise Manager displays the instance as: cag1.crick.cagis.gov

I did find that the targets.xml file under the directory ..10.2.0/mycrof.cagis.gov_cag1/sysman/emd has NAME='cag1.crick.cagis.gov" listed
Wondering if I can change this value and restart the agent.

3. Instances create before the machine name change still show up in Enterprise Manager as the old machine name.

I uninstalled the agent, renamed the machine, deleted agent directories then reinstalled then agent. Somewhere the old machine name is getting picked up and being registered.
icon6.gif  Re: Instance registered under old domain name [message #440209 is a reply to message #440006] Thu, 21 January 2010 10:32 Go to previous messageGo to next message
LKBrwn_DBA
Messages: 413
Registered: July 2003
Location: WPB, FL
Senior Member
You may need to stop the agent and on the agent home under one of the sysman subdirectories (config or emd) modify emd.properties file and remove the targets.xml file, then execute these commands:
export AH={Agent Home}
cd $AH/bin
./emctl stop agent
rm -r $AH/sysman/emd/state/*
rm -r $AH/sysman/emd/collection/*
rm -r $AH/sysman/emd/upload/*
rm $AH/sysman/emd/lastupld.xml
rm $AH/sysman/emd/agntstmp.txt
rm $AH/sysman/emd/blackouts.xml
./emctl start agent
./emctl upload agent

Razz
Re: Instance registered under old domain name [message #440245 is a reply to message #440209] Thu, 21 January 2010 15:54 Go to previous message
bscholl
Messages: 9
Registered: May 2008
Junior Member
Think that did it,.. Thank you!
Previous Topic: configure OEM dbconsole for two database...
Next Topic: oracle not available in oem
Goto Forum:
  


Current Time: Fri Apr 18 03:26:03 CDT 2014

Total time taken to generate the page: 0.25762 seconds