Home » Developer & Programmer » Forms » Can not connect to DB
Can not connect to DB [message #438173] Thu, 07 January 2010 06:05 Go to next message
salora
Messages: 26
Registered: December 2009
Location: Thailand
Junior Member
Really need help!! I has install Oracle Form runtime/Report Runtime, it's successfullly.

But when I run form module with form runtime. By entry user/pasword and hoststring, Then I got the error "ora-12705 invalid or unknown nls parameter value specified"

I has tried to search from the net, some suggestion is to check parameter of NLS_LANG, It's already valid. But still can not connect

Anyone can help. please.

Thank you in advance.



Re: Can not connect to DB [message #438181 is a reply to message #438173] Thu, 07 January 2010 06:33 Go to previous messageGo to next message
Littlefoot
Messages: 20901
Registered: June 2005
Location: Croatia, Europe
Senior Member
Account Moderator
This is what Oracle says:Oracle
ORA-12705: Cannot access NLS data files or invalid environment specified

Cause: Either an attempt was made to issue an ALTER SESSION command with an invalid NLS parameter or value; or the environment variable(s) NLS_LANG, ORA_NLSxx, or ORACLE_HOME was incorrectly specified, therefore the NLS data files cannot be located.

Action: Check the syntax of the ALTER SESSION command and the NLS parameter, correct the syntax and retry the statement, or specify the correct directory path/values in the environment variables.



How did you install forms and Reports? Which version did you install? Was it 6i or 10g (i hope you didn't install one of the ancient versions)? Where is the database? Is it on your computer? If so, did you install Developer Suite (Forms & Reports) into the same directory (i.e. Oracle home) as the database (which would be VERY WRONG; in that case, perhaps you should reinstall Developer Suite), or into its own directory?

Re: Can not connect to DB [message #438597 is a reply to message #438181] Mon, 11 January 2010 02:43 Go to previous messageGo to next message
salora
Messages: 26
Registered: December 2009
Location: Thailand
Junior Member
I have 6 CDs for do installation as following detail.

CD1. Oracle 8 client
(Do not Install this)
CD2. Developer 2000
- Developer 2000 - Forms 5.0.6.8.0
- Developer 2000 - Report 5.0.5.8.0

CD3. Developer 2000
- Developer 2000 - Forms 5.0.6.16.0 (only Form runtime 5.0.6.16.0)
- Developer 2000 - Report 5.0.5.14.0 (only Report runtime 5.0.5.14.0)

CD4. Oracle Form (Custom)
- Form Runtime (6.0.8.11.3)
- Report Runtime (6.0.8.11.3)

CD5. Form 6.0.8.15.0
- Forms runtime 6.0.8.15.0
- Report runtime 6.0.8.15.0

CD6. Form 6.0.8.15.0
- Forms runtime 6.0.8.26.0
- Report runtime 6.0.8.26.0

Situation:
I have been installed by follow above step, to the new PC is OK.
But for the PC witch I got problem, befor do the install this PC already have Oracle client
and can connect to the database (in server) by use Toad. --> OK

After that, I need to have form runtime to run the application
then, I do the install as following step, except CD1.(start from CD2)
then I got the problem

Any suggestion? pls, help
Re: Can not connect to DB [message #438602 is a reply to message #438597] Mon, 11 January 2010 02:56 Go to previous messageGo to next message
Littlefoot
Messages: 20901
Registered: June 2005
Location: Croatia, Europe
Senior Member
Account Moderator
Once again: into what directory did you install CD's 2 - 6? Should *NOT* be into Oracle 8 client's directory (which already existed on that computer).
Re: Can not connect to DB [message #439938 is a reply to message #438602] Wed, 20 January 2010 05:03 Go to previous messageGo to next message
salora
Messages: 26
Registered: December 2009
Location: Thailand
Junior Member
Thanks you for your reply,

Also I have more issues, Sad

When did the installation(fresh installation).

1. Why it's need to install by sequence (start from CD1 to CD6) ?

2. I have tried to installed,
2.1 Start with CD1(form client8),
2.2 And continue with CD6(FORM Developer 6.0.8.26.0 (patch 17)

Then I got errror ""You need to install Forms Runtime 5.0.6.8.0 before using this patch"

even CD1-6 is not concern about Forms Runtime 5.0.6.8.0.


3. If I need to install the following product in client PC.
3.1 Oracle client8
3.2 Forms runtime 6.0.8.26.0 patch 17
3.3 Report runtime 6.0.8.26.0 patch 17

Any possibility that to install only 2 CDs? (Oracle client and Oracle form developer) rather than start from CD1 till CD6.

really nedd help

Sad




Re: Can not connect to DB [message #439967 is a reply to message #439938] Wed, 20 January 2010 06:16 Go to previous messageGo to next message
Littlefoot
Messages: 20901
Registered: June 2005
Location: Croatia, Europe
Senior Member
Account Moderator
Quote:
1. Why it's need to install by sequence (start from CD1 to CD6) ?
Probably for the same reason children go to first class first, then the second, etc. etc., until they reach sixth class.

Quote:
I got errror ""You need to install Forms Runtime 5.0.6.8.0 before using this patch"
If Oracle says so, I believe it has some good reasons.

Quote:
3. If I need to install the following product in client PC.
3.1 Oracle client8
3.2 Forms runtime 6.0.8.26.0 patch 17
3.3 Report runtime 6.0.8.26.0 patch 17

Any possibility that to install only 2 CDs? (Oracle client and Oracle form developer) rather than start from CD1 till CD6.
Try. You might get a message simlar to the one mentioned in the prevous quotation.
Re: Can not connect to DB [message #440062 is a reply to message #439967] Wed, 20 January 2010 20:54 Go to previous message
salora
Messages: 26
Registered: December 2009
Location: Thailand
Junior Member
Hi Littel foot

Seem like i have to follow the traditional installation. Shocked
Anyway, thank you so much for your reply.

Regard, Smile
Previous Topic: datagrid in forms 6i
Next Topic: When-Button-Pressed Trigger Code to cover three scenarios
Goto Forum:
  


Current Time: Fri Dec 09 09:34:01 CST 2016

Total time taken to generate the page: 0.15502 seconds