Home » Developer & Programmer » Forms » open image from application server (application server 10g)
open image from application server [message #437056] Wed, 30 December 2009 13:00 Go to next message
bad_sector007
Messages: 12
Registered: December 2009
Location: Egypt
Junior Member

Hello

I'm trying to open some images from the client machine using this code web.show_document.

it works well but only when the files in this path
C:\DevSuiteHome_1\forms\java
example C:\DevSuiteHome_1\forms\java\1234.tif
the Url is
http ://192.168.1.246:8889/forms/java/123.tif

the problem is :-

I need to change the path to be c:\attached\1234.tif
every time I try to change the path it doesn't work.


Re: open image from application server [message #437752 is a reply to message #437056] Tue, 05 January 2010 23:03 Go to previous messageGo to next message
djmartin
Messages: 10180
Registered: March 2005
Location: Canberra ACT Australia
Senior Member
Account Moderator
Please post your code.

David
Re: open image from application server [message #437892 is a reply to message #437056] Wed, 06 January 2010 06:50 Go to previous messageGo to next message
bad_sector007
Messages: 12
Registered: December 2009
Location: Egypt
Junior Member

Hello David
I'm Trying to open some images stored in the application server at the client machine.
the code i use is :
WEB.SHOW_DOCUMENT(:PRL_ATTACH.PRL_URL,'_blank');
--where :PRL_ATTACH.PRL_URL = /gpd_docs/fn13/comp1mf3926/L8603.tif
the file is stord is this path
C:\DevSuiteHome_1\forms\java\gpd_docs\fn13\comp1mf3926\L8603.tif
so the final url is :-
http: //192.168.1.246:8889/forms/java/gpd_docs/fn13/comp1mf3926/L8603.tif

I've searched about how to create the virtual path in forms developer and i found that i have to modify the file called orion-web.xml in this path C:\DevSuiteHome_1\j2ee\DevSuite\application-deployments\forms\formsweb
by adding the virtual path like that
<virtual-directory virtual-path="/gpd_docs" real-path="C:\gpd_docs" />
so the new url in the developer is :-
http: //192.168.1.246:8889/forms/gpd_docs/fn13/comp1mf3926

now it's working good on the developer.
the problem is:-
i want to create the the virtual path on the application server (10g).

after searching about how to create the virtual path at the application server i found a document configuring the webutil talks about this part in the configuration.
I've attached photo for this document.
but when i tried to write this code the application server it didn't work.
*note the images working at the application server if the images in this path. c:\orahome2\forms\java\gpd_docs\*.*

* you will find a space between the link because it's now allowed for me to post links.

I wish it's clear now.
  • Attachment: webutil.JPG
    (Size: 160.34KB, Downloaded 146 times)
Re: open image from application server [message #438059 is a reply to message #437892] Thu, 07 January 2010 00:26 Go to previous messageGo to next message
djmartin
Messages: 10180
Registered: March 2005
Location: Canberra ACT Australia
Senior Member
Account Moderator
I believe that the new Forms path is actually http: //192.168.1.246:8889/forms/java/gpd_docs/fn13/comp1mf3926
Please note the 'java' directory.

You say the application server uses c:\orahome2\forms\java\gpd_docs\*.*

Please confirm that 'L8603.tif' lives in c:\orahome2\forms\java\gpd_docs\fn13\comp1mf3926\ on the AS.

David
Re: open image from application server [message #438081 is a reply to message #438059] Thu, 07 January 2010 01:19 Go to previous messageGo to next message
bad_sector007
Messages: 12
Registered: December 2009
Location: Egypt
Junior Member

Hello David
I think you missed a part.
It's working in the application server when the files in this path:- c:\orahome2\forms\java\*.* but the problem that i want to change this directory to be c:\gpd_docs not c:\orahome2\forms\java.

so i need to create a virtual path as i did in the forms developer.
Thx for your reply,

khaled
Re: open image from application server [message #438713 is a reply to message #438081] Mon, 11 January 2010 23:22 Go to previous message
djmartin
Messages: 10180
Registered: March 2005
Location: Canberra ACT Australia
Senior Member
Account Moderator
I suggest that you remove all the directory and subdirectory bits from your code and add them to your 'path' statements.

David
Previous Topic: utl_http issue
Next Topic: Oracle Form Very slow
Goto Forum:
  


Current Time: Fri Dec 02 16:32:24 CST 2016

Total time taken to generate the page: 0.17223 seconds