Home » Infrastructure » Linux » Error in invoking target install of makefile /u01/oracle/plsql/lib/ins_plsql.mk (Install Oracle9iR2(9.2.0.4) on CentOS 4.8 on VMware server)
Error in invoking target install of makefile /u01/oracle/plsql/lib/ins_plsql.mk [message #436283] Tue, 22 December 2009 13:22 Go to next message
roy516
Messages: 3
Registered: December 2009
Junior Member
When I install oracle 9.2.0.4.0 on CentOS 4.8, I get the following error at 63 percent.

Error in invoking target install of makefile $ORACLE_HOME/plsql/lib/ins_plsql.mk

I tried this possible solution.

(a) Open a new terminal window
Login as oracle user:
cd $ORACLE_HOME/bin
cp genclntsh genclntsh.bak
(b) vi genclntsh
(c) In line 152,change
from # LD_SELF_CONTAINED="-z defs"

to # LD_SELF_CONTAINED=""

save the file.
(d) Run the genclntsh script, ./genclntsh
(f) Go back to the Installer and click "Retry".

But when I executed genclntsh, I got the following error-like messages.

basename: too few arguments
Try `basename --help' for more information.
cp: missing file arguments
Try `cp --help' for more information.
cp: cannot stat `/DISCARD/': No such file or directory
Created $ORACLE_HOME/lib/libclntst9.a

After that the prompt came back. I hit the retry button, but got the same error message again.

I hope someone can help me further resolving this problem.
Re: Error in invoking target install of makefile /u01/oracle/plsql/lib/ins_plsql.mk [message #436284 is a reply to message #436283] Tue, 22 December 2009 14:57 Go to previous messageGo to next message
BlackSwan
Messages: 24908
Registered: January 2009
Senior Member
>I hope someone can help me further resolving this problem.
I know with 100% certainty that Oracle installs without any problem when the installer actually reads & follows the Installation Guide.

I suspect that your system either is missing required libraries or the version on your system do not meet required minimum version.

When all else fails, Read The Fine Manual

http://download.oracle.com/docs/html/A96167_01/toc.htm

Installing into unsupported VM environment is asking for problems.

[Updated on: Tue, 22 December 2009 14:58]

Report message to a moderator

Re: Error in invoking target install of makefile /u01/oracle/plsql/lib/ins_plsql.mk [message #436287 is a reply to message #436283] Tue, 22 December 2009 15:46 Go to previous messageGo to next message
roy516
Messages: 3
Registered: December 2009
Junior Member
I agree with you somewhat. However, someone made it successfully without this kind of error. I checked this error on the google. There is lots of posts having the same error since 2002. Unfortunately, there was no post giving detailed solution.

I did install Oracle9i closely as installation manual.
Re: Error in invoking target install of makefile /u01/oracle/plsql/lib/ins_plsql.mk [message #436288 is a reply to message #436287] Tue, 22 December 2009 16:58 Go to previous messageGo to next message
BlackSwan
Messages: 24908
Registered: January 2009
Senior Member
>There is lots of posts having the same error since 2002
I seriously doubt folks were using VM in 2002.

Why are you messing with obsoleted & unsupported V9?
Re: Error in invoking target install of makefile /u01/oracle/plsql/lib/ins_plsql.mk [message #436290 is a reply to message #436283] Tue, 22 December 2009 17:11 Go to previous message
roy516
Messages: 3
Registered: December 2009
Junior Member
You are right. The only difference is no VMware involved in previous posts. But I think newworking would be major issue for VMware.

I like Oracle9i because it is small. Lower hardware requirement for this version. Many companies are still using Oracle9i. The other reason is the same software packages showing in my training vedio. I just don't understand why I have this error during oracle9i installation. Of course, I am not the only one.
Previous Topic: Creating new service
Next Topic: su oracle -
Goto Forum:
  


Current Time: Tue Sep 27 21:11:37 CDT 2016

Total time taken to generate the page: 0.23190 seconds