Home » Developer & Programmer » Forms » FORMS ERROR PDE-PLI018 (merged 4) (Forms [32 bits] Versión 10.1.2.0.2)
icon14.gif  FORMS ERROR PDE-PLI018 (merged 4) [message #436132] Mon, 21 December 2009 14:13 Go to next message
oswaldomad
Messages: 2
Registered: December 2009
Location: BOGOTA
Junior Member
I try to open a library bintables.pll but i recived a message error "PDE-PLI018 COULD NOT FIND LIBRARY HASH ", but this library exist and i was compilated

Please help meeeeee
Re: FORMS ERROR PDE-PLI018 (merged 4) [message #437549 is a reply to message #436132] Tue, 05 January 2010 00:04 Go to previous messageGo to next message
djmartin
Messages: 10180
Registered: March 2005
Location: Canberra ACT Australia
Senior Member
Account Moderator
Is the library in the same directory as the forms? Is this your first form? Have you done a Compile All (Ctrl-shft-k) and a save before doing a Compile All (ctrl-shft-k) and generate (Ctrl-T) and save on your form?

David
icon4.gif  Re: FORMS ERROR PDE-PLI018 (merged 4) [message #437682 is a reply to message #437549] Tue, 05 January 2010 08:48 Go to previous messageGo to next message
oswaldomad
Messages: 2
Registered: December 2009
Location: BOGOTA
Junior Member
No the library is in diferent directory as the form.
I work with Oracle Developer suit, I open forms builder Forms [32 bits] Versión 10.1.2.0.2. Next step i conect with db. later I try to open the library (File/open) Lib_bintablas.pll then I recived a message box from oracle " PDE-PLIO18 COULD NOT FIND LIBRARY HASH"

The library hash is in the same directory that Lib_bintablas, and i open hash library and i was compilated.

Re: FORMS ERROR PDE-PLI018 (merged 4) [message #437778 is a reply to message #437682] Tue, 05 January 2010 23:55 Go to previous messageGo to next message
djmartin
Messages: 10180
Registered: March 2005
Location: Canberra ACT Australia
Senior Member
Account Moderator
Put the PL/SQL libraries in the same directory as your forms. Also put your menus and any object libraries in there as well.

David
Re: FORMS ERROR PDE-PLI018 (merged 4) [message #448633 is a reply to message #436132] Wed, 24 March 2010 07:18 Go to previous message
rbhadane
Messages: 8
Registered: November 2007
Location: gujarat
Junior Member
After Lot of findings I am able to fix this issue
I was facing same issue for oracle forms 10g and found that
its bug with oracle and they have PATCH 2673271 for this

Inorder to apply this patch on windows OS please follow the steps below

1) save the Unzipped 2673271 folder on path
%ORACLE_HOME%\.patch_storage

2)got to start menu of Windows and in cmd type

> set %ORACLE_HOME%=path for oracle on your machine

and then go to cd %ORACLE_HOME%\OPatch>
and run the command

> opatch apply %ORACLE_HOME%\.patch_storage\2673271

Please follow the instructions ...on screen

then finally
Patch will return some missing file errors but those are warnigns

and then you can check if you are able to open the PLL

Previous Topic: /oas/product/j2ee/OC4J_BI_Forms/applications/formsapp/formsweb/WEB-INF/lib/frmsrv.jar:
Next Topic: Do Nothing Base on Alert Button Selected
Goto Forum:
  


Current Time: Mon Dec 05 18:56:19 CST 2016

Total time taken to generate the page: 0.14226 seconds