Home » Developer & Programmer » Reports & Discoverer » displaying apostrophes in oracle reports (reports 10gr2 windows 2000 and 2003 )
icon5.gif  displaying apostrophes in oracle reports [message #435332] Tue, 15 December 2009 11:44 Go to next message
ma04
Messages: 15
Registered: October 2009
Location: swindon, uk
Junior Member
Hi gurus

i have data with apostrophes in a varchar2 column in a table and this displays fine in forms but when the same data is output in a report it displays it with the following character as uppercase.

eg. St. Micheal's displays St. Micheal S in the report.

I can't remember if there's a config setting somewhere that will treat apostrophes as such.

Any ideas will be much appreciated.

thanks in advance.

regards

MA
icon4.gif  Re: displaying apostrophes in oracle reports [message #435650 is a reply to message #435332] Thu, 17 December 2009 04:34 Go to previous messageGo to next message
ma04
Messages: 15
Registered: October 2009
Location: swindon, uk
Junior Member
i'm surprised that there's no response yet for this. Shocked

come on guys.

there must be someone out there who has had problem in the past and got / had it sorted??

please share your little gems!! Smile
Re: displaying apostrophes in oracle reports [message #435673 is a reply to message #435650] Thu, 17 December 2009 05:34 Go to previous messageGo to next message
Littlefoot
Messages: 20827
Registered: June 2005
Location: Croatia, Europe
Senior Member
Account Moderator
It works fine, as expected, using Reports 10g (9.0.4) with Oracle 9i (9.2.0.8) as well as Oracle 10g (10.2.0.1). Report was ran on Windows XP from Reports Builder. Can't reproduce on your operating system(s).

./fa/7149/0/
Re: displaying apostrophes in oracle reports [message #435694 is a reply to message #435673] Thu, 17 December 2009 07:44 Go to previous message
ramoradba
Messages: 2454
Registered: January 2009
Location: AndhraPradesh,Hyderabad,I...
Senior Member
Yes ! Even for me On Oracle reports 6i(Win XP) it is fine.

Sriram Smile
Previous Topic: rep-1439 error while calling one report from another report
Next Topic: Get parameter name and type at runtime
Goto Forum:
  


Current Time: Sat Oct 01 14:28:02 CDT 2016

Total time taken to generate the page: 0.07863 seconds