Home » Developer & Programmer » Forms » Alert On form (dev 6i, forms 10 g )
Alert On form [message #435210] Tue, 15 December 2009 03:16 Go to next message
annu-agi
Messages: 198
Registered: July 2005
Location: Karachi
Senior Member

dear experts

After a long time i am working on a forms and stuck in a very simple coding kindly help me out of this

declare
	aalert	number;
	al_id alert;
	err_txt varchar2(100) ;
begin
	err_txt:='Do you want to save this record';
	
	if :user_mst.user_pwd=:user_mst.reenter_pwd then
		al_id := Find_Alert('alert_save'); 
		Set_Alert_Property(al_id, Alert_message_text, err_txt ); 
  
		aalert:=show_alert(al_id);
		if aalert=alert_button1 then
			commit_form;
		ELSE
			CLEAR_FORM(NO_VALIDATE);
		END IF; 
	end if;	
end;



i cant identify where i am doing mistake. it shows error on set_alert_property line

and the error is
error 103 at line 10, column 60
encountered the symbol'''' when expectig one of the following:
begen case declare end exception exit for goto if loop mod
..............................
the symbol '''' was ignored

Re: Alert On form [message #435213 is a reply to message #435210] Tue, 15 December 2009 03:31 Go to previous messageGo to next message
Littlefoot
Messages: 20827
Registered: June 2005
Location: Croatia, Europe
Senior Member
Account Moderator
This code compiles fine on my Forms 10g (9.0.4).

When do you get the error (compile or runtime)? Where (Forms 6i or 10g)?
Re: Alert On form [message #435214 is a reply to message #435213] Tue, 15 December 2009 03:50 Go to previous messageGo to next message
annu-agi
Messages: 198
Registered: July 2005
Location: Karachi
Senior Member

hi little foot



at compile time .. and becasue of this error i cant move farword.. by the way i use this code on dev 6i and forms 10 g 10.1.2.0.2

same error on both versions

  • Attachment: untitled.JPG
    (Size: 164.72KB, Downloaded 95 times)
Re: Alert On form [message #435215 is a reply to message #435214] Tue, 15 December 2009 04:10 Go to previous messageGo to next message
Littlefoot
Messages: 20827
Registered: June 2005
Location: Croatia, Europe
Senior Member
Account Moderator
Still no problem here:

./fa/7127/0/

Try to delete this trigger and create it from scratch. Manually type the whole text (don't use copy-paste!), then compile again.

Any success?
Re: Alert On form [message #435218 is a reply to message #435210] Tue, 15 December 2009 04:29 Go to previous messageGo to next message
rajy_salim
Messages: 204
Registered: January 2008
Location: Beirut - Lebanon
Senior Member
I also compiled this code in both 6i and 10g with no errors.

Rajy
Re: Alert On form [message #435219 is a reply to message #435215] Tue, 15 December 2009 04:31 Go to previous messageGo to next message
annu-agi
Messages: 198
Registered: July 2005
Location: Karachi
Senior Member

it works ... i delete all the coding and re-write it again .....its i still dont know .. what it is .. anyway .. thanks for gettin me out ..

little foot on genious head.


anyway .. thanks and regards
Re: Alert On form [message #435224 is a reply to message #435219] Tue, 15 December 2009 04:52 Go to previous message
annu-agi
Messages: 198
Registered: July 2005
Location: Karachi
Senior Member

thank you salim
Previous Topic: Need to eliminate "Do you want to save changes" at close form (merged 4)
Next Topic: Help me
Goto Forum:
  


Current Time: Thu Sep 29 03:58:28 CDT 2016

Total time taken to generate the page: 0.15021 seconds