Home » RDBMS Server » Server Administration » Compilers for oracle patching (oracle,,Linux)
Compilers for oracle patching [message #432942] Fri, 27 November 2009 08:54 Go to next message
Messages: 31
Registered: July 2009

Is gcc-c++ compiler required for Oracle CPU or PSU patching. I already have gcc-3.4.6-11 but no gcc-c++ installed.


Re: Compilers for oracle patching [message #432950 is a reply to message #432942] Fri, 27 November 2009 10:19 Go to previous messageGo to next message
Michel Cadot
Messages: 63911
Registered: March 2007
Location: Nanterre, France, http://...
Senior Member
Account Moderator
I don't think gcc++ is required but the best way to know is to test it, isn't it?

Re: Compilers for oracle patching [message #432985 is a reply to message #432942] Sat, 28 November 2009 01:04 Go to previous message
Messages: 147
Registered: October 2009
Location: Dallas, TX
Senior Member
On linux you need the gnu linkers, but since there are no source modules to compile/recompile there is no need for a compiler. The same OS package requirements that existed for the base installation of the Oracle version you are running is what is required for the CPU and patches unless otherwise notified in the README for the CPU or patch.
Previous Topic: Invalid Object - PRVT_ADVISOR
Next Topic: Find dbms_scheduler Jobs Running
Goto Forum:

Current Time: Sat Oct 22 02:28:02 CDT 2016

Total time taken to generate the page: 0.08039 seconds