Home » Fusion Middleware & Colab Suite » Weblogic & Application Server » developer 6i forms & reports on oracle SOA suite 10.1.3.1.0
developer 6i forms & reports on oracle SOA suite 10.1.3.1.0 [message #432759] Thu, 26 November 2009 02:20 Go to next message
annu-agi
Messages: 199
Registered: July 2005
Location: Karachi
Senior Member

dear experts


I am new to Oracle Application server and concepts .. I have developed so many client server based applications in Oracle developer 6i. Now my management wants that all the application should be web based .. for that i create a infrastructure with 10g database rel 10.2.0.1 and over that i have install oracle soa suite 10.1.3 with application server

so, I think all the preparations has been done ..... now can anyone help me how to make a testing form and deployed on application server .. is there any document or simple step by step procedure to help me out.. (all my applications are developed on dev 6i not on jdev.

so any help would be so appreciable ..


regards

anwer
Re: developer 6i forms & reports on oracle SOA suite 10.1.3.1.0 [message #433212 is a reply to message #432759] Mon, 30 November 2009 13:31 Go to previous messageGo to next message
joy_division
Messages: 4640
Registered: February 2005
Location: East Coast USA
Senior Member
I am not completely sure I know the question here, but using Forms Builder 10g, it will read in a form developed in 6i and automatically convert it.
Save that .fmb file, move it to the app server, compile it and run it with a URL of:
http://[server2:port]/forms/frmservlet?config=[your RAD]&form=[form name]

If you have not set up RADs for SSO, then for testing you can simply just enter an oracle UID/PWD@TNS to get into the form.
Re: developer 6i forms & reports on oracle SOA suite 10.1.3.1.0 [message #433244 is a reply to message #433212] Mon, 30 November 2009 23:39 Go to previous messageGo to next message
annu-agi
Messages: 199
Registered: July 2005
Location: Karachi
Senior Member

Thank you joy..


First i would like to know how to configure server, how to place my forms and report on server and where.... i think then after it is possible to run any form and report .. so kindly guide me from step one how can i configure standard application server and access only one form possible from network ..that all my initial requirment.


regards

anwer


** for help just see the attachment ..the file contain all the initial information about installations
  • Attachment: orapass.txt
    (Size: 3.49KB, Downloaded 443 times)
Re: developer 6i forms & reports on oracle SOA suite 10.1.3.1.0 [message #433316 is a reply to message #433244] Tue, 01 December 2009 08:30 Go to previous messageGo to next message
joy_division
Messages: 4640
Registered: February 2005
Location: East Coast USA
Senior Member
I have said this before...configuring OAS was the hardest thing I ever did and it's not a task to be done without knowledge of what you are doing.
The best thing I can say is to read the documentation and then come back with specific questions.
formsweb.cfg is where most of the configuration for your forms are stored.
Re: developer 6i forms & reports on oracle SOA suite 10.1.3.1.0 [message #434067 is a reply to message #432759] Mon, 07 December 2009 01:59 Go to previous messageGo to next message
annu-agi
Messages: 199
Registered: July 2005
Location: Karachi
Senior Member

after several hit and tries ... i configured form service and report services only ... and now i can run my forms easily .... now as another part .. i want to run reports as on web ..for that i just creat one form on EMP table and one button on it... By pressing a button i want to run report .. that is simple tabular emp list.


My form is running over my machine .. that is developer suite i have install 10 g on my machine ..... and also run these forms from my form and report services machine


but when i run report it doesnt display or run. the coding i have written behind the button is
DECLARE
    vc_url1 varchar2(1000);
BEGIN
    vc_url1:='http://'||:global.mach_name||':8888/reports/rwservlet?report='||:global.RepPath||'emp.rdf&userid=scott/tiger@xe&destype=cache&desformat=html&paramform=no';
    WEB.SHOW_DOCUMENT(vc_url1,'_blank');
END;



any idea what i am doing mistake. any help would be appricaitable


regards


anwer
  • Attachment: emp.fmb
    (Size: 100.00KB, Downloaded 277 times)
Re: developer 6i forms & reports on oracle SOA suite 10.1.3.1.0 [message #434205 is a reply to message #434067] Mon, 07 December 2009 12:47 Go to previous messageGo to next message
joy_division
Messages: 4640
Registered: February 2005
Location: East Coast USA
Senior Member
You can have a look at the reports server log for help on the problem.
Something like
http://{server}:7778/reports/rwservlet/showjobs?queuetype=past&server={report server name}
Re: developer 6i forms & reports on oracle SOA suite 10.1.3.1.0 [message #434364 is a reply to message #434205] Tue, 08 December 2009 23:39 Go to previous message
annu-agi
Messages: 199
Registered: July 2005
Location: Karachi
Senior Member

now error shows ..


Error  
 
   
    REP-51002: Bind to Reports Server  rep_vm-1_frhome1 failed
 
 




how to getrid of this error.

Previous Topic: frmweb crash
Next Topic: Report_path On applicaiton server report services
Goto Forum:
  


Current Time: Sat Dec 03 18:05:01 CST 2016

Total time taken to generate the page: 0.13122 seconds