Home » Developer & Programmer » Forms » Problema ICONOS barra menu forms 10g (FORMS 10G)
Problema ICONOS barra menu forms 10g [message #431308] Mon, 16 November 2009 11:05 Go to next message
byron_osorio26
Messages: 1
Registered: November 2009
Location: cENTRO aMERICA
Junior Member
Mi problema es que no puedo mostrar los iconos de una carpeta en mi maquina, en una forma en forms 10g, con una nueva barra de menu que construi con un par de iconos.

1. hice una aplicacion con una nueva barra de erramientas, diferente a la que trae por default DEFAULT&SMARTBAR y al principio tenia problemas que no encontraba mi nuevo menu de barra de erramientas pero lo solucione poniendo el path en C:\DevSuiteHome_1\forms\server\default.env y agreque en FORMS_PATH= el nuevo path deparado de comas sin espacios en blanco.

2. pero los iconos de mi nueva barra de herramientas no aparecen, entonces investigue todos los lugares que habia que modificar y ninguno me funciono, estos son.
2.1 c:\devsuitehome_1\j2ee\devsuite\application-deployments\forms\formsweb\orion-web.xml
y aqui agregue un path virtual asi:
<virtual-directory virtual-path="/iconos" real-path="C:\aplicaciones\iconos" />
que es donde tengo mis iconos de mi nueva barra.

2.2 c:\devsuitehome_1\forms\server\forms.conf
aqui agregue un alias, para la busqueda de los iconos.
agregue:
AliasMatch ^/forms/iconos/(..*) "C:\aplicaciones\iconos"

2.3 c:\devsuitehome_1\forms\java\oracle\forms\registry\registry.dat

aqui configure el path virtual con el llamado de los iconos donde probe de diferentes maneras, segun consejos encontrados en la web, pero ninguno me funciono.
probe las siguientes formas:
2.3.1 default.icons.iconpath=iconos/
2.3.2 default.icons.iconpath=http : / / mimaquina.dominio. com:8889 /forms/iconos
este ultimo se puede ver al correr la forma, y la direccion que sale esa es la que se utiliza, con todo y el numero de puerto.
2.4 c:\devsuithome_1\forms\server\default.env
aqui agregue los path general:
FORMS_PATH=C:\DevSuiteHome_1\forms;C:\aplicaciones\Iconos

y en el registro de windows agregue a la clave HKEY_LOCAL_MACHINE\SOFTWARE\ORACLE\KEY_DevSuiteHome1
las variables
UI_ICON y le puse el path de mis iconos C:\aplicaciones\iconos\
y agregue la variable
UI_ICON_EXTENSION y le puse el tipo de extension que manejaria que es ICO.
pero nada de todo eso que modifique me funciona.
Alguien podria darme una idea de que me hace falta o que estoy haciendo mal?

Gracias
Re: Problema ICONOS barra menu forms 10g [message #432571 is a reply to message #431308] Wed, 25 November 2009 00:14 Go to previous messageGo to next message
djmartin
Messages: 10180
Registered: March 2005
Location: Canberra ACT Australia
Senior Member
Account Moderator
Have a look at:
Icons in 9i/10g orion-web usage
(someone else's) http://www.orafaq.com/forum/t/78328/0/unread/67467/#msg_225604
mine http://www.orafaq.com/forum/t/75610/2/

David
Re: Problema ICONOS barra menu forms 10g [message #531363 is a reply to message #432571] Tue, 15 November 2011 10:05 Go to previous message
Ag2s
Messages: 1
Registered: November 2011
Location: Honduras
Junior Member
Hi there Dj, I've tried all the links people and you have written about showing icons on oracle forms 10, believe me but I still same problem Sad

it is drive me crazy, pliz any extra help about it? greetings from Honduras

Ag2s
Previous Topic: Browse to get and put file
Next Topic: Oracle Forms Builder \ Object Navigator \ Reports
Goto Forum:
  


Current Time: Wed Sep 28 05:50:28 CDT 2016

Total time taken to generate the page: 0.05625 seconds