Home » Developer & Programmer » Forms » Requesting login and password on each forms
Requesting login and password on each forms [message #430536] Tue, 10 November 2009 22:53 Go to next message
sailesh
Messages: 72
Registered: September 2007
Location: MAURITIUS
Member
Hi all,

I have migrated my oracle 10g db and forms and report to 11gR1. The application server is standalone on 10g application server. I have installed the same version of form & report as it was on 10g. The only problem i am getting is that the user while logging into the application, they have to enter the login and passsword two times. the first time they login, invalid username/password. The second time the users login is good.

Is there any configuration that needs to be done on the formsweb.cfg as the db is now on 11gR1?


thanks,

sailesh
Re: Requesting login and password on each forms [message #430538 is a reply to message #430536] Tue, 10 November 2009 23:09 Go to previous messageGo to next message
javed.khan
Messages: 340
Registered: November 2006
Location: Banglore
Senior Member

Okay here we can go for guess and trace only... Check with this steps.
Open the form and simply close.
Open again and login.
Whats happens then...?

Jak
Re: Requesting login and password on each forms [message #430547 is a reply to message #430538] Wed, 11 November 2009 00:05 Go to previous messageGo to next message
sailesh
Messages: 72
Registered: September 2007
Location: MAURITIUS
Member
Hi,

The same thing happens.
The user has to login 2 times.


sailesh
Re: Requesting login and password on each forms [message #430556 is a reply to message #430547] Wed, 11 November 2009 00:58 Go to previous messageGo to next message
javed.khan
Messages: 340
Registered: November 2006
Location: Banglore
Senior Member

Why I asked to do it is.
To check the event.See what just now u did is just opened the login form and closed means something like flag or some global parameter intialized @ this time which is used on second time. all you have to check the login form. dig into that you will surely get a way out.

Jak
Re: Requesting login and password on each forms [message #430564 is a reply to message #430556] Wed, 11 November 2009 01:19 Go to previous messageGo to next message
sailesh
Messages: 72
Registered: September 2007
Location: MAURITIUS
Member
Hi,

The problem is that it is working fine on the 10g database. Only on 11g i am facing the problem.

sailesh
Re: Requesting login and password on each forms [message #430611 is a reply to message #430564] Wed, 11 November 2009 03:28 Go to previous messageGo to next message
javed.khan
Messages: 340
Registered: November 2006
Location: Banglore
Senior Member

If I were you i was about to build a new Login form and see wether every form in 11i will ask twice for password?
Re: Requesting login and password on each forms [message #430899 is a reply to message #430611] Thu, 12 November 2009 23:52 Go to previous messageGo to next message
sailesh
Messages: 72
Registered: September 2007
Location: MAURITIUS
Member
hi,

I created a new forms in 11g and i am encountering the same problem. After logging twice with my username and password, it was ok.


thanks,

Sailesh
Re: Requesting login and password on each forms [message #431067 is a reply to message #430899] Sat, 14 November 2009 04:45 Go to previous messageGo to next message
javed.khan
Messages: 340
Registered: November 2006
Location: Banglore
Senior Member

Means theres nothing wrong with your form may be u should go through the manuals of 11g. Anyway in my case its okay i am able to get into the application once.
Re: Requesting login and password on each forms [message #432558 is a reply to message #430536] Tue, 24 November 2009 23:01 Go to previous messageGo to next message
djmartin
Messages: 10180
Registered: March 2005
Location: Canberra ACT Australia
Senior Member
Account Moderator
Have you solved your problem?

David
Re: Requesting login and password on each forms [message #432707 is a reply to message #432558] Wed, 25 November 2009 22:47 Go to previous message
sailesh
Messages: 72
Registered: September 2007
Location: MAURITIUS
Member
hi,

the problem was that the login and password at the database level was in lower case. But in the application, the code converts the lower case to upper case.

Hence in 11g i just disable the case sensitive feature. it was Sriram from orafaq that gave me the idea.

Thanks Sriram very much.


SQL> show parameter sec_case_sensitive_logon

NAME TYPE VALUE
------------------------------------ ----------- ------------------------------
sec_case_sensitive_logon boolean TRUE

SQL> alter system set sec_case_sensitive_logon=false;

System altered.
Previous Topic: rwserver -install repserver not working
Next Topic: displaying parameters on the plotted graph
Goto Forum:
  


Current Time: Sat Dec 03 12:29:37 CST 2016

Total time taken to generate the page: 0.13525 seconds