Home » Developer & Programmer » Forms » Error Running Form on Web (Oracle 10G Dev Suite, Win XP Professional)
Error Running Form on Web [message #430019] Fri, 06 November 2009 22:30 Go to next message
maqaisar
Messages: 3
Registered: November 2009
Junior Member
I have gone through various errors before hitting this. I made few changes like changing the port number to 8057 in portlist file as well as in "default-web-site" file. I also changed in the runtime preference to use "mycomp_name":8057/forms90/f90servlet"

It takes me to the web and then it starts to give error relating DEP - Data Execution Prevention

Just to add that I have already changed this option to turn on DEP for all Program and services except those I select.

Finally it closes the error message and ask to send error which I suppose come from the web page of Microsoft. Please see the attahed document for the trail.

Any help extremely appreciated and thanking you in Advance.
./fa/6976/0/
  • Attachment: FormError.JPG
    (Size: 113.27KB, Downloaded 655 times)
Re: Error Running Form on Web [message #430031 is a reply to message #430019] Sat, 07 November 2009 01:35 Go to previous messageGo to next message
javed.khan
Messages: 340
Registered: November 2006
Location: Banglore
Senior Member

Try after disabling this feature in your PC.
If a program is failing and you want to disable DEP to see if that is the cause. Here are the steps. (Just disable DEP for the program in question... don't disable it for your whole system.)

1. Click Start
2. Select Control Panel
3. Select System
4. Click the Advanced tab
5. In the Performance region select Settings
6. Click the Data Execute tab in the dialog box that opens
7. Select Turn on DEP for all programs and services except for those I select
8. Click Add.
9. The open dialog box will open. Browse and select your application.
10. Click Open
11. Click Apply
12. Click Ok
13. Reboot



Jak
  • Attachment: DEP.JPG
    (Size: 570.53KB, Downloaded 195 times)

[Updated on: Sat, 07 November 2009 01:40]

Report message to a moderator

Re: Error Running Form on Web [message #430083 is a reply to message #430019] Sun, 08 November 2009 02:05 Go to previous messageGo to next message
maqaisar
Messages: 3
Registered: November 2009
Junior Member
I have tried this but the error remained the same. Even I enabled popups as well just as pre-caution. I'll appreciate any help to get rid of this error.
Thanks.
Re: Error Running Form on Web [message #430196 is a reply to message #430083] Mon, 09 November 2009 07:23 Go to previous messageGo to next message
javed.khan
Messages: 340
Registered: November 2006
Location: Banglore
Senior Member

Dear Maj,

DEP have two options might be we have to look deep inside into your system files now. so let have a look.DEP configuration for the system is controlled through switches in the Boot.ini file. If you are logged on as an administrator, you can now easily configure DEP settings by using the System dialog box in Control Panel.

Now one way to do what i am using and working for me fine and allready told to you is

Click Start, click Run, type sysdm.cpl, and then click OK.
On the Advanced tab, under Performance, click Settings.
On the Data Execution Prevention tab, use one of the following procedures:
Click Turn on DEP for essential Windows programs and services only to select the OptIn policy.
Click Turn on DEP for all programs and services except those I select to select the OptOut policy, and then click Add to add the programs that you do not want to use the DEP feature.
Click OK two times.

Other one is editing your boot.ini file can be quite dengerous and needs expertise when editing The Boot.ini file can be modified directly with scripting mechanisms or with the Bootcfg.exe tool that is included in Windows XP SP2.

To configure DEP to switch to the AlwaysOn policy by using the Boot.ini file, follow thes steps:
Click Start, right-click Mye Computer, and then click Properties.
Click the Advanced tab, and then click Settings under the Startup and Recovery field.
In the System starrtp field, click Edit. The Boot.ini file opens in Notepad.
In Notepad, click Find on the Edit menu.
In the Find what box, type /noexecute, and then click Find Next.
In the Find dialog box, click Cancel.
Replace policy_level with AlwaysOff.

Plss Plss Plss Make sure that you enter the text accurately. The Boot.ini file switch should now read:
/noexecute=AlwaysOff

An Always Off will not cover any Security level for data excecution

In Notepad, click Save on the File menu.
Click OK two times.
Restart the computer.

Good Luck
Jak


[Updated on: Mon, 09 November 2009 07:38]

Report message to a moderator

Re: Error Running Form on Web [message #430230 is a reply to message #430196] Mon, 09 November 2009 11:00 Go to previous messageGo to next message
maqaisar
Messages: 3
Registered: November 2009
Junior Member
Thanks very much for all the help, unfortunately it didn't do any good to me. Now it gets in the loop error and tries to recover the page and fails. I have made the changes in the boot file to read as AlwaysOff, previously it was Optout.

I'll appreciate any hints to get through this. This has become a nightmare to run Oracle Forms 10G... Is there any problem with the Explorer 8?

Thanks.

./fa/6992/0/
  • Attachment: Boot File.JPG
    (Size: 37.60KB, Downloaded 587 times)
Re: Error Running Form on Web [message #430322 is a reply to message #430230] Tue, 10 November 2009 01:45 Go to previous message
javed.khan
Messages: 340
Registered: November 2006
Location: Banglore
Senior Member

Smile Well i guess its Clean XP with SP3 Okay...
lets see what they have to say about this...

http://www.slickit.ca/2009/03/internet-explorer-fix-ie8-dep-crashes.html


Thanks Jak
Previous Topic: remove the border of pushbutton
Next Topic: Unable to views icon on button at run time
Goto Forum:
  


Current Time: Sat Sep 24 16:21:50 CDT 2016

Total time taken to generate the page: 0.09643 seconds