Home » Developer & Programmer » Forms » Parameter Problem` (Oracle 10g,Dev 10g)
Parameter Problem` [message #429583] Wed, 04 November 2009 12:06 Go to next message
Messages: 17
Registered: September 2008
Junior Member

My report works fine without values in text item for date which passes to parameter.
(char 15) item contains following code on key next item trigger

when i leave the text item empty and click report button then
report work fine but when i enter value '01012009' and click report button then following error occures
REP-52251: Cannot get output of job ID 71 you requested on Thu Nov 05 23:00:56 
PKT 2009.<P>REP-51026: No output for job 71

code for parameter are
Add_Parameter(list_id, 'F_DATE',TEXT_Parameter,:CONTROL.FROMDATE);
	Add_Parameter(list_id, 'T_DATE',TEXT_Parameter,:CONTROL.TODATE);

Please suggest what to now.Thanx
Re: Parameter Problem` [message #429682 is a reply to message #429583] Thu, 05 November 2009 03:48 Go to previous message
Messages: 204
Registered: January 2008
Location: Beirut - Lebanon
Senior Member
It may be a problem of datatypes.
What happens if you enter "01/01/2009" instead of "01012009"?
What is the datatype of the parameter set in the report? Is it Character or Date??
If it is Date, you must re-use the to_date function in the report to convert the value passed as Character.

Previous Topic: Forms 6i - dynamic order by problem
Next Topic: Writing to excel using forms 10g, Apps setup
Goto Forum:

Current Time: Thu Oct 27 18:34:01 CDT 2016

Total time taken to generate the page: 0.08634 seconds