Home » Applications » Oracle Fusion Apps & E-Business Suite » CUSTOMER INTERFACE (Oracle, 11.5.10.2, Windows XP)
icon5.gif  CUSTOMER INTERFACE [message #428912] Fri, 30 October 2009 13:01 Go to next message
oraclefaqs1
Messages: 23
Registered: October 2008
Location: SC
Junior Member

hi Guys,

It has been a while since I got in here.
Howz everyone ?.

I had a question regarding Customer conversion. For my current client I need to do a customer conversion process from a data extract file to Oracle.

Here's the deal, since it is a 11.5.10.2 version I think I can still use CUSTOMER INTERFACE IMPORT seeded program for importing the customer data, I am able to get all the required information to populate the Interface tables, but he needs that I need to populate the ACCOUNT_NAME and SALES_CHANNEL_CODE field with LEGACY NUMBER and some REPORT GROUP respectively coming from the extract, I am unable to figure out what is the corresponding column in the interface table RA_CUSTOMERS_INTERFACE_ALL need to be populated to hit these fields. needed ASAP

thanks,
purna
Re: CUSTOMER INTERFACE [message #429186 is a reply to message #428912] Mon, 02 November 2009 08:08 Go to previous messageGo to next message
idris.ali
Messages: 34
Registered: June 2008
Location: Hyderabad
Member
Hi Purna,

Customer Interface doesn't support all the columns corresponding to a Customer.

Pls go thru
AR User Guide->Customer->Customer Interface->Customer Interface Table Descriptions and Validation

I don't think any of the columns you mentioned is supported Sad

Thanks,
Idris
Re: CUSTOMER INTERFACE [message #429258 is a reply to message #429186] Mon, 02 November 2009 18:40 Go to previous messageGo to next message
oraclefaqs1
Messages: 23
Registered: October 2008
Location: SC
Junior Member

Thanks Idris.

I think we are doing the other way for that. But now I am coming across the following problem, when I am trying to insert sample record into interface tables and run the CUSTOMER INTERFACE IMPORT to create a customer. It gives the following error

Customer Interface Ends with Error: Customer Record For Insert Must Have Validated Profile Record Defined In The RA_CUSTOMER_PROFILES_INTERFACE table.

Below are my insert statements

Insert into ra_customers_interface_all (ORIG_SYSTEM_CUSTOMER_REF
,ORIG_SYSTEM_ADDRESS_REF ,SITE_USE_CODE ,INSERT_UPDATE_FLAG ,CUSTOMER_STATUS
,CUSTOMER_NAME ,PRIMARY_SITE_USE_FLAG ,LOCATION ,ADDRESS1 ,ADDRESS2 ,CITY ,STATE ,COUNTY ,COUNTRY ,POSTAL_CODE ,CUSTOMER_NAME_PHONETIC ,TRANSLATED_CUSTOMER_NAME ,LAST_UPDATED_BY ,LAST_UPDATE_DATE ,CREATED_BY ,CREATION_DATE ,PERSON_FIRST_NAME ,PERSON_LAST_NAME ,PERSON_FLAG )
values (104645
,1
,'BILL_TO'
,'I'
,'A'
,'EDWARD TOOLE'
,'Y'
,'MENDENHALL'
,'P.O. BOX 11'
,NULL
,'MENDENHALL'
,'PA'
,'CHESTER'
,'US'
, 19357
,'EDWARD ALTERNATE NAME'
,'EDWARD ACCOUNT NAME'
,4710
,sysdate
,4550
,sysdate
,'EDWARD'
,'TOOLE'
,'Y'
)



Insert into ra_customer_profiles_int_all (INSERT_UPDATE_FLAG
,ORIG_SYSTEM_CUSTOMER_REF ,ORIG_SYSTEM_ADDRESS_REF ,CUSTOMER_PROFILE_CLASS_NAME -- ,COLLECTOR_NAME -- ,STANDARD_TERM_NAME ,CURRENCY_CODE ,OVERALL_CREDIT_LIMIT ,TRX_CREDIT_LIMIT ,CREDIT_HOLD ,LAST_UPDATED_BY ,LAST_UPDATE_DATE ,CREATION_DATE ,CREATED_BY ,VALIDATED_FLAG )
values ('I'
,104645
,1
,'DEFAULT'
-- ,'DEFAULT'
,'USD'
,'20000'
,'5000'
,'N'
,4710
,SYSDATE
,SYSDATE
,4550
,'Y'
)


I looked all over metalink, but it gives stupid answers and neither works like inserting two records into RA_CUSTOMER_PROFILES_INT_ALL for each customer in RA_CUSTOMERS_INTERFACE_ALL one with ORIG_SYSTEM_CUSTOMER_REF AND ORIG_SYSTEM_ADDRESS_REF and the other with just ORIG_SYSTEM_CUSTOMER_REF.

could someone please help me ASAP.

thanks,
purna
Re: CUSTOMER INTERFACE [message #429916 is a reply to message #428912] Fri, 06 November 2009 05:06 Go to previous message
idris.ali
Messages: 34
Registered: June 2008
Location: Hyderabad
Member
Hi purna,

"There should be at-least one customer profile (customer level)
for each customer".

Though you are inserting a record in RA_CUSTOMER_PROFILE_INT
you are passing ORIG_SYSTEM_ADDRESS_REF = 1 (which means
its a Site level Profile and not customer level).
For a customer level profile orig_system_address_ref = null.

So you modify the insert to pass orig_system_address_ref while inserting in ra_customer_profile_int as NULL and it will fix the issue for you.

Thanks,
Idris
Previous Topic: get the request parameter from global variable on the form
Next Topic: Customer conversion
Goto Forum:
  


Current Time: Sat Oct 01 14:28:47 CDT 2016

Total time taken to generate the page: 0.14883 seconds