Home » Developer & Programmer » Forms » How to Run a Oracle 10g Report in Forms 10g (10g)
How to Run a Oracle 10g Report in Forms 10g [message #425470] Fri, 09 October 2009 04:49 Go to next message
suyog
Messages: 4
Registered: October 2009
Location: pune
Junior Member
Hi, i am a programmer,working with Forms & Reports 6i. Now i am going to work with Forms & Reports 10g. I am facing one problem while i am running a report in oracle 10g. I have created 1 form. In that form i am calling one report. I have also added 1 button to call the report. I also have written 1 procedure Names : RUN_REPORT_OBJECT_PROC ( Downloaded it form the Internet). In the call to the form: i am writting 1 trigger : when_button_pressed. in this trigger, i am giving a call to my report.The paramentrs given are as below :
RUN_REPORT_OBJECT_PROC( <Report_Name>,
'repserv10g@fnimphiu-pc',
'HTMLCSS',
CACHE,
'REPTEST',
'SDUDPIRUP \HV',
/reports/rwservlet');

I want to know that what is the value should i enter as a report_server_name.
I am working on a local machine. i also have created a database on my own machine & accessing the same.
Re: How to Run a Oracle 10g Report in Forms 10g [message #425478 is a reply to message #425470] Fri, 09 October 2009 05:13 Go to previous messageGo to next message
klat
Messages: 87
Registered: May 2009
Location: Mumbai
Member


create a report sever of your own , say suyog_repserver and use it.

from command prompt enter the following line
rwserver server = suyog_repserver start

HOpe it will work

Re: How to Run a Oracle 10g Report in Forms 10g [message #425486 is a reply to message #425478] Fri, 09 October 2009 05:35 Go to previous messageGo to next message
suyog
Messages: 4
Registered: October 2009
Location: pune
Junior Member
Hi,
Thanks for the reply . i have create my own server.
I am calling this procedure from the When_Button_Pressed Trigger.
The PArameters for the Procedure are :
RUN_REPORT_OBJECT_PROC(report_id REPORT_OBJECT,
report_server_name varchar2,
report_format varchar2,
report_destype_name number,
report_file_name varchar2,
report_otherparam varchar2,
reports_servlet varchar2)
I am entering the parameters in the trigger for calling this are :
(933,
'suyog_repserver',
'HTML',
933,
'b2re933ss.rdf',
null,
null)
While doing the compilation of the Form i am getting the following error:
Error 306 at line 1 ,column 1
wrong number of types of arguments in call to 'RUN_REPORT_OBJECT_PROC'

As the parameters for the procedure and the parameters in the trigger are the same.

Please help me.
Re: How to Run a Oracle 10g Report in Forms 10g [message #425491 is a reply to message #425486] Fri, 09 October 2009 05:49 Go to previous messageGo to next message
klat
Messages: 87
Registered: May 2009
Location: Mumbai
Member

I don't know about this procedure. Please check report_destype_name.

Why don't you try web.show_document for displaying reports.

Re: How to Run a Oracle 10g Report in Forms 10g [message #425494 is a reply to message #425491] Fri, 09 October 2009 05:51 Go to previous messageGo to next message
rajy_salim
Messages: 204
Registered: January 2008
Location: Beirut - Lebanon
Senior Member
Did you attach the report to the form?

Rajy
Re: How to Run a Oracle 10g Report in Forms 10g [message #425495 is a reply to message #425494] Fri, 09 October 2009 05:57 Go to previous message
suyog
Messages: 4
Registered: October 2009
Location: pune
Junior Member
Yes,i have attached the report to my form.
Previous Topic: Search character using wild card method using Forms Devloper
Next Topic: Problem in run form and OC4J
Goto Forum:
  


Current Time: Fri Sep 30 03:47:52 CDT 2016

Total time taken to generate the page: 0.26129 seconds