Home » Applications » Oracle Fusion Apps & E-Business Suite » BOM_BO_PUB.process_bom processes first bom and errors out every run (BOM 11.5.0.9 HP UNIX )
BOM_BO_PUB.process_bom processes first bom and errors out every run [message #425374] Thu, 08 October 2009 16:43 Go to next message
oraappsfaq
Messages: 9
Registered: August 2009
Location: US
Junior Member
I have a custom code using BOM_BO_PUB.process_bom API in which I am creating a simple BOM structure. It creates first bom and errors out for subsequent bom's. If I run the program again previously error bom processes just fine but one at a time. I think I am missing on some initialization somewhere but not able to pinpoint it. Could some one help me out?

Error is

Return Status = E
Message Count = 1
1 MESSAGE TEXT Records in a business object must have the same key values. Not all records in this business object are having the same key values. Please ensure that the assembly item name, organization code and alternate designator values are the same for all reco
1 MESSAGE TYPE E

[Updated on: Thu, 08 October 2009 17:02]

Report message to a moderator

Re: BOM_BO_PUB.process_bom processes first bom and errors out every run [message #425557 is a reply to message #425374] Fri, 09 October 2009 11:42 Go to previous messageGo to next message
oraappsfaq
Messages: 9
Registered: August 2009
Location: US
Junior Member
Has anyone worked on BOM_BO_API.process_bom before? Please help.
Re: BOM_BO_PUB.process_bom processes first bom and errors out every run [message #448139 is a reply to message #425557] Fri, 19 March 2010 13:32 Go to previous messageGo to next message
pikku24
Messages: 18
Registered: March 2010
Junior Member
Hi ,
I am facing the same issue on this api .Any reply to this ?

Thanks
Re: BOM_BO_PUB.process_bom processes first bom and errors out every run [message #521022 is a reply to message #448139] Thu, 25 August 2011 18:55 Go to previous messageGo to next message
vyenduri
Messages: 2
Registered: August 2011
Junior Member
Are u able to solve the problem that u are facing with bom creation using the API. If u are able to solve it could u please let me the solution. I am also facing the same issue.
Re: BOM_BO_PUB.process_bom processes first bom and errors out every run [message #521023 is a reply to message #425374] Thu, 25 August 2011 18:58 Go to previous messageGo to next message
vyenduri
Messages: 2
Registered: August 2011
Junior Member
if u fixed the errors, could u please send me the solution.
Re: BOM_BO_PUB.process_bom processes first bom and errors out every run [message #521757 is a reply to message #521023] Thu, 01 September 2011 15:03 Go to previous message
vamsi kasina
Messages: 2107
Registered: October 2003
Location: Riyadh, Saudi Arabia
Senior Member
Folks,
Please start a new thread with the full details [release, error, what is your code, etc].
Please read the Forum Guides before posting.
OraFAQ Forum
Oracle Apps Forum Guide
I'm locking this thread, as it is very old.

By
Vamsi
Previous Topic: Concurrent Program Parameter Validation
Next Topic: Tuning select statement that link between sub ledgers and GL
Goto Forum:
  


Current Time: Sat Dec 10 08:42:13 CST 2016

Total time taken to generate the page: 0.11557 seconds