Home » Server Options » RAC & Failsafe » Connection from oracle cliente 10g to RAC with 2 nodes (Oracle RAC 10G R2)
Connection from oracle cliente 10g to RAC with 2 nodes [message #425134] Wed, 07 October 2009 12:47 Go to next message
celsog1
Messages: 2
Registered: October 2009
Location: San Jose
Junior Member
hello, i need your help

I´m trying to configure a connection from my oracle client 10g in Windows XP with a Oracle Rac Database 10G R2. The cluster database have 2 nodes, when i put the connection string in the TNSnames.ora file in the side my oracle client, i achieve connect the first time, but, de second time not success because appears the error "ORA-12545: the connection failed because the host destiny or the object don´t exist". I'm triyig to fix this error and I'm reding articules about connections, bust i don´t resolve the problem.

The connection string in the TNSnamse. ora in the side client and the side servers nodes of cluster is it:

PR_TAF =
(DESCRIPTION =
(ENABLE = BROKEN)
(ADDRESS_LIST =
(ADDRESS = (PROTOCOL = TCP)(HOST = A.B.C.D)(PORT = 1521))
(ADDRESS = (PROTOCOL = TCP)(HOST = A.B.C.D)(PORT = 1521))
)
(LOAD_BALANCE = ON)
(FAILOVER = ON )
(CONNECT_DATA =
(SERVER = DEDICATED)
(SERVICE_NAME = pr_taf)
(FAILOVER_MODE =
(TYPE = SELECT)
(METHOD = BASIC)
(RETRIES = 180)
(DELAY = 5)
)
)
)
Re: Connection from oracle cliente 10g to RAC with 2 nodes [message #425135 is a reply to message #425134] Wed, 07 October 2009 12:56 Go to previous messageGo to next message
Mahesh Rajendran
Messages: 10630
Registered: March 2002
Location: oracleDocoVille
Senior Member
Account Moderator
Are you sure you are using HOST=VIRTUAL_IP ?
Re: Connection from oracle cliente 10g to RAC with 2 nodes [message #425143 is a reply to message #425135] Wed, 07 October 2009 14:33 Go to previous messageGo to next message
celsog1
Messages: 2
Registered: October 2009
Location: San Jose
Junior Member
Yes I´m using the Virtual IP's for the string connection in the TNSnames.ora file in the windows client side, in the TNSnames.ora in the nodes side no, but, from windows oracle client the connection is success for the first time, the second time present error, the third time is success, the fourth time present error again, you see the secuence. For me, the connection from de windows client only work for one node, but the service taf in the cluster is works in both nodes, for the service taf the two instances databases are prefered. I don´t now what is the configuration error.
Re: Connection from oracle cliente 10g to RAC with 2 nodes [message #425157 is a reply to message #425143] Wed, 07 October 2009 18:12 Go to previous message
ebrian
Messages: 2794
Registered: April 2006
Senior Member
Verify that the local_listener value is set for each node and that it is using the VIP address.
Previous Topic: Problem in JDBC Connection (RAC in 11G Release 2 )
Next Topic: Cluster not working
Goto Forum:
  


Current Time: Fri Nov 28 20:36:16 CST 2014

Total time taken to generate the page: 0.11072 seconds