Home » Developer & Programmer » Forms » Sending Mails thru Oracle Reports(6i or 10g) on Oracle Application Server (Oracle Reports(6i or 10g) , Oracle Application Server9iR1 or 10g)
icon6.gif  Sending Mails thru Oracle Reports(6i or 10g) on Oracle Application Server [message #424255] Thu, 01 October 2009 02:28 Go to next message
ali_sakar
Messages: 22
Registered: February 2009
Location: Mumbai
Junior Member

Hi,

We make Products using Oracle Forms and Reports 6i which is currently working fine on Client/Server. When we deployed the same on AS, then we found out that mailing thru reports is not working. Can anyone help on how to achieve it?

Ali.
Re: Sending Mails thru Oracle Reports(6i or 10g) on Oracle Application Server [message #424522 is a reply to message #424255] Fri, 02 October 2009 23:42 Go to previous messageGo to next message
m.bhatkrishna@gmail.com
Messages: 6
Registered: September 2009
Junior Member
Hi,
You can use destype=mail option while passing paramters to the web.show_document
You can also include &cc=''&&bcc=' ' option along with this
So that your final URL will be

hp://servername:port/reports/rwservlet?server=<repservername>&destype=mail&desname=<xyz@xyz.com>&destype=<pdf>&cc=xyzx@xyz.com&desformat=pdf&report=<some.rdf>


You have to configure the smtp server ip addres in your application Server for sending mail.
go to the directory
<Orahome>/<MidHome>/reports/config/<reportservername.conf>
edit the following tag
<!--pluginParam name="mailServer">%MAILSERVER_NAME%</pluginParam-->

as
<pluginParam name="mailServer">SMTP ipaddress:port</pluginParam>

and restart the reports server.and check the above url ..
Regards,
Krishna
Re: Sending Mails thru Oracle Reports(6i or 10g) on Oracle Application Server [message #424543 is a reply to message #424255] Sat, 03 October 2009 05:21 Go to previous messageGo to next message
ali_sakar
Messages: 22
Registered: February 2009
Location: Mumbai
Junior Member

Thanx a lot Krishna. I will try this as soon as possible and update this post.

When using 10g AS
In the meanwhile I came across this problem of security. When I try to create the report using the URL, all the parameter values and everything becomes visible to the user. This is not accepted by my PM. Is there any work around for this? I also tried using run_report_object, but it requires report_object in all my forms thats calling the report. I have around 300 such forms so this seems to be quite a non-practical soln. If you could suggest something better.

Thanking in advance.

Ali.
Re: Sending Mails thru Oracle Reports(6i or 10g) on Oracle Application Server [message #426345 is a reply to message #424543] Thu, 15 October 2009 00:48 Go to previous messageGo to next message
djmartin
Messages: 10180
Registered: March 2005
Location: Canberra ACT Australia
Senior Member
Account Moderator
Do NOT ask a new question in an old thread!!

Search this forum for 'hide url'.

David
Re: Sending Mails thru Oracle Reports(6i or 10g) on Oracle Application Server [message #428749 is a reply to message #424543] Thu, 29 October 2009 16:12 Go to previous message
pitss_guy
Messages: 2
Registered: August 2009
Junior Member
It is unfortunately required that you have a report and additional report objects (DESNAME, DESTYPE, etc). There is software that we, PITSS America, offers which can add these objects quickly. 300 forms would take PITSS.con about 2 minutes to take care of. This is just one of the actions that is automated using the software to Migrate from any version to 10g. www.pitssamerica.com is the site if you want more information.

Another option might be to use Migration Assistant provided by Oracle. This is very clunky and doesn't handle all of the issues, which is why Oracle recommends PITSS. But it might solve this one issue for you.

Cheers
Previous Topic: datablock item is not getting updated?
Next Topic: ora-29283 invalid file operation
Goto Forum:
  


Current Time: Tue Sep 27 02:35:47 CDT 2016

Total time taken to generate the page: 0.06954 seconds