Home » Applications » Oracle Fusion Apps & E-Business Suite » Compile Errors in 10g using template.fmb (win 2k3, EBS 12.1.1, Forms Version 10.1.2.0.2)
Compile Errors in 10g using template.fmb [message #424218] Wed, 30 September 2009 15:48
oasisfaq
Messages: 1
Registered: September 2009
Junior Member
Thank you in advance gurus.

I'm new to EBS and Oracle Forms Development. I am in the process of verifying my new development environment installation.

I have installed EBS 12.1.1 and Forms Builder 10g (Forms [32 Bit] Version 10.1.2.0.2). This runs on Win 2003 Standard Ed. sp2 in VMWare Workstation 6.5.

I have a working directory 'C:\Forms_Workspace'. In which, I have copied APPSTAND.fmb, CUSTOM.pll, APPCORE.pll, template.fmb, etc (see below). This directory also contains the forms I will be modifying.
***************************************************************
C:\Forms_Workspace>ls
APPCORE.pll FNDSQF.pll JL.pll SETUP_TEST.fmx VERT2.pll
APPDAYPK.pll GHR.pll OPM.pll TEMPLATE_TEST.fmb VERT3.pll
APPFLDR.pll GLOBE.pll PQH_GEN.pll TEST2.fmb VERT4.pll
APPSTAND.fmb JA.pll PSAC.pll VERT.pll VERT5.pll
CUSTOM.pll JE.pll SETUP_TEST.fmb VERT1.pll XXOEXOEORD.fmb
***************************************************************

I have updated: C:\Form_Dev_Install\forms\server\default.env
FORMS_PATH=C:\Form_Dev_Install\forms;C:\Forms_Workspace

I have added to: My Computer > Properties > Environmental Variables
FORMS_PATH C:\Forms_Workspace

I can successfully run the C:\Form_Dev_Install\forms\test.fmb and my C:\Forms_Workspace\SETUP_TEST.fmb. These don't include any PLLs. I CAN'T compile the template.fmb (TEMPLATE_TEST.fmb). Looks like the PLLs aren't found. Many Errors. One example below.
****************************************
Code:
if (name_in('system.mode') = 'ENTER-QUERY') then
app_exception.disabled;
return;
end if;

Compilation Error:
Package Body: APP_CUSTOM, 4 Errors
Error 302 at Line 22, column 19
component 'DISABLED' must be declared
****************************************

Questions:
1) Is the default.env for OC4J while the Env Variable is for Forms Builder?
2) Should I be able to compile the template.fmb if it is simply copied and unchanged?
3) I believe Forms Builder is not locating the PLLs. What might be the root cause and possible solutions?

Final note: I copied all the PLLs and the template.fmb to the C:\Form_Dev_Install\forms dir and attempted to compile it. Compilation failed with the same errors.

Thank you for your help and guidance. Please tell me if there is any additional information I can provide or clarify. Thanks again.

Trey
Previous Topic: SSHR Bug: One of the Approvers is "BLANK" !!
Next Topic: A new person type can not be found in the Person Type Usage !
Goto Forum:
  


Current Time: Mon Dec 05 02:54:33 CST 2016

Total time taken to generate the page: 0.11211 seconds