Home » RDBMS Server » Backup & Recovery » ORA-01034: Oracle Not Available - I know what I did, but I don't know how to fix it (Oracle 10g XE, 10.2.0, Windows XP)
icon5.gif  ORA-01034: Oracle Not Available - I know what I did, but I don't know how to fix it [message #423539] Fri, 25 September 2009 04:04 Go to next message
newbie_dev
Messages: 1
Registered: September 2009
Location: Atlanta
Junior Member
Hi everyone,

I know you have probably heard this question more times than there is fingers and toes in the world, but I was having trouble finding documentation about my exact situation. I am new to Oracle, so please be gentle. Here it goes:

I have Oracle 10g express installed on a Parallels VM running Windows XP. Everything was working fine, I was running queries for an assignment. I was having to run create.sql and insert.sql scripts every time I started the SQL command line and logged in. It was starting to get annoying, so thought I would try to save it. So I typed something like, "SAVE a2db", I think, and it seemed to work.

I logged off the database and shut down the Guest OS with Oracle 10g XE installed running on Parallels VM. When I got back on a little bit later, I still had to run the create.sql and insert.sql scripts. So I tried to save it again as "a2db", but it said that it was already mounted. So, for some reason I had the bright idea of trying to delete it so I could make a new one. I found the following instructions for deleting a database.

I logged in AS SYSDBA and typed in these commands:

Quote:
SQL> shutdown immediate;
oracle database closed
oracle database dismounted
oracle instance shutdown

SQL> startup restrict mount;
SQL> drop database;
Database dropped

SQL> exit




Since I did that I have not been able to do much, I could really use any insight from more experienced users.


Here is some more output stuff that may be helpful:

Quote:
SQL> connect
Enter user-name: system
Enter password:
ERROR:
ORA-01034: ORACLE not available
ORA-27101: shared memory realm does not exist


SQL> connect AS SYSDBA
Enter user-name: system
Enter password:
Connected to an idle instance.
SQL> startup
ORA-01078: failure in processing system parameters
ORA-01565: error in identifying file 'C:\Oracle\app\oracle\product\10.2.0\server\dbs/spfileXE.ora'
ORA-27041: unable to open file
OSD-04002: unable to open file
O/S-Error: (OS 2) The system cannot find the file specified.
SQL>


Finally here are lines from two files, I am not sure if they will be helpful:

From 'C:\Oracle\app\oracle\admin\XE\bdump\alert_xe.txt'
:

Quote:
Fri Sep 25 01:38:10 2009
Shutting down instance: further logons disabled
Fri Sep 25 01:38:13 2009
Stopping background process CJQ0
Fri Sep 25 01:38:13 2009
Stopping background process QMNC
Fri Sep 25 01:38:15 2009
Stopping background process MMNL
Fri Sep 25 01:38:16 2009
Stopping background process MMON
Fri Sep 25 01:38:18 2009
Shutting down instance (immediate)
License high water mark = 2
Fri Sep 25 01:38:18 2009
Stopping Job queue slave processes
Fri Sep 25 01:38:18 2009
Job queue slave processes stopped
Waiting for dispatcher 'D000' to shutdown
All dispatchers and shared servers shutdown
Fri Sep 25 01:38:20 2009
ALTER DATABASE CLOSE NORMAL
Fri Sep 25 01:38:22 2009
SMON: disabling tx recovery
SMON: disabling cache recovery
Fri Sep 25 01:38:32 2009
Shutting down archive processes
Archiving is disabled
Archive process shutdown avoided: 0 active
Thread 1 closed at log sequence 17
Successful close of redo thread 1
Fri Sep 25 01:38:40 2009
Completed: ALTER DATABASE CLOSE NORMAL
Fri Sep 25 01:38:40 2009
ALTER DATABASE DISMOUNT
Completed: ALTER DATABASE DISMOUNT
ARCH: Archival disabled due to shutdown: 1089
Shutting down archive processes
Archiving is disabled
Archive process shutdown avoided: 0 active
ARCH: Archival disabled due to shutdown: 1089
Shutting down archive processes
Archiving is disabled
Archive process shutdown avoided: 0 active
Fri Sep 25 01:39:11 2009
Starting ORACLE instance (restrict)
LICENSE_MAX_SESSION = 0
LICENSE_SESSIONS_WARNING = 0
Picked latch-free SCN scheme 2
Using LOG_ARCHIVE_DEST_10 parameter default value as

USE_DB_RECOVERY_FILE_DEST
Autotune of undo retention is turned on.
IMODE=BR
ILAT =10
LICENSE_MAX_USERS = 0
SYS auditing is disabled
ksdpec: called for event 13740 prior to event group initialization
Starting up ORACLE RDBMS Version: 10.2.0.1.0.
System parameters with non-default values:
sessions = 49
__shared_pool_size = 71303168
__large_pool_size = 8388608
__java_pool_size = 4194304
__streams_pool_size = 0
spfile =

C:\ORACLE\APP\ORACLE\PRODUCT\10.2.0\SERVER\DBS\SPFILEXE.ORA
sga_target = 146800640
control_files = C:\ORACLE\ORADATA\XE\CONTROL.DBF
__db_cache_size = 58720256
compatible = 10.2.0.1.0
db_recovery_file_dest = C:\Oracle\app\oracle\flash_recovery_area
db_recovery_file_dest_size= 10737418240
undo_management = AUTO
undo_tablespace = UNDO
remote_login_passwordfile= EXCLUSIVE
dispatchers = (PROTOCOL=TCP) (SERVICE=XEXDB)
shared_servers = 4
job_queue_processes = 4
audit_file_dest = C:\ORACLE\APP\ORACLE\ADMIN\XE\ADUMP
background_dump_dest = C:\ORACLE\APP\ORACLE\ADMIN\XE\BDUMP
user_dump_dest = C:\ORACLE\APP\ORACLE\ADMIN\XE\UDUMP
core_dump_dest = C:\ORACLE\APP\ORACLE\ADMIN\XE\CDUMP
db_name = XE
open_cursors = 300
os_authent_prefix =
pga_aggregate_target = 16777216
PMON started with pid=2, OS id=2508
PSP0 started with pid=3, OS id=624
MMAN started with pid=4, OS id=3476
DBW0 started with pid=5, OS id=1600
LGWR started with pid=6, OS id=1112
CKPT started with pid=7, OS id=188
SMON started with pid=8, OS id=192
RECO started with pid=9, OS id=2592
CJQ0 started with pid=10, OS id=2596
MMON started with pid=11, OS id=1604
Fri Sep 25 01:39:12 2009
starting up 1 dispatcher(s) for network address

'(ADDRESS=(PARTIAL=YES)(PROTOCOL=TCP))'...
MMNL started with pid=12, OS id=836
Fri Sep 25 01:39:12 2009
starting up 4 shared server(s) ...
Oracle Data Guard is not available in this edition of Oracle.
Fri Sep 25 01:39:13 2009
ALTER DATABASE MOUNT
Fri Sep 25 01:39:17 2009
Setting recovery target incarnation to 2
Fri Sep 25 01:39:17 2009
Successful mount of redo thread 1, with mount id 2579598593
Fri Sep 25 01:39:17 2009
Database mounted in Exclusive Mode
Completed: ALTER DATABASE MOUNT
Fri Sep 25 01:39:28 2009
drop database
Fri Sep 25 01:39:28 2009
Deleted file C:\ORACLE\ORADATA\XE\SYSTEM.DBF
Deleted file C:\ORACLE\ORADATA\XE\UNDO.DBF
Deleted file C:\ORACLE\ORADATA\XE\SYSAUX.DBF
Deleted file C:\ORACLE\ORADATA\XE\USERS.DBF
Deleted Oracle managed file

C:\ORACLE\APP\ORACLE\FLASH_RECOVERY_AREA\XE\ONLINELOG\O1_MF_1_358MH2PR_.LOG
Deleted Oracle managed file
C:\ORACLE\APP\ORACLE\FLASH_RECOVERY_AREA\XE\ONLINELOG\O1_MF_2_358MH9KW_.LOG
Deleted file C:\ORACLE\ORADATA\XE\TEMP.DBF
Instance terminated by USER, pid = 1896
Deleted file C:\ORACLE\ORADATA\XE\CONTROL.DBF
Completed: drop database
Fri Sep 25 01:39:34 2009
Shutting down instance (abort)
License high water mark = 1




Finally, I found this at 'C:\Oracle\app\oracle\product\10.2.0\server\log\winxpdev\client\css.txt':


2009-09-25 01:08:03.963: [ OCROSD][228]utgdv:1:could not open registry key SOFTWARE\Oracle\ocr os error The system could not find theenvironment option that was entered.

Quote:
[ OCRUTL][228]u_set_gbl_comp_error: Parameter was NULL
[ OCRUTL][228]u_set_gbl_comp_error: Parameter was NULL
2009-09-25 01:08:03.963: [ OCRRAW][228]proprinit: Could not open raw device
2009-09-25 01:08:03.963: [ default][228]a_init:7!: Backend init
unsuccessful : [33]
[ OCRUTL][228]u_set_ocr_error: Parameter was NULL
2009-09-25 01:08:03.963: [ CSSCLNT][228]clsssinit: error(33 ) in OCR initialization



Like I said, I could really use help trying to fix this. I need a way to get it back how it was before I did the "DROP database". I tried to do the FLASHBACK but there was no backup file in the directory, same issue trying RMAN.

However, there is a Batch file called "Backup" in this directory: 'C:\Oracle\app\oracle\product\10.2.0\server\BIN'.
I do not know if this will even be helpful, but I am just trying to give as much information as I can.

I know this was a stupid mistake, but I am still learning and need insight. Please let me know of any suggestions or solutions you may have.


Best Regards,
Jason

[Updated on: Fri, 25 September 2009 04:09]

Report message to a moderator

Re: ORA-01034: Oracle Not Available - I know what I did, but I don't know how to fix it [message #423629 is a reply to message #423539] Fri, 25 September 2009 11:29 Go to previous message
Mahesh Rajendran
Messages: 10671
Registered: March 2002
Location: oracleDocoVille
Senior Member
Account Moderator
I believe, you got confused with MySQL and Oracle concepts.
In Oracle , multiple users/schema are in the same database.
Unfortunately, you have used the best command to drop a database cleanly (drop database).
Usually, unless you have taken some sought of backup, it is impossible to restore and recover.
It depends on how you would have configured Oracle XE during installation (archive log mode, autobackups etc).
Provided above are configured, the steps outlined here in documentation should work.
http://download.oracle.com/docs/cd/B25329_01/doc/admin.102/b25107/backrest.htm#CIHHBDDG

I am not an XE user myself and have not tried these before.
Good luck!.
Previous Topic: target database name does not match name in recovery catalog
Next Topic: Recovering a lost database
Goto Forum:
  


Current Time: Sat Oct 01 11:00:24 CDT 2016

Total time taken to generate the page: 0.15887 seconds